X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Proxy Authorization Required. Firefox does not ask for a proxy username and password.

Kuphostiwe

I am using firefox on mac with manual proxies and have provided the proxy address and port. I have set the proxy in Firefox->Preferences->Advanced->Network. This proxy requires authentication But firefox does not prompt me for credentials of this proxy. It just throws a page that says "Proxy Authorization Required" and "Description: Authorization is required for access to this proxy"

I have tried the following to no effect. 1) Clearing all the profiles in ~/Library/Profiles folders 2) Clearing profiles.ini file. 3) Setting the proxy along with username and password in System preferences and make firefox use system proxies instead of manual proxies.

Right now I am downloading firefox 13 beta to see if this solves the problem. Any workaround available for FF12.0?


Any help is greatly appreciated.

Thanks.


EDIT:: Tried with FF 13 beta. Same problem

I am using firefox on mac with manual proxies and have provided the proxy address and port. I have set the proxy in Firefox->Preferences->Advanced->Network. This proxy requires authentication But firefox does not prompt me for credentials of this proxy. It just throws a page that says "Proxy Authorization Required" and "Description: Authorization is required for access to this proxy" I have tried the following to no effect. 1) Clearing all the profiles in ~/Library/Profiles folders 2) Clearing profiles.ini file. 3) Setting the proxy along with username and password in System preferences and make firefox use system proxies instead of manual proxies. Right now I am downloading firefox 13 beta to see if this solves the problem. Any workaround available for FF12.0? Any help is greatly appreciated. Thanks. EDIT:: Tried with FF 13 beta. Same problem

Okulungisiwe ngu Sanjay

Isisombululo esikhethiwe

I managed to solve this one. Just set the following values to false in about:config.

  1. network.automatic-ntlm-auth.allow-proxies
  2. network.negotiate-auth.allow-proxies

Hope this helps someone out there :).

Funda le mpendulo ngokuhambisana nalesi sihloko 14

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

Not sure

Fakela amapulagi

  • Displays Java applet content, or a placeholder if Java is not installed.
  • WebEx64 General Plugin Container Version 203
  • Shockwave Flash 11.1 r102
  • Apple Connect Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0

Eminye Imininingwane

Application Basics
Name
Firefox
Version
12.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20120420145725
browser.startup.homepage_override.mstone
rv:12.0
extensions.lastAppVersion
12.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Vendor ID
0x8086
Device ID
0x 116
WebGL Renderer
ATI Technologies Inc. -- ATI Radeon HD 6750M OpenGL Engine -- 2.1 ATI-7.12.9
GPU Accelerated Windows
1/1 OpenGL
AzureBackend
quartz

Isisombululo Esikhethiwe

I managed to solve this one. Just set the following values to false in about:config.

  1. network.automatic-ntlm-auth.allow-proxies
  2. network.negotiate-auth.allow-proxies

Hope this helps someone out there :).

I managed to solve this one. Just set the following values to '''false''' in about:config. #''''' network.automatic-ntlm-auth.allow-proxies''''' #''''' network.negotiate-auth.allow-proxies''''' Hope this helps someone out there :).

Okulungisiwe ngu Sanjay

bruce.hodge 0 izisombululo 2 izimpendulo
Kuphostiwe

The problem still exists in FF15 on the MAC. The ntml fix works, but it would be nice if it worked out of the box. Is there a way to make the change and package FF up for redistribution with network.automatic-ntlm-auth.allow-proxies = False ?

The problem still exists in FF15 on the MAC. The ntml fix works, but it would be nice if it worked out of the box. Is there a way to make the change and package FF up for redistribution with network.automatic-ntlm-auth.allow-proxies = False ?
cor-el
  • Top 10 Contributor
  • Moderator
17526 izisombululo 158458 izimpendulo
Kuphostiwe

Use a mozilla.cfg file in the Firefox program folder to lock prefs or specify new (default) values.

Place a file local-settings.js in the defaults/pref folder where you also find the file channel-prefs.js to specify using mozilla.cfg.

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0); // use this to disable the byte-shift

See:

You can use these functions in mozilla.cfg:

defaultPref();  // set new default value
pref();         // set pref, but allow changes in current session
lockPref();     // lock pref, disallow changes
Use a mozilla.cfg file in the Firefox program folder to lock prefs or specify new (default) values. Place a file local-settings.js in the defaults/pref folder where you also find the file channel-prefs.js to specify using mozilla.cfg. pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0); // use this to disable the byte-shift See: *http://kb.mozillazine.org/Locking_preferences You can use these functions in mozilla.cfg: defaultPref(); // set new default value pref(); // set pref, but allow changes in current session lockPref(); // lock pref, disallow changes
bruce.hodge 0 izisombululo 2 izimpendulo
Kuphostiwe

Thanks Cor-el, A little more info if anyone is trying to fix the original bug. If the Blue coat proxy is set to authenticate via LDAP it works no problem. If the blue coat is set to IWA and use AD it doesn't work. The browser is either having issues with the hand over from one auth method to the other or it doesn't like the AD method????

Thanks Cor-el, A little more info if anyone is trying to fix the original bug. If the Blue coat proxy is set to authenticate via LDAP it works no problem. If the blue coat is set to IWA and use AD it doesn't work. The browser is either having issues with the hand over from one auth method to the other or it doesn't like the AD method????