X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

What should I do when I see an error message saying "Firefox service initialization failed" ?

Kuphostiwe

I have updated to Firefox 11.0 today. I had been using Xmarks well but suddenly I have not been able to synchronize bookmarks from a couple of days ago.

I clicked "Synchronize Now" button on Xmarks Settings and I saw

"Synchronizing...." message. But later it showed a message under current status reading "Problem Synching, Firefox initialization failed. Firefox reports that some required services are unavailable.Please visit our help page for instructions."

And I have tried Xmarks Setup Wizard also. The wizard says "Xmarks will synchronize your bookmarks.Xmarks will now merge your data,starting with your server data." Later It showed an error message reading "Xmarks-Synchronization failed.Error is Firefox service initialization failed."

Please let me know how to solve the problem.

Nicolai,

I have updated to Firefox 11.0 today. I had been using Xmarks well but suddenly I have not been able to synchronize bookmarks from a couple of days ago. I clicked "Synchronize Now" button on Xmarks Settings and I saw "Synchronizing...." message. But later it showed a message under current status reading "Problem Synching, Firefox initialization failed. Firefox reports that some required services are unavailable.Please visit our help page for instructions." And I have tried Xmarks Setup Wizard also. The wizard says "Xmarks will synchronize your bookmarks.Xmarks will now merge your data,starting with your server data." Later It showed an error message reading "Xmarks-Synchronization failed.Error is Firefox service initialization failed." Please let me know how to solve the problem. Nicolai,

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.1 r102
  • Google Update
  • Mozilla Plugin
  • Version 0.9.19, Copyright 2006-2012 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • Aosmgr Plugin Module
  • npxwebplugin_file v.7.2.5.5
  • npxwebplugin v.7.2.5.5
  • NPTEWEB Dynamic Link Library
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • rexpert 3.0 plugin viewer
  • Version 2.6.1.5251
  • Google Talk Plugin Video Accelerator version:0.1.44.14
  • npEfdsWPlugin DLL
  • WIZVERA Delfino1.0.4.3
  • npxwfile
  • npxecure v.7.0.0.0
  • 5.0.61118.0
  • npINISAFEWeb60
  • INISAFE CrossWeb NP Plugin version:6.4.0.31
  • AhnLab Online Security
  • SBS Starter ActiveX Control Module
  • TouchEn Key for Multi-Browser
  • Space International - EasyKeytec-plugin v2011.9.8.2
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • gomtvx NIE Module
  • iTunes Detector Plug-in
  • MarkAny FPS Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPSKComm v.8.2.2.2
  • OZReport Viewer plugin (Gecko Version: 1.8b1)
  • OZTransferX plugin (Gecko Version: 1.8b1)
  • OZApplication Viewer plugin (Gecko Version: 1.8b1)
  • Veraport Mozilla Plugin (1002)
  • 2,5,3,1
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • np-mswmp

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0

Eminye Imininingwane

I am using Windows XP Home Edition Service Pack 3 as OS.

Vivek 289 izisombululo 2084 izimpendulo
Kuphostiwe

Hi,

You can try to Remove Xmarks in Tools (Alt + T) > Add-ons > Extensions and then reinstall it via the search box on the top right or from AMO.

Before that, please also see this.

Support

Hi, You can try to '''Remove''' Xmarks in '''Tools''' ('''Alt''' + '''T''') > '''Add-ons''' > '''Extensions''' and then reinstall it via the search box on the top right or from [https://addons.mozilla.org/en-US/firefox/addon/xmarks-sync/?src=search AMO]. Before that, please also see [http://helpdesk.xmarks.com/troubleshooting/sending-us-your-log-file/ this]. [https://www.xmarks.com/about/help Support]

Umnikazi wombuzo

Hi, I had already tried what you suggested before I first posted the previous question. I have tried them today again but the result was the same as before. Removing and reinstalling the Xmarks did not seem to work in my case.

I have even deleted and reinstalled the Firefox browser but the result was still the same.

I synchronized bookmarks successfully with Xmarks server in Google Chrome web browser.

I do not know why it does not work with Firefox suddenly.

Will some part of my logfile help solve the problem ? (Does the "failed to initialize bmsvc or tsvc..." mean anything ?)

Would I be better to change my default browser or the bookmark add-on ?



[2012-03-23 19:03:29] Returned error: Firefox service initialization failed(6)
[2012-03-26 14:00:48] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({})
[2012-03-26 14:00:49] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({})
[2012-03-26 14:05:48] ------ Xmarks/4.0.6 (/Places) starting download with sync.xmarks.com ------
[2012-03-26 14:05:48] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({})
[2012-03-26 14:05:48] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({})
[2012-03-26 14:16:14] Returned error: Cancelled by user(2)
[2012-03-26 14:55:15] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({})
[2012-03-26 14:55:15] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({})
[2012-03-26 14:55:15] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({})
[2012-03-26 14:55:15] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({})
[2012-03-26 15:01:32] ------ Xmarks/4.0.6 (/Places) starting getTurboTags with api.xmarks.com ------
[2012-03-26 15:01:32] >>> POST https://api.xmarks.com/internal/topics_review/read
[2012-03-26 15:01:32] >>> Body is: {"urls":["https://login.xmarks.com/?referrer=https%3A%2F%2Fmy.xmarks.com%2F"],"mid":"gfi1o9rx","apihost":"api.xmarks.com","drifthost":"www.xmarks.com","statichost":"static.xmarks.com","cid":"xmfx"}
[2012-03-26 15:01:33] >>> Callback ({status:0, buildtime:"201101211627", urls:{'https://login.xmarks.com/?referrer=https%3A%2F%2Fmy.xmarks.com%2F':{topics:[["xmarks", 2417], ["bookmark sync", 592], ["synchronization", 1017], ["bookmarking", 584], ["firefox addons", 1480], ["mozilla addons", 275], ["addons", 863], ["browsers", 368], ["extensions", 453], ["internet tools", 582]], url_id:147088861, user_count:1600, review:{numratings:1533, userreview:null, locked:0, avgrating:4.6249, userrating:null}}}, fb_session:false})
[2012-03-26 15:02:00] ------ Xmarks/4.0.6 (/Places) starting getrevisions with sync.xmarks.com ------
[2012-03-26 15:02:00] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({})
[2012-03-26 15:02:00] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({})
[2012-03-26 15:02:00] >>> POST https://sync.xmarks.com/sync/bookmarks/getrevisions
[2012-03-26 15:02:00] >>> Body is: {"limit":50,"log":{"mid":"gfi1o9rx","serp":0,"ssEnabled":false,"sbsEnabled":true}}
[2012-03-26 15:02:01] >>> Callback ({username:"Nicolai3", status:0, toprev:583, revisions:[{created:1262580203, 


=
Hi, I had already tried what you suggested before I first posted the previous question. I have tried them today again but the result was the same as before. Removing and reinstalling the Xmarks did not seem to work in my case. I have even deleted and reinstalled the Firefox browser but the result was still the same. I synchronized bookmarks successfully with Xmarks server in Google Chrome web browser. I do not know why it does not work with Firefox suddenly. Will some part of my logfile help solve the problem ? (Does the "failed to initialize bmsvc or tsvc..." mean anything ?) Would I be better to change my default browser or the bookmark add-on ? ------------ <pre><nowiki> [2012-03-23 19:03:29] Returned error: Firefox service initialization failed(6) [2012-03-26 14:00:48] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({}) [2012-03-26 14:00:49] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({}) [2012-03-26 14:05:48] ------ Xmarks/4.0.6 (/Places) starting download with sync.xmarks.com ------ [2012-03-26 14:05:48] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({}) [2012-03-26 14:05:48] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({}) [2012-03-26 14:16:14] Returned error: Cancelled by user(2) [2012-03-26 14:55:15] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({}) [2012-03-26 14:55:15] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({}) [2012-03-26 14:55:15] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({}) [2012-03-26 14:55:15] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({}) [2012-03-26 15:01:32] ------ Xmarks/4.0.6 (/Places) starting getTurboTags with api.xmarks.com ------ [2012-03-26 15:01:32] >>> POST https://api.xmarks.com/internal/topics_review/read [2012-03-26 15:01:32] >>> Body is: {"urls":["https://login.xmarks.com/?referrer=https%3A%2F%2Fmy.xmarks.com%2F"],"mid":"gfi1o9rx","apihost":"api.xmarks.com","drifthost":"www.xmarks.com","statichost":"static.xmarks.com","cid":"xmfx"} [2012-03-26 15:01:33] >>> Callback ({status:0, buildtime:"201101211627", urls:{'https://login.xmarks.com/?referrer=https%3A%2F%2Fmy.xmarks.com%2F':{topics:[["xmarks", 2417], ["bookmark sync", 592], ["synchronization", 1017], ["bookmarking", 584], ["firefox addons", 1480], ["mozilla addons", 275], ["addons", 863], ["browsers", 368], ["extensions", 453], ["internet tools", 582]], url_id:147088861, user_count:1600, review:{numratings:1533, userreview:null, locked:0, avgrating:4.6249, userrating:null}}}, fb_session:false}) [2012-03-26 15:02:00] ------ Xmarks/4.0.6 (/Places) starting getrevisions with sync.xmarks.com ------ [2012-03-26 15:02:00] Failed to initialize ["bmsvc", "@mozilla.org/browser/nav-bookmarks-service;1", ({})]: error is ({}) [2012-03-26 15:02:00] Failed to initialize ["tsvc", "@mozilla.org/browser/tagging-service;1", ({})]: error is ({}) [2012-03-26 15:02:00] >>> POST https://sync.xmarks.com/sync/bookmarks/getrevisions [2012-03-26 15:02:00] >>> Body is: {"limit":50,"log":{"mid":"gfi1o9rx","serp":0,"ssEnabled":false,"sbsEnabled":true}} [2012-03-26 15:02:01] >>> Callback ({username:"Nicolai3", status:0, toprev:583, revisions:[{created:1262580203, </nowiki></pre> ===========

Okulungisiwe ngu cor-el

Vivek 289 izisombululo 2084 izimpendulo
Kuphostiwe

Please see this. If you click on the I'm getting a 'Sync Error'! link, you would get a pop-up and further helpful instructions.

You can also try to check in a new profile, after installing only the Xmarks extension. If the problem persists, please also try to temporarily stop any security software to check the Xmarks sync. If the new profile is okay, you can later copy the needed personal data from the old profile. Firefox stores your personal data and settings in another location (profile folder) separate from its files/folder. A new profile would have the default Firefox settings (Tools (Alt + T) > Options, and about:config ), and usually would also be empty of any Extensions and themes (Appearance) in Tools > Add-ons) and their settings. Also, a new profile would have no previous stored website data/settings etc., (Tools > Clear Recent History).

Profiles Howto

Profile Folder & Files

about:config Entries

Please see [https://www.xmarks.com/about/help this]. If you click on the '''I'm getting a 'Sync Error'!''' link, you would get a pop-up and further helpful instructions. You can also try to check in a [https://support.mozilla.org/en-US/kb/Managing-profiles new profile], after installing only the Xmarks extension. If the problem persists, please also try to temporarily stop any security software to check the Xmarks sync. If the new profile is okay, you can later [https://support.mozilla.org/en-US/kb/Recovering%20important%20data%20from%20an%20old%20profile?s=profile&r=1&e=sph&as=s copy the needed personal data] from the old profile. Firefox stores your personal data and settings in [http://kb.mozillazine.org/Profile_folder another location (profile folder)] separate from its [http://kb.mozillazine.org/Installation_directory files/folder]. A new profile would have the default Firefox settings ('''Tools''' ('''Alt''' + '''T''') > [https://support.mozilla.org/en-US/kb/Options%20window '''Options'''], and [http://kb.mozillazine.org/About:config about:config] ), and usually would also be empty of any '''Extensions''' and themes ('''Appearance''') in Tools > Add-ons) and their settings. Also, a new profile would have no previous stored website data/settings etc., ('''Tools''' > [https://support.mozilla.org/en-US/kb/Clear%20Recent%20History '''Clear Recent History''']). [https://support.mozilla.org/en-US/kb/Profiles?s=profile&r=2&e=sph&as=s Profiles Howto] [http://kb.mozillazine.org/Profile_folder_-_Firefox Profile Folder & Files] [http://kb.mozillazine.org/About:config_entries about:config Entries]

Umnikazi wombuzo

I emailed my log file to support@xmarks.com .

But based on the facts that - xmarks extension in Chrome synchronizes well. - the error message says "Firefox initialization failed. Firefox reports that some

 required services are unavailable."

I still think my problem will be on the Firefox browser.

Thanks anyway Vivek.Wilfred.

I emailed my log file to support@xmarks.com . But based on the facts that - xmarks extension in Chrome synchronizes well. - the error message says "Firefox initialization failed. Firefox reports that some required services are unavailable." I still think my problem will be on the Firefox browser. Thanks anyway Vivek.Wilfred.
Vivek 289 izisombululo 2084 izimpendulo
Kuphostiwe

You can also try a new profile and install only Xmarks in the new profile. This would help to determine if any other add-ons are interfering. Before creating the new profile and installing Xmarks, please also try disabling any security software for a few minutes.

You can also try a [https://support.mozilla.org/en-US/kb/Managing-profiles new profile] and install only Xmarks in the new profile. This would help to determine if any other add-ons are interfering. Before creating the new profile and installing Xmarks, please also try disabling any security software for a few minutes.

Umnikazi wombuzo

I created a new profile and Xmarks bookmarks synching succeeded. But I could not find the new profile in my computer fold(C\Documents and Settings\(User)\Application Data\Mozilla\Firefox\Profiles).

If I could locate the new profile folder like "xxxxxxxx.default user" I could use previous settings like "searchplugins" etc. .

I created a new profile and Xmarks bookmarks synching succeeded. But I could not find the new profile in my computer fold(C\Documents and Settings\(User)\Application Data\Mozilla\Firefox\Profiles). If I could locate the new profile folder like "xxxxxxxx.default user" I could use previous settings like "searchplugins" etc. .
Vivek 289 izisombululo 2084 izimpendulo
Kuphostiwe

You can also open the profile folder via Firefox Help (Alt + H) > Troubleshooting Information > Open Containing Folder. The new profile would have a different name from the xxxxxxxx.default user. If you are unable to find the folder, please see this.

You can also open the profile folder via Firefox '''Help''' ('''Alt''' + '''H''') > '''Troubleshooting Information''' > '''Open Containing Folder'''. The new profile would have a different name from the xxxxxxxx.default user. If you are unable to find the folder, please see [https://support.mozilla.org/en-US/questions/916668#answer-305338 this].