X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FF 11 not showing Google Calendar unless logged in

Kuphostiwe

Only happens in FF 11. Clearing cache and cookies doesn't help. Disabling add-ons doesn't help. If you're logged in to gmail, calendar loads fine until you delete the login cookie.

Jon

Only happens in FF 11. Clearing cache and cookies doesn't help. Disabling add-ons doesn't help. If you're logged in to gmail, calendar loads fine until you delete the login cookie. Jon

Eminye Imininingwane Yohlelo

Amasayithi athintekayo

http://

Fakela amapulagi

  • Version 2.7.6.6619
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.1 r102
  • Google Update
  • 4.1.10111.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • NPWLPG
  • GEPlugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

Eminye Imininingwane

Nathan2055 11 izisombululo 110 izimpendulo
Kuphostiwe

Calender is a Google service that requires you to be logged in. Can you be more specific?

Calender is a Google service that requires you to be logged in. Can you be more specific?

Umnikazi wombuzo

There's a pubic sharing option that I've always used. It always worked until upgrading to FF 11 last night. It continues to work in all other browsers. Now it only shows in FF 11 when you've logged in to calendar.google.com and fails again after the google login cookie is removed.

Try this in FF 11 and other browsers:

https://www.google.com/calendar/embed?src=o8ckatic024amcgkdo1qd2vf0c%40group.calendar.google.com

Jon

There's a pubic sharing option that I've always used. It always worked until upgrading to FF 11 last night. It continues to work in all other browsers. Now it only shows in FF 11 when you've logged in to calendar.google.com and fails again after the google login cookie is removed. Try this in FF 11 and other browsers: https://www.google.com/calendar/embed?src=o8ckatic024amcgkdo1qd2vf0c%40group.calendar.google.com Jon

Okulungisiwe ngu bigjon321

Umnikazi wombuzo

UPDATE

FF 11 fails to load the publicly shared Google Calendar after deleting the google.com "S" cookie (which is set only when logging in to calendar.google.com).

Jon

UPDATE FF 11 fails to load the publicly shared Google Calendar after deleting the google.com "S" cookie (which is set only when logging in to calendar.google.com). Jon
Nathan2055 11 izisombululo 110 izimpendulo
Kuphostiwe

Sorry about the wait, I had some backend PC issues. Anyway, I am running FF11 and the calender loads fine for me. Please clear your cache and tell me whether this fixes your issue.

Sorry about the wait, I had some backend PC issues. Anyway, I am running FF11 and the calender loads fine for me. Please [[How to clear the cache|clear your cache]] and tell me whether this fixes your issue.

Umnikazi wombuzo

As I said originally, I did that. Clear your google.com cookies and try again.

Jon

As I said originally, I did that. Clear your google.com cookies and try again. Jon
jscher2000
  • Top 10 Contributor
8763 izisombululo 71700 izimpendulo
Kuphostiwe

Link works for me. Close page, clear google.com cookies, click link again, works again.

Do you have any recently created or updated privacy-related add-ons that could be relevant? To bypass add-ons, you could try starting Firefox in Safe Mode.

First, save any work (e.g., email messages you're composing, purchases). Then use Help > Restart with Add-ons Disabled. In the Safe Mode dialog, don't check any boxes, simply click the Continue in Safe Mode button.

Does that make any difference?

Link works for me. Close page, clear google.com cookies, click link again, works again. Do you have any recently created or updated privacy-related add-ons that could be relevant? To bypass add-ons, you could try starting Firefox in [http://support.mozilla.com/kb/Safe+Mode Safe Mode]. First, save any work (e.g., email messages you're composing, purchases). Then use Help > Restart with Add-ons Disabled. In the Safe Mode dialog, don't check any boxes, simply click the Continue in Safe Mode button. Does that make any difference?

Umnikazi wombuzo

No. Same as when I tried that earlier. It all centers around a couple google.com cookies, but there may be others as well (gmail, etc.).

It appears that google is using a user-agent string to decide what calendar app to give me, but if google sees a certain couple of cookies, it doesn't use that user-agent string in the same way.

Jon

No. Same as when I tried that earlier. It all centers around a couple google.com cookies, but there may be others as well (gmail, etc.). It appears that google is using a user-agent string to decide what calendar app to give me, but if google sees a certain couple of cookies, it doesn't use that user-agent string in the same way. Jon

Umnikazi wombuzo

"Link works for me. Close page, clear google.com cookies, click link again, works again."

Me, too... until I refresh.

Jon

"Link works for me. Close page, clear google.com cookies, click link again, works again." Me, too... until I refresh. Jon
cor-el
  • Top 10 Contributor
  • Moderator
17530 izisombululo 158511 izimpendulo
Kuphostiwe

Does it work if you temporarily switch to Private Browsing mode?

That should give you a fresh set of cookies.

Flipping the "Always use private browsing mode" setting should be sufficient to test that.

  • Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • [ ] "Always use private browsing mode"
Does it work if you temporarily switch to Private Browsing mode? *https://support.mozilla.org/kb/Private+Browsing That should give you a fresh set of cookies. Flipping the "Always use private browsing mode" setting should be sufficient to test that. *Tools > Options > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> *[ ] "Always use private browsing mode"

Umnikazi wombuzo

No, sorry. No google.com cookie appears.

Update:

After about 20 refreshes, a google.com "S" cookie appeared, the calendar loaded, and nuking said cookie reverted to inability to load the calendar. and no cookie being set.

Jon

No, sorry. No google.com cookie appears. Update: After about 20 refreshes, a google.com "S" cookie appeared, the calendar loaded, and nuking said cookie reverted to inability to load the calendar. and no cookie being set. Jon

Umnikazi wombuzo

I did it again... this time it took 6 refreshes to make the cookie appear and the calendar load.

Jon

I did it again... this time it took 6 refreshes to make the cookie appear and the calendar load. Jon
Nathan2055 11 izisombululo 110 izimpendulo
Kuphostiwe

I'm sorry no one has responded before now. If you are still having this problem, please try running your browser in safe mode by following these instructions. This may fix your problem, as it will reset several settings that could be causing trouble. Also, please reset your theme to the default one by clicking Firefox > Add-ons > Appearance. This may fix your problem.

I'm sorry no one has responded before now. If you are still having this problem, please try running your browser in safe mode by following [[Safe mode|these instructions]]. This may fix your problem, as it will reset several settings that could be causing trouble. Also, please reset your theme to the default one by clicking Firefox > Add-ons > Appearance. This may fix your problem.