Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

IE works but Firefox and Chrome does not. At first, the message stated that the browser could not find the site. Now it does nothing. I enter a URL, hit Enter and nothing happens. The refresh button is not active. Any ideas?

  • 6 uphendule
  • 11 zinale nkinga
  • 15315 views
  • Igcine ukuphendulwa ngu mannietree

more options

Toshiba A660 laptop Windows 7 Home Premium Firefox 10 Windows Firewall

All Replies (6)

more options

Is the problem that Firefox (and Chrome) won't load any websites, even your home page or pages opened from your bookmarks? In that case, see this article:

Is the problem just entering URLs in the address bar? In that case, it may be an extension causing it (the same extension may also affect Chrome, not sure):


Pressing Enter in the address bar doesn't work

The AVG Safe Search extension is causing an issue where pressing Enter when trying to go to a website does not work. You have to click the green go arrow instead. Until this is resolved you can work around this issue by disabling the extension:

  1. At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP), and then click Add-ons. The Add-ons Manager tab will open.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Click Disable button next to the AVG Safe Search extension to disable it.
  4. Click Restart Firefox.

For more information, see Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.


Ref:

more options

Thanks Alice. No websites open and I tried everything in the recommended article and nothing changed. i have no extensions, so the extension isn't causing a problem. The other thing I found was that the printer does not recognize the wifi. So it makes me think it is related to the firewall but when I shut off the firewall, nothing changes either. I am confused.

more options

I don't know about wifi printer issue so I can't help with that but if both Firefox and Chrome won't connect to the Internet, it might be a software firewall or other Internet security software that is affecting both Chrome and Firefox but not Internet Explorer. See the Configure firewalls so that Firefox can access the Internet article. Please list all Internet Security applications you have running (Inoticed a McAfee product in your Plugins list).

more options

Do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

See also:

more options

I should have asked earlier, did you ever have a Norton product like Norton 360 or Norton Internet Security installed, even a trial version, and then removed it? I found this with a google search: http://forums.techguy.org/web-email/927729-solved-ie-works-but-opera.html (2 page thread). If so, you can download a Norton Removal Tool using IE and save it to your desktop, then close IE and run the removal tool.

Ref: http://kb.mozillazine.org/Firewalls#Norton_firewalls_from_Symantec


Important: Even after all Norton products are uninstalled, a driver or kernel service (e.g., SYMTDI) can be left behind that blocks Internet access. The EnumProcess tool can be used to detect all firewall processes and servies. A removal tool can be downloaded from Symantec to completely remove Norton products from your computer.


more options

Thanks everyone. I have looked for all my firewalls manually and using EnumProcess toll. There are the Windows firewall, Windows Defender (not on) and Ad-Aware which I just added. The Window Firewall has been configured to allow Firefox and Chrome. My plug-ins list was inaccurate. I checked and here is the correct list: Adobe Acrobat, Google Update, Microsoft Office 2010, NVideo 3D Vision, Shockwave Flash, Silverlight and Windows Live Photo Gallery. I scanned for malware using Microsoft Security Essentials, malwarebytes, ad-aware and superantispyware. All that was found were some tracking cookies. I could not install Spy=bot. Confused and frustrated.