Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to disable Google Safe Browsing

  • 1 baphendule
  • 5 zinale nkinga
  • 2624 views
  • Igcine ukuphendulwa ngu SafeBrowser

more options

There is a red window that pops up saying certain sites are "attack" sites, and it is super annoying. Supposedly it is another one of Google's brainiac schemes called "safe browsing". I don't want it, it's blocking some of my favourite sites but I can't seem to get rid of it. How do I disable/remove/delete the bleeping thing?

Isisombululo esikhethiwe

Google Safe Browsing has been a part of Firefox for a very long time to protect users from known malware and phishing sites. It is not part of Google's recent policy change that many users are misunderstanding; the new Google policy change affects only Google products/services in which users must sign-in or log-in (i.e., you, the user, have established an account for that service).

Information about Safe Browsing: https://www.mozilla.org/en-US/firefox/phishing-protection/ (read all sections and follow links within sections regarding your privacy)

Sample warnings. You can click on "Why is this page blocked" on these screens to discover why the page is being blocked.

You can turn off the warnings at your own risk:

  • Firefox button > Options > Options (or Tools > Options) > Security, un-check both "Block reported attack sites" and "Block reported web forgeries"


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (1)

more options

Isisombululo Esikhethiwe

Google Safe Browsing has been a part of Firefox for a very long time to protect users from known malware and phishing sites. It is not part of Google's recent policy change that many users are misunderstanding; the new Google policy change affects only Google products/services in which users must sign-in or log-in (i.e., you, the user, have established an account for that service).

Information about Safe Browsing: https://www.mozilla.org/en-US/firefox/phishing-protection/ (read all sections and follow links within sections regarding your privacy)

Sample warnings. You can click on "Why is this page blocked" on these screens to discover why the page is being blocked.

You can turn off the warnings at your own risk:

  • Firefox button > Options > Options (or Tools > Options) > Security, un-check both "Block reported attack sites" and "Block reported web forgeries"


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.