Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox crashes due to AccessibleMarshal.dll

  • 15 uphendule
  • 6 zinale nkinga
  • Igcine ukuphendulwa ngu 44mayg

more options

Downloaded and installed newest Firefox version last night. Installed on Toshiba laptop, Win XP SP2, runs fine. Tried to install on Dell with same operating system, gives error instantly when trying to start with message:

firefox.exe application error the application failed to initialize properly (0x0150004) click on OK to terminate the application.

Looking at the install log for the Toshiba shows:

Registered: C:\Program Files\Mozilla Firefox\AccessibleMarshal.dll

But for the Dell it shows:

ERROR Registering: C:\Program Files\Mozilla Firefox\AccessibleMarshal.dll

Could this be the problem, not registering the DLL?

Okulungisiwe ngu NoahSUMO

All Replies (15)

more options

Do a clean (re)install and delete the Firefox program folder (C:\Program Files\Mozilla Firefox\).

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible.

  • Do NOT remove personal data when you uninstall the current version or you lose your bookmarks and other data because all profile folders will be removed.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

more options

Thanks for the reply Cor-el

Referring to Errors:

On Start (firefox.exe application error the application failed to initialize properly (0x0150004) click on OK to terminate the application)


In Install Log (ERROR Registering: C:\Program Files\Mozilla Firefox\AccessibleMarshal.dll)

I tried all that, but to no avail. The download I used for install on the Dell (which gave the above error) is the same download I used to install on the Toshiba, which is working fine. I'm downloading the install file again on another computer right now to give it another shot at install on the Dell, but I'm not counting on it to work. I got no error messages on install or uninstall. Only when I tried to run it, the above error message came up almost instantly. I checked the Toshiba registry for any instances of the AccessibleMarshal.DLL and found two, but I haven't checked the registry on the Dell yet.

more options

Well, no go on the second download, same exact error message. Didn't think it would make a difference but had to take the shot. And I had even tried to register the DLL earlier in the day before trying the second download/install. I'm stumped, never seen anything like this. I wonder if I have some kind of service disabled causing it.

more options

Anybody???? I even did what I have never done........ installed a BETA version of something, BETA Firefox. Still exact same error, no load message.

more options

You did make sure that you removed the entire Firefox program folder?

more options

I'm no hacker, but far from a rookie. Did all the above, and more. Downloading the BETA was like a last ditch effort, but exact same error message and the DLL not registered. Even tried to register it manually several times with the the executes in all Firefox folders, no go. Not sure what the dependency is, but the DLL might be the key to getting it to run.

more options

I guess since the experts can't answer it, I don't feel so stupid.

more options

Are these two platforms both either 32 or 64bit OS?

more options

Both are NTFS, but not sure 32 or 64 bit. Looked at system properties and other areas, but can't find that detail. I know, I should know it or be able to find it, but I'm vapor locking on how to get that particular info.

more options

No problem, you could look here for the means:;en-us;827218 Cheers---

more options

Thanks for the reply thc4fox.

Both are WinXP sp2 (x86), 32 bit. If that is the deciding factor, it should load on both.

more options

I am not an expert, but the probe is out and sniffing for whatever! Just yesterday, I had reason to delve below the surface of an XP Pro (SP3) for strange (unable to start) issue and the interest is still awake. Cheers,

more options

OK, I guess "Keep Sniffin'" would be in order here. Read all I've posted, maybe it will help you out.

more options

Usually someone has been down the track before and occasionally they post some useful details which may help others to investigate and/or eliminate factors in their particular case. This AccessibleMarshal.dll error seems to have a long history --- posts from 2006 with early Firefox versions had issues similar to yours. There is a link and an excerpt below which could be worth checking in your case, particularly since it mentions the problem would occur on a clean install (no previous instance of Firefox on the system and Windows before Vista --??) Have a look here: and the post to read:

Mark Banner (:standard8) 2011-12-22 12:55:21 PST

"Created attachment 583905 [details] [diff] [review] Add the Win32 redistributable directory to the mozconfigs"

"Somehow we missed shipping the Win32 Redistributables from Visual C++. We didn't detect this as it would only show on Windows versions less than Vista, and you'd probably only see it if you had a completely clean install, and you didn't have the dlls installed elsewhere (as it appears my XP system does)."

"If you're seeing this then you want to copy the following files from a Firefox installation:

Microsoft.VC80.CRT.manifest msvcm80.dll msvcp80.dll msvcr80.dll

The patch I'm attaching updates our configuration files to specify the Win32 redistribution directory, which will then cause the build system to include the files in the build."

.... ends.... ................................................................

The earlier 2006 instances also had the same issue in some cases: .................................................................

Hope this progresses the search and resolution. Cheers

more options

Thanks, but I'm not sure these are the same problems. I checked my laptop with the exact same setup, WIN XP SP2 (which works) and these files: msvcm80.dll msvcp80.dll msvcr80.dll aren't in the System32 folder, but they are in the Firefox folder. So placing them in the System32 folder doesn't seem to be the issue.