Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox keeps trying to impose a home page on me that I don't want.

  • 2 uphendule
  • 3 zinale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu cor-el

more options

This morning after I went online I had to close Firefox and reopen it, when I reopened it I got a nasty shock. The home page I had been using was gone, replaced by something called funmoods. Then a window popped up saying "unrecognized changes" had been made and did I want to keep them. Oddly enough it refused to let me get rid of the changes.

After some hair pulling to change things back the way I liked. At that point the window asking me if I want to keep the changes popped up immediately. Only this time it had no problem making changes back the way it wanted them. I ended up going through the whole process again. Now whenever I open Firefox that box pops up. I feel like I'm having funmoods shoved down my throat and I do NOT like that!

In fact I tried the funmoods search engine and found it to be completely useless. I use the web for serious research and funmoods doesn't do serious searches searches. I don't want funmoods on my browser at all, but I can't get rid of it. Imagine how I must feel about having it shoved down my throat as a home page.

I would appreciate any helpful suggestions for taking care of this problem.

All Replies (2)

more options

Hi rmkelliher,

You should take a look at the Knowledge Base article How to set the home page. Your homepage might have been changed by a particular site. Sites like MSN, Yahoo, etc have been know to ask to become your homepage.

There are steps in that article to reset your homepage preferences to default. I would try that first to clear out any strangeness. If that works, you can try setting your homepage again to your personal preference.

You might want to take a look at the Search with the Firefox address bar and Search the web from the address bar articles for help changing those just in case they have been taken over by funmoods as well.

If that doesn't work you should look at the article How to fix preferences that won't save.

Finally, your issue may be because you've been hit with some Malware.

Hopefully this helps!