Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox doesn't show images on websites even their own pages

  • 5 uphendule
  • 13 zinale nkinga
  • 15182 views
  • Igcine ukuphendulwa ngu NormaRuth

more options

Not only does firefox not show images, but also won't play audio online. Also my hotmail seems messed up, with text over text etc. It doesn't even show images on the firefox pages

Isisombululo esikhethiwe

For Firefox doesn't show images on websites see analytical information in :

Images or animations do not load


For Firefox won't play audio online see: Video or audio does not play


also see : Websites look wrong


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Hi NormaRuth,

Have you looked at the Fix problems that cause images to not show Knowledge Base article? There is a lot of useful information in there.

You also might want to try starting Firefox in Troubleshoot Firefox issues using Safe Mode. If you don't have the issue while all of your add-ons, extensions, and themes are disabled, you can try adding them back in one by one until you find the culprit. You should look at the Extensions and Themes troubleshooting guide and the Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems article as well.

Hopefully this helps!

more options

Isisombululo Esikhethiwe

For Firefox doesn't show images on websites see analytical information in :

Images or animations do not load


For Firefox won't play audio online see: Video or audio does not play


also see : Websites look wrong


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

more options

See:

  • Check the permissions for the domain in the current tab in Tools > Page Info > Permissions
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in Tools > Options > Content: Load Images > Exceptions
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

more options

If you have increased the minimum font size then try the default setting "none" as a (too) high value can cause issues.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow websites to choose their fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but use an extension to set the default page zoom to prevent issues with overlapping text.

more options

Thanks! I am pleased to report that my problem with images is solved!