X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I make Courier font display properly?

Kuphostiwe

I'm running Firefox 10.0, and after a recent update (last night, though I didn't have chance to notice the change until this morning), Courier font is displaying as Courier New in all instances. Is there a way to fix this?

I'm running Firefox 10.0, and after a recent update (last night, though I didn't have chance to notice the change until this morning), Courier font is displaying as Courier New in all instances. Is there a way to fix this?

Isisombululo esikhethiwe

Okay, I fixed it, but it turns out I had to downgrade back to a version of Firefox 9 to get Courier to display the way I liked. Still, thank you again for your efforts, bram!

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

I updated Firefox.

Fakela amapulagi

  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 15.0.0.198
  • Shockwave Flash 11.1 r102
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 4.0.60831.0
  • NPWLPG
  • Winamp Application Detector
  • Wacom Dynamic Link Library
  • Adobe PDF Plug-In For Firefox and Netscape

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0

Eminye Imininingwane

Application Basics
Name
Firefox
Version
10.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Element Hiding Helper for Adblock Plus
1.2.1
true
elemhidehelper@adblockplus.org
Greasemonkey
0.9.15
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
LJlogin
2.2.1
true
{ad4ee9e5-49c7-4589-acf3-db9fa76a95c9}
Stylish
1.2.5
true
{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}
AVG Safe Search
12.0.0.1912
false
{1E73965B-8B48-48be-9C8D-68B920ABC1C4}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.link.open_newwindow
2
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.sankakucomplex.com/
browser.startup.homepage_override.buildID
20120129021758
browser.startup.homepage_override.mstone
rv:10.0
browser.tabs.autoHide
true
extensions.lastAppVersion
10.0
gfx.blacklist.direct2d
2
gfx.blacklist.layers.direct3d10
2
gfx.blacklist.layers.direct3d10-1
2
gfx.blacklist.layers.direct3d9
2
gfx.blacklist.layers.opengl
2
gfx.blacklist.suggested-driver-version
10.6
gfx.blacklist.webgl.angle
2
gfx.blacklist.webgl.msaa
2
gfx.blacklist.webgl.opengl
2
network.cookie.prefsMigrated
true
network.protocol-handler.warn-external.dnupdate
false
places.database.lastMaintenance
1328124255
places.history.expiration.transient_current_max_pages
73687
places.history.expiration.transient_optimal_database_size
117897624
places.last_vacuum
1304305040
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Mobility Radeon HD 4200 Series
Vendor ID
1002
Device ID
9712
Adapter RAM
256
Adapter Drivers
atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.712.2.1000
Driver Date
3-15-2010
Adapter RAM (GPU #2)
Unknown
Adapter Drivers (GPU #2)
Unknown
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled
false (6.1.7601.17563)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
GPU Accelerated Windows
0/1. Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.

Bram Pitoyo 6 izisombululo 30 izimpendulo
Kuphostiwe
  1. On the menu bar, click on the Firefox menu and select Preferences...
  2. Select the Content panel.
  3. Under Fonts & Colors, click the Advanced... button
  4. Under Monospace, select Courier New on the dropdown menu

For more information, see Change the fonts and colors websites use.

# On the menu bar, click on the '''Firefox''' menu and select '''Preferences...''' # Select the '''Content''' panel. # Under '''Fonts & Colors''', click the '''Advanced...''' button # Under '''Monospace''', select '''Courier New''' on the dropdown menu For more information, see [[Changing fonts and colors]].

Umnikazi wombuzo

That's not what I want. I want Courier, not Courier New (which, it turns out, it was already set to). Using your instructions I tried to set it to Courier, but after clicking "OK" and so on, it goes back to Courier New automatically.

That's not what I want. I want ''Courier'', not Courier New (which, it turns out, it was already set to). Using your instructions I tried to set it to Courier, but after clicking "OK" and so on, it goes back to Courier New automatically.

Okulungisiwe ngu alchemicalheart

Bram Pitoyo 6 izisombululo 30 izimpendulo
Kuphostiwe

Could you try resetting your user preferences and see if it will solve the problem?

  1. On the menu bar, click the Help menu and select Restart with Add-ons Disabled... Firefox will start up with the Firefox Safe Mode dialog.
  2. Put a check mark by Reset all user preferences to Firefox defaults.
  3. Click Make Changes and Restart.
Could you try resetting your user preferences and see if it will solve the problem? # On the menu bar, click the '''Help''' menu and select '''Restart with Add-ons Disabled...''' Firefox will start up with the Firefox Safe Mode dialog. # Put a check mark by '''Reset all user preferences''' to Firefox defaults. # Click Make Changes and Restart.

Umnikazi wombuzo

Unfortunately that didn't help either.

Unfortunately that didn't help either.
Bram Pitoyo 6 izisombululo 30 izimpendulo
Kuphostiwe

We’ve established, I think, that this is a problem with Firefox rather than any specific website. Could you reinstall it again by going to getfirefox.com?

We’ve established, I think, that this is a problem with Firefox rather than any specific website. Could you reinstall it again by going to [http://getfirefox.com getfirefox.com]?

Umnikazi wombuzo

Okay, after a lengthy process of trying stuff...

I tried reinstalling the update over the rest - didn't work. I tried uninstalling Firefox (while leaving preferences/etc intact), then reinstalling entirely - didn't work. I tried a complete uninstall (removing preferences/add-ons/etc), then reinstalling - still didn't work.

Thank you very much for your attempts to help, but at this point I have to admit I'm kind of resigned to the change.

Okay, after a lengthy process of trying stuff... I tried reinstalling the update over the rest - didn't work. I tried uninstalling Firefox (while leaving preferences/etc intact), then reinstalling entirely - didn't work. I tried a complete uninstall (removing preferences/add-ons/etc), then reinstalling - still didn't work. Thank you very much for your attempts to help, but at this point I have to admit I'm kind of resigned to the change.

Okulungisiwe ngu alchemicalheart

Isisombululo Esikhethiwe

Okay, I fixed it, but it turns out I had to downgrade back to a version of Firefox 9 to get Courier to display the way I liked. Still, thank you again for your efforts, bram!

Okay, I fixed it, but it turns out I had to downgrade back to a version of Firefox 9 to get Courier to display the way I liked. Still, thank you again for your efforts, bram!
Bram Pitoyo 6 izisombululo 30 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You’re welcome, and sorry that I couldn’t resolve your problem!

Just curious: back in Firefox 10, could you change Courier New to any typeface you want, or does the font menu only refused to work with Courier?

It might be a new bug that you (or I) could file on Bugzilla, if you like to help.

You’re welcome, and sorry that I couldn’t resolve your problem! Just curious: back in Firefox 10, could you change Courier New to any typeface you want, or does the font menu only refused to work with Courier? It might be a new bug that you (or I) could file on Bugzilla, if you like to help.

Okulungisiwe ngu Bram Pitoyo

Umnikazi wombuzo

I could change Courier New to other typefaces, just not to Courier for some reason. Whenever I tried to do that (before or after reinstalling Firefox 10.0), it would automatically change back to Courier New.

I once had the same problem on a more generalized level (following a Windows update which I had to system restore to fix), but this was localized entirely to Firefox.

I'm entirely unfamiliar with Bugzilla, though.

I could change Courier New to other typefaces, just not to Courier for some reason. Whenever I tried to do that (before or after reinstalling Firefox 10.0), it would automatically change back to Courier New. I once had the same problem on a more generalized level (following a Windows update which I had to system restore to fix), but this was localized entirely to Firefox. I'm entirely unfamiliar with Bugzilla, though.
cor-el
  • Top 10 Contributor
  • Moderator
17569 izisombululo 158915 izimpendulo
Kuphostiwe

The Courier font that you have may no be compatible anymore with Firefox 10 if you can't select it.

You can do a font test to see if you can identify corrupted or not working font(s).

The Courier font that you have may no be compatible anymore with Firefox 10 if you can't select it. You can do a font test to see if you can identify corrupted or not working font(s). *http://browserspy.dk/fonts-flash.php?detail=1

Umnikazi wombuzo

Hmm. Did that test and it doesn't even list Courier for me, just Courier New and forms of that.

Hmm. Did that test and it doesn't even list Courier for me, just Courier New and forms of that.
cor-el
  • Top 10 Contributor
  • Moderator
17569 izisombululo 158915 izimpendulo
Kuphostiwe

If they don't show up in the list of the default fonts and also are not identified by the Flash plugin on the test page then they are most likely no longer compatible.

If they don't show up in the list of the default fonts and also are not identified by the Flash plugin on the test page then they are most likely no longer compatible.

Umnikazi wombuzo

It showed up on the list on Firefox, but the plugin on the test page didn't detect it.

It showed up on the list on Firefox, but the plugin on the test page didn't detect it.
Bram Pitoyo 6 izisombululo 30 izimpendulo
Kuphostiwe

I’m going to try changing Courier New to Courier on my Windows (admittedly XP) machine tomorrow. If it doesn’t work, then it’s probably a bug.

Cor-el, do you have Windows 7, and if so, could you reproduce this problem?

I’m going to try changing ''Courier New'' to ''Courier'' on my Windows (admittedly XP) machine tomorrow. If it doesn’t work, then it’s probably a bug. Cor-el, do you have Windows 7, and if so, could you reproduce this problem?
cor-el
  • Top 10 Contributor
  • Moderator
17569 izisombululo 158915 izimpendulo
Kuphostiwe

No, I'm on Linux, so can't test it on Windows.

I've tested it in Firefox 10 and both Courier and Courier New show correctly.

No, I'm on Linux, so can't test it on Windows. I've tested it in Firefox 10 and both Courier and Courier New show correctly. *fontinfo: https://addons.mozilla.org/firefox/addon/fontinfo/