Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why can't I upgrade to the most recent Firefox with a Mac 10.5.8

  • 1 baphendule
  • 9 zinale nkinga
  • 22 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

I'm trying to update Firefox 3.0.10. I have a Mac 10.5.8 with 512 MB of SDRam. When I try to upgrade to the most recent Firefox it tells me my computer isn't compatible, but also tells me that Osx 10.5 with 512 MB of ram should work. Any suggestions? Is there a previous Firefox update which could work, and how would I go about finding that previous update.

Thanks, sorry I'm not so good at this stuff.

All Replies (1)

more options

Firefox 3.6.x is the last available from Mozilla for PPC Macs.
http://www.mozilla.com/en-US/firefox/all-older.html

Download Firefox 3.6.26 and install it - https://support.mozilla.com/en-US/kb/Installing+Firefox+on+Mac


For older Macs that aren't supported in the Firefox 4+ versions, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/
http://tenfourfox.blogspot.com/
https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported
http://code.google.com/p/tenfourfox/wiki/AAATheFAQ