Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

unable to open firefox after download

  • 3 uphendule
  • 7 zinale nkinga
  • 140 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

I'm using a netbook with linux and firefox 2. I tried to download the newest version of Firefox, but it will not open. It says to change the helper application in preferences, but I don't know what that is. I need to upgrade my system because of security issues. Please Help!!!!

All Replies (3)

more options

Which netbook? Asus EeePC or Acer One or ???

Which Linux distro?

Many of the Linux distros that came with Firefox 2 need to be updated for a Firefox 3+ version, or need a newer GTK package.

more options

Jan. 29, 2012

could e

Hi edmeister,

  My netbook is an Asus EeePc 900.   The operating system is Linux with Firefox 2.   I don't know what I am supposed to do to be able to update and run a newer version of Firefox.   My computer knowledge is very minimal, but if someone would kindly explain to me what it is that I need to do to in order to accomplish this, I would greatly appreciate it.   Also, I don't know what the specific Helper Application is that I need to specify in the Preferences section of my netbook.
                                             Thank You ,
                                            lynnsdancers
more options

The version of Xandros Linux (from early 2007) that Asus was using on theEeePC doesn't have the GTK package needed to run Firefox 3+ versions, you need to update it. See these:
http://forum.eeeuser.com/viewtopic.php?id=41815
http://wiki.eeeuser.com/howto:installfirefox3?s=firefox
I am not aware any support articles about installing a version of Firefox newer than Firefox 3.0, although I read somewhere that if Firefox 3.0 worked, Firefox 3.5 would. But 3.5 is an unsupported version nowadays, you need Firefox 3.6.x at least.

I quit keeping track of the upgrade stuff about Xandros Linux because I installed a much newer Linux distro on my EeePC 900A in 2010. This is what I replaced it with:
http://www.geteasypeasy.com/