Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

there is no tools section on firefox interface to stop pop ups. so how can I stop them

  • 10 uphendule
  • 4 zinale nkinga
  • 6 views
  • Igcine ukuphendulwa ngu jp2pj92

more options

almost every site I use I get a firefox message this site is not trusted. it keeps popping up over and over. If I add an exception it still keeps popping up and stops me using some sites. it states that the site has no up to date licence, however if i check this the licence is valid. I would get rid of firfox but i cannot access the net through explorer for some reason.

Isisombululo esikhethiwe

Did you check the issuer of the certificate?

Try to rename the file cert8.db to cert8.db.old in the Firefox Profile Folder to remove all intermediate certificates that Firefox has stored by visiting secure websites.
If that helped to solve the problem then you can remove the renamed file cert8.db.old unless you have user certificates that you may want to export first and import them in the new file.
Otherwise you can restore the certificates by renaming (copying) the file back to cert8.db
Firefox will automatically store new intermediate certificates when you visit websites that send them.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (10)

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Hi thanks for your help unfortunately this has not solved the problem, using safe mode and all ad-ons disabled the firefox po-ups still keep stopping me from using my computer properly. It states secure connection failed -- certificate expired. Just trying to access my e-mails and this will come up five or six times before I can get into the e-mail site. clicking on the add exception makes no difference. I have even tried using my system restore, going back a month at a time but this also does not work. have you any idea what may have disabled my internet options, I have windows XP operating system

more options

"It states secure connection failed -- certificate expired."

That is not considered a "pop-up", it's an alert or warning message.
Which website gives you that message?
Is the date / time set correctly in Windows?

more options

Hi thanks . this happens on almost every site that i use including hotmail. this warning pops up several times, sometimes i can keep clearing it by clicking the x top right corner. other times have to add an exception, but sometimes this will not work and i have to leave the sight. this can happen when i try to buy goods from the internet ie amazon and stops me completing the order. Not sure about the correct time or how to check/ reset this if wrong. sorry but not very good at computers and the 'experts at plusnet , my broadband supplier, are unable to help.

more options

See this WinXP support article.
http://support.microsoft.com/kb/307938

more options

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

Can you attach screenshots that show relevant details in the certificate manager of such a blocked certificate?

more options

Hi thanks for trying to help with my problem. I do click on the 'I understand the risks' add exception and check the certificate. then I find that the certificate has not run out, often with one or two years still to go. this still makes no difference. all the sites like hotmail etc that i have made an exception still come up with this warning every time i go on the site.

with regard to an earlier post the time in bottom right hand corner is wrong but i believe the year is correct, i have had the computer from new. all these problems seem to have started since downloading firefox 8 and I have also lost the use of internet explorer so cannot delete firefox.

more options

Thank you for everyone on here for helping me with my fiefox problem. this has now thankfully been solved and I can once again use my computer without tearing my hair out.

more options

Isisombululo Esikhethiwe

Did you check the issuer of the certificate?

Try to rename the file cert8.db to cert8.db.old in the Firefox Profile Folder to remove all intermediate certificates that Firefox has stored by visiting secure websites.
If that helped to solve the problem then you can remove the renamed file cert8.db.old unless you have user certificates that you may want to export first and import them in the new file.
Otherwise you can restore the certificates by renaming (copying) the file back to cert8.db
Firefox will automatically store new intermediate certificates when you visit websites that send them.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
more options

Hi unable to change name of cert8.db however the annoying warnings from firefox have now thankfully been stopped. Thank you all once again for your help.