X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

how to move firefox title bar buttons (close/max/min) from the left to the right side ??

Kuphostiwe

notice that windows title bar buttons normally on the right side , but firfox's is on the left side

notice that windows title bar buttons normally on the right side , but firfox's is on the left side

Okulungisiwe ngu m4gdy

Isisombululo esikhethiwe

i've just found the solution:

go to

about:config

search for intl.uidirection.ar

change it from RTL to LTR

thx all 4 ur help/answers , even that it didn't work xD

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

when i installed windows 7 ultimate / updated FF from v9 to v9.0.1

Fakela amapulagi

  • Shockwave Flash 11.1 r102
  • Yahoo Application State Plugin version 1.0.0.7
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

Eminye Imininingwane

the-edmeister
  • Top 25 Contributor
  • Moderator
5397 izisombululo 40134 izimpendulo
Kuphostiwe

That's not the normal position in Firefox. You have something installed that moved it to the left side of the Titlebar.

http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

That's not the normal position in Firefox. You have something installed that moved it to the left side of the Titlebar. http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

Umnikazi wombuzo

thx 4 the answer , but the problem still unsolved , i downloaded FF 10 and its the same , i guess its because i use FF arabic , so is there is anyway to solve this without downgrading to FF v9 ?

thx 4 the answer , but the problem still unsolved , i downloaded FF 10 and its the same , i guess its because i use FF arabic , so is there is anyway to solve this without downgrading to FF v9 ?
cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157847 izimpendulo
Kuphostiwe

If you have an RTL locale then those button are probably because of that at the left side. Easiest would be to install an LTR locale, but you may also be able to swap those buttons to the left side with code in userChrome .css.

Add code to userChrome.css below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.

Does this code work with your locale?


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#nav-bar > * { -moz-box-ordinal-group:2; }
#window-controls{ -moz-box-ordinal-group:1!important; }
If you have an RTL locale then those button are probably because of that at the left side. Easiest would be to install an LTR locale, but you may also be able to swap those buttons to the left side with code in userChrome .css. Add code to userChrome.css below the default @namespace line. *http://kb.mozillazine.org/userChrome.css The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder. *http://kb.mozillazine.org/Editing_configuration Does this code work with your locale? ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #nav-bar > * { -moz-box-ordinal-group:2; } #window-controls{ -moz-box-ordinal-group:1!important; } </nowiki></pre>

Umnikazi wombuzo

@cor-el no the code didn't work :S , but i downloaded a tool named left sider

http://www.softpedia.com/get/Tweak/System-Tweak/LeftSider.shtml

when i enable it then disable it the FF buttons move to the right , but when i restart FF it back to the left again , any solution to make it permanent ?

, and how to install an LTR locale ?? i tried FF english and it works without problems the problem with the arabic version only

thx in advance

@cor-el no the code didn't work :S , but i downloaded a tool named left sider http://www.softpedia.com/get/Tweak/System-Tweak/LeftSider.shtml when i enable it then disable it the FF buttons move to the right , but when i restart FF it back to the left again , any solution to make it permanent ? , and how to install an LTR locale ?? i tried FF english and it works without problems the problem with the arabic version only thx in advance

Okulungisiwe ngu m4gdy

cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157847 izimpendulo
Kuphostiwe

I tried the code with the AR locale and it works for me to get the window controls at the right side of the location bar with the default theme.
Make sure that the file is in the correct chrome folder in the Firefox Profile Folder

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Can you post the full content of the userChrome.css file?

I do notice that the tree buttons in that container are still RTL, so I added a direction:ltr to the code.


#nav-bar > *{ -moz-box-ordinal-group:2; }
#window-controls { -moz-box-ordinal-group:1!important; direction:ltr!important; }
I tried the code with the AR locale and it works for me to get the window controls at the right side of the location bar with the default theme.<br /> Make sure that the file is in the correct chrome folder in the Firefox Profile Folder You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Open Containing Folder Can you post the full content of the userChrome.css file? I do notice that the tree buttons in that container are still RTL, so I added a direction:ltr to the code. ----- <pre><nowiki>#nav-bar > *{ -moz-box-ordinal-group:2; } #window-controls { -moz-box-ordinal-group:1!important; direction:ltr!important; }</nowiki></pre>

Okulungisiwe ngu cor-el

Umnikazi wombuzo

maybe i'm doing it wrong , sry i'm noob ^^


/*

* Edit this file and copy it as userChrome.css into your
* profile-directory/chrome/
*/

/*

* This file can be used to customize the look of Mozilla's user interface
* You should consider using !important on rules which you want to
* override default settings.
*/

/*

* Do not remove the @namespace line -- it's required for correct functioning
*/

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */


/*

* Some possible accessibility enhancements:
*/

/*

* Make all the default font sizes 20 pt:
*
* * {
*   font-size: 20pt !important
* }
*/

/*

* Make menu items in particular 15 pt instead of the default size:
*
* menupopup > * {
*   font-size: 15pt !important
* }
*/

/*

* Give the Location (URL) Bar a fixed-width font
*
* #urlbar {
*    font-family: monospace !important;
* }
*/

/*

* Eliminate the throbber and its annoying movement:
*
* #throbber-box {
*   display: none !important;
* }
*/

/*

* For more examples see http://www.mozilla.org/unix/customizing.html
*/

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. nav-bar > * { -moz-box-ordinal-group:2; }
  2. window-controls{ -moz-box-ordinal-group:1!important; }
maybe i'm doing it wrong , sry i'm noob ^^ /* * Edit this file and copy it as userChrome.css into your * profile-directory/chrome/ */ /* * This file can be used to customize the look of Mozilla's user interface * You should consider using !important on rules which you want to * override default settings. */ /* * Do not remove the @namespace line -- it's required for correct functioning */ @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */ /* * Some possible accessibility enhancements: */ /* * Make all the default font sizes 20 pt: * * * { * font-size: 20pt !important * } */ /* * Make menu items in particular 15 pt instead of the default size: * * menupopup > * { * font-size: 15pt !important * } */ /* * Give the Location (URL) Bar a fixed-width font * * #urlbar { * font-family: monospace !important; * } */ /* * Eliminate the throbber and its annoying movement: * * #throbber-box { * display: none !important; * } */ /* * For more examples see http://www.mozilla.org/unix/customizing.html */ @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #nav-bar > * { -moz-box-ordinal-group:2; } #window-controls{ -moz-box-ordinal-group:1!important; }
cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157847 izimpendulo
Kuphostiwe

There is already an @namespace line further up in the file (if you do not see it then do a search), so you can either remove the @namespace line that you've added.

The file looks OK, so should be working.

Did you make sure that the file name is correct and that Windows didn't add a hidden .txt file extension?
You can verify that via the Properties.

You can also temporarily add some extra test code at the end of the file to see if that works.


#urlbar {
 font-family: monospace !important;
 font-size: 15px !important;
}

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
There is already an @namespace line further up in the file (if you do not see it then do a search), so you can either remove the @namespace line that you've added. The file looks OK, so should be working. Did you make sure that the file name is correct and that Windows didn't add a hidden .txt file extension?<br /> You can verify that via the Properties. You can also temporarily add some extra test code at the end of the file to see if that works. ---- <pre><nowiki>#urlbar { font-family: monospace !important; font-size: 15px !important; }</nowiki></pre> ---- You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Umnikazi wombuzo

the last code didn't work either , and the file extension is .css not .txt

i guess the problem has smth to do with win 7 not a bug from FF , any thoughts ?

the last code didn't work either , and the file extension is .css not .txt i guess the problem has smth to do with win 7 not a bug from FF , any thoughts ?

Okulungisiwe ngu m4gdy

cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157847 izimpendulo
Kuphostiwe

Windows hides some file extension and .txt is one of them. If you've saved the file as a Text file then Windows may have added a .txt file extension. So you need to check the file type to be sure that the type is CSS (Cascading Stylesheet).

Windows hides some file extension and .txt is one of them. If you've saved the file as a Text file then Windows may have added a .txt file extension. So you need to check the file type to be sure that the type is CSS (Cascading Stylesheet). *http://kb.mozillazine.org/Editing_configuration/Troubleshooting

Umnikazi wombuzo

i usually use extension changer so i'm sure its .css not .txt

i usually use extension changer so i'm sure its .css not .txt

Okulungisiwe ngu m4gdy

cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157847 izimpendulo
Kuphostiwe

Yes, that is OK. The file should be working if it is in the correct location in the chrome folder in the Firefox Profile Folder, so I don't know what else can be wrong if you've checked everything.

Do you see any errors in the Firefox/Tools > Web Developer > Error Console (Shift+Ctrl+J) immediately after starting Firefox about the userChrome.css file?

Are you using the default theme?

Yes, that is OK. The file should be working if it is in the correct location in the chrome folder in the Firefox Profile Folder, so I don't know what else can be wrong if you've checked everything. Do you see any errors in the Firefox/Tools > Web Developer > Error Console (Shift+Ctrl+J) immediately after starting Firefox about the userChrome.css file? Are you using the default theme?

Umnikazi wombuzo

no , i've removed nasa theme and i'm using the default one now

and yes i've found an error

unexpected end of file while searching for closing ( hope i translated it right , the arabic version of FF have some mistakes on translation )

file:///C:/Users/-----/AppData/Roaming/Mozilla/Firefox/Profiles/dh99gc2p.default/chrome/userChrome.css

line :55

and this is my current userchrome file http://www.mediafire.com/?1wisnzs6vix1lxj

no , i've removed nasa theme and i'm using the default one now and yes i've found an error unexpected end of file while searching for closing ( hope i translated it right , the arabic version of FF have some mistakes on translation ) file:///C:/Users/-----/AppData/Roaming/Mozilla/Firefox/Profiles/dh99gc2p.default/chrome/userChrome.css line :55 and this is my current userchrome file http://www.mediafire.com/?1wisnzs6vix1lxj

Okulungisiwe ngu m4gdy

cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157847 izimpendulo
Kuphostiwe

There is no real content in that userChrome.css file: the last rule starts with a comment (/*) that isn't closed with a "}", so that line wouldn't work even with that opening comment code removed.

Create a new file userChrome.css with only the content that I posted above.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#nav-bar > *{ -moz-box-ordinal-group:2; }
#window-controls { -moz-box-ordinal-group:1!important; direction:ltr!important; }
There is no real content in that userChrome.css file: the last rule starts with a comment (/*) that isn't closed with a "}", so that line wouldn't work even with that opening comment code removed. Create a new file userChrome.css with only the content that I posted above. ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #nav-bar > *{ -moz-box-ordinal-group:2; } #window-controls { -moz-box-ordinal-group:1!important; direction:ltr!important; }</nowiki></pre>
JayGarcia 30 izisombululo 273 izimpendulo
Kuphostiwe

You mentioned that you're running the Arabic version of Firefox. If the latest addition to the userChrome.css file doesn't work, that may be why it cannot be forced to move from one side to the other.

You mentioned that you're running the Arabic version of Firefox. If the latest addition to the userChrome.css file doesn't work, that may be why it cannot be forced to move from one side to the other.

Umnikazi wombuzo

@cor-el didn't work either

@dad7732 FF v9 used to work fine with win xp sp3 but it didn't with win 7 so i upgraded to v9.0.1 then to v10 so i guess the problem has smth to do with win 7 not FF

but left sider ( link posted above ) solved the problem temporarily , any way to make it permanent ?

@cor-el didn't work either @dad7732 FF v9 used to work fine with win xp sp3 but it didn't with win 7 so i upgraded to v9.0.1 then to v10 so i guess the problem has smth to do with win 7 not FF but left sider ( link posted above ) solved the problem temporarily , any way to make it permanent ?

Okulungisiwe ngu m4gdy

Isisombululo Esikhethiwe

i've just found the solution:

go to

about:config

search for intl.uidirection.ar

change it from RTL to LTR

thx all 4 ur help/answers , even that it didn't work xD

i've just found the solution: go to about:config search for intl.uidirection.ar change it from RTL to LTR thx all 4 ur help/answers , even that it didn't work xD

Okulungisiwe ngu m4gdy