Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to get an https rss feed working?

  • 4 uphendule
  • 1 inale nkinga
  • 448 views
  • Igcine ukuphendulwa ngu Lazine

more options

Can't it do https rss feeds?

I have an RSS feed, it is stored in FF as http:

if I change it to https Firefox just changes it back to http.

The site does support https and serves the pages, and rss feed via https. If i just enter it in the URLbar i can see the feed, but there is no way to subscribe when its https only if you remove the 's' and go http.

Can't it do https rss feeds? I have an RSS feed, it is stored in FF as http: if I change it to https Firefox just changes it back to http. The site does support https and serves the pages, and rss feed via https. If i just enter it in the URLbar i can see the feed, but there is no way to subscribe when its https only if you remove the 's' and go http.

All Replies (4)

more options

So you can't subscribe to the feed on this page?

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


Please update Firefox to the latest version via "Help > About Firefox" or "Help > Check for Updates"
The Firefox 7.0.1 version that you currently run is no longer supported with security updates.

You can find the latest Firefox release here:

more options

Hm, yes i can subscribe to that. So its a different problem. Very curious, and sad.

more options

Does accessing the feed require authorization?

What happens if you enter the feed location in the location bar?

Do you see a subscribe to this feed frame with the correct URL in the location bar?

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"
more options

There is authentication in the URL.

If I enter it in the location bar:

I get the "subscribe to this feed" if I use "http:" but if I use "https:" I get "This XML file does not appear to have any style information associated with it. The document tree is shown below."

I see the subscribe to frame with the correct url, when it starts with "http:" but not when it starts with "https:"