X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox can't handle links to .mov files?!

Kuphostiwe

I upgraded to Lion (so, Mac OS X) and using Firefox 9, together with Quicktime plugin 7.7.1.

When I open http://apple.com/trailers and choose a trailer, you can watch a trailer inline or use a download link. Although the inline works properly, the download never starts, and the external quicktime player doesn't start either.

Using the web developer console, I checked the request: [11:43:21.674] GET http://trailers.apple.com/movies/fox/prometheus/prometheus-tlr1_h480p.mov

And the answer is: [HTTP/1.1 302 Moved Temporarily 131ms]

But nothing else changes. Page doesn't reload, nothing moves.

In the preferences, Applications tab, I have all video/quicktime being handled by "Use QuickTime Plug-in 7.7.1".

I tried to change to "Ask" or to use application "Quicktime", but nothing moves :(

Thanks for any information you can give.

I upgraded to Lion (so, Mac OS X) and using Firefox 9, together with Quicktime plugin 7.7.1. When I open http://apple.com/trailers and choose a trailer, you can watch a trailer inline or use a download link. Although the inline works properly, the download never starts, and the external quicktime player doesn't start either. Using the web developer console, I checked the request: [11:43:21.674] GET http://trailers.apple.com/movies/fox/prometheus/prometheus-tlr1_h480p.mov And the answer is: [HTTP/1.1 302 Moved Temporarily 131ms] But nothing else changes. Page doesn't reload, nothing moves. In the preferences, Applications tab, I have all video/quicktime being handled by "Use QuickTime Plug-in 7.7.1". I tried to change to "Ask" or to use application "Quicktime", but nothing moves :( Thanks for any information you can give.

Okulungisiwe ngu Alberto Simões

Isisombululo esikhethiwe

It seems it is related to the user agent. Apple sucking. Setting it to the safari user agent string seems to work.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

Eminye Imininingwane

Application Basics
Name
Firefox
Version
9.0.1
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
1Password
3.8.9
true
onepassword@agilebits.com
Adblock Plus
2.0.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Corrector para Português de Portugal
11.12.25.0
true
pt-PT-preao@maracuja.homeip.net
Corretor para Português de Portugal
11.12.25.0
true
pt-PT@dictionaries.addons.mozilla.org
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
DownloadHelper
4.9.8
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Test Pilot
1.2
false
testpilot@labs.mozilla.com
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20111220165912
browser.startup.homepage_override.mstone
rv:9.0.1
extensions.lastAppVersion
9.0.1
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
0x24300,0x20400
WebGL Renderer
Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine -- 2.1 APPLE-7.14.5
GPU Accelerated Windows
1/1 OpenGL

Umnikazi wombuzo

Check FIrefox behavior's here: http://youtu.be/PfABP0u1POs

It also shows the behavior of Safari, that is the one I would like to have in Firefox.

Check FIrefox behavior's here: http://youtu.be/PfABP0u1POs It also shows the behavior of Safari, that is the one I would like to have in Firefox.

Okulungisiwe ngu Alberto Simões

Umnikazi wombuzo

Updated to 10, same problem. And no idea what is going on. And it seems any other user has the same problem :(

Updated to 10, same problem. And no idea what is going on. And it seems any other user has the same problem :(

Umnikazi wombuzo

10.0.2, same shit. :(

10.0.2, same shit. :(
Michael Verdi 128 izisombululo 857 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi Alberto, Sorry for missing your post back in January. On OS X I can only get this to work correctly in Safari. I works great on Windows though. I don't think there are any incorrect settings here so I filed a bug https://bugzilla.mozilla.org/show_bug.cgi?id=734274 so our developers can look at it.

Hi Alberto, Sorry for missing your post back in January. On OS X I can only get this to work correctly in Safari. I works great on Windows though. I don't think there are any incorrect settings here so I filed a bug https://bugzilla.mozilla.org/show_bug.cgi?id=734274 so our developers can look at it.

Impendulo Ewusizo

Hello, Verdi. The curious is that it worked before (Firefox 5, at least), and I have a friend, also with MacOS X, where it works :-|

Thanks. Alberto

Hello, Verdi. The curious is that it worked before (Firefox 5, at least), and I have a friend, also with MacOS X, where it works :-| Thanks. Alberto
cor-el
  • Top 10 Contributor
  • Moderator
17869 izisombululo 161698 izimpendulo
Kuphostiwe

Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Reload web page(s) and bypass the cache. *Press and hold Shift and left-click the Reload button. *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Cmd + Shift + R" (MAC) Clear the cache and the cookies from sites that cause problems. "Clear the Cache": *Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now" "Remove Cookies" from sites causing problems: *Firefox > Preferences > Privacy > Cookies: "Show Cookies" ---- Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Umnikazi wombuzo

No, cor-el. I tried everything. I removed my full profile. I deleted the Firefox application. I deactivated all extensions and plugins. Nothing.

No, cor-el. I tried everything. I removed my full profile. I deleted the Firefox application. I deactivated all extensions and plugins. Nothing.
AliceWyman
  • Moderator
241 izisombululo 2619 izimpendulo
Kuphostiwe

You said, In the preferences, Applications tab, I have all video/quicktime being handled by "Use QuickTime Plug-in 7.7.1". I tried to change to "Ask" or to use application "Quicktime", but nothing moves :(

Not sure what you meant by "nothing moves" but if you've changed the action from the QuickTime plugin to another action for QuickTime Movies (.mov files) that are downloaded (as opposed to embedded media, which will always use an enabled plugin) and it doesn't work, the problem could be with the "download" option on Apple's trailer pages.

Here's a direct link to a .mov file (see http://kb.mozillazine.org/Testing_plugins for other media test links)

You said, ''In the preferences, Applications tab, I have all video/quicktime being handled by "Use QuickTime Plug-in 7.7.1". I tried to change to "Ask" or to use application "Quicktime", but nothing moves :( '' Not sure what you meant by "nothing moves" but if you've changed the action from the QuickTime plugin to another action for QuickTime Movies (.mov files) that are downloaded (as opposed to embedded media, which will always use an enabled plugin) and it doesn't work, the problem could be with the "download" option on Apple's trailer pages. Here's a direct link to a .mov file (see http://kb.mozillazine.org/Testing_plugins for other media test links) *http://its.virginia.edu/network/videotest/when-sm.mov

Okulungisiwe ngu AliceWyman

Umnikazi wombuzo

Hello, Alice. You are right, indeed. I tried yesterday to rename the title of this issue, but it seems it didn't stick.

The problem is that the .mov file that is linked from Apple page is an HTML file (you can find it if you try to wget it). Nevertheless, it seems that something is being lost by Firefox.

Hello, Alice. You are right, indeed. I tried yesterday to rename the title of this issue, but it seems it didn't stick. The problem is that the .mov file that is linked from Apple page is an HTML file (you can find it if you try to wget it). Nevertheless, it seems that something is being lost by Firefox.

Umnikazi wombuzo

v11, same problem.

v11, same problem.
mscr.help 0 izisombululo 1 izimpendulo
Kuphostiwe

Works on my Admin account, but not on managed account. Running Lion 10.7.3.

Works on my Admin account, but not on managed account. Running Lion 10.7.3.

Umnikazi wombuzo

I am running with an admin account :-|

I am running with an admin account :-|

Umnikazi wombuzo

v12.0, still not fixed. I imagine that or few people use FF in mac and try to watch Apple Trailers in external application, or they don't have any problem with it. This is frustrating :(

v12.0, still not fixed. I imagine that or few people use FF in mac and try to watch Apple Trailers in external application, or they don't have any problem with it. This is frustrating :(

Umnikazi wombuzo

Firefox v13.0 installed. This is not yet working. And they claim that free software has a smaller delay on fixing bugs...

Firefox v13.0 installed. This is not yet working. And they claim that free software has a smaller delay on fixing bugs...

Isisombululo Esikhethiwe

It seems it is related to the user agent. Apple sucking. Setting it to the safari user agent string seems to work.

It seems it is related to the user agent. Apple sucking. Setting it to the safari user agent string seems to work.
bjacobs 0 izisombululo 6 izimpendulo
Kuphostiwe

Not sure what one should do here...please explain.

Not sure what one should do here...please explain.

Umnikazi wombuzo

Firefox can't do a thing. I already complained with Apple.

Meanwhile, you can install user agent switch plugin for Firefox, and change your user agent to Safari one to watch the trailers.

Probably easier to use safari for that while Apple doesn't fix it :-/

Firefox can't do a thing. I already complained with Apple. Meanwhile, you can install user agent switch plugin for Firefox, and change your user agent to Safari one to watch the trailers. Probably easier to use safari for that while Apple doesn't fix it :-/
bjacobs 0 izisombululo 6 izimpendulo
Kuphostiwe

Okay, I've just been using Safari for the movie trailers. thanks.

Okay, I've just been using Safari for the movie trailers. thanks.