Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I disable the "Improve Firefox" suggestion which appeared after FF8 update? No any choise helps to avoid the popup appearance next time.

  • 6 uphendule
  • 28 zinale nkinga
  • 13 views
  • Igcine ukuphendulwa ngu David Xie

more options

I am using FF8 with Selenium RC testing framework. When I installed the last FF update the popup YesNo dialog "Would you like to help improve ..." began to appear before each test run. So, tests stopped running on this popup and my problem is that I can't disable this popup for the next times. I mean I select Yes or No, popup disappears, but still appears during the next test run. How can I disable this popup at all?

Okulungisiwe ngu tenety

Isisombululo esikhethiwe

Hi guys! Thanks to all of you for cooperation and willing to help. I've summarized all your advices, so the following 3 steps sort the problem out for FF8 and make my tests to run fine:

  1. Create and configure a new FF profile, using these instruction and suggestions . Don't switch your FF to default profile at the end.
  2. Then perform the first 6 steps by SafeBrowser (see above) for the new profile. Switch to default profile (in firefox -p).
  3. Don't forget to use your new profile when running Selenium Server (-firefoxProfileTemplate command line parameter) or set Selenium to use this profile when starting a browser from Salenece.
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

Try setting the preference toolkit.telemetry.prompted to "true" in about:config

  1. type about:config in the URL/Location/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = toolkit.telemetry.prompted
  4. double click the preference in the lower pane to toggle it to true (or right-click the preference in the lower pane and choose "Toggle")
  5. preference in lower pane should now be bold, show "user set" and value should be "true"
  6. close the about:config tab
  7. See --> http://kb.mozillazine.org/Editing_configuration


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Okulungisiwe ngu SafeBrowser

more options

If you create a new profile with each test run then you can use a file user.js to initialize pref and add a line with the above mentioned pref in it.

Create a default template folder \defaults\profile in the Firefox program folder and place the user.js file in it.


user_pref("toolkit.telemetry.prompted", true);
more options

Here's my solution; hope it will be helpful to you:

1. Create a file called 'user.js' with the following:

user_pref("toolkit.telemetry.enabled", false); user_pref("toolkit.telemetry.prompted", 2); user_pref("toolkit.telemetry.rejected", true);

Note: the first line isn't necessary for Firefox 9, seems like Mozilla have changed things around in the new version (I'm using FF9 Beta 3).

2. Open up your prefs.js and make sure there's nothing about "toolkit.telemetry" in that file.

3. Deploy your Firefox profile with the user.js file inside.

That should be it! This is our solution with our public Firefox deployment.

more options

In Firefox 8 the toolkit.telemetry.prompted pref is still a Boolean, so your solution is only for Firefox 9+ versions where it has been changed to an Integer (Number).

more options

Isisombululo Esikhethiwe

Hi guys! Thanks to all of you for cooperation and willing to help. I've summarized all your advices, so the following 3 steps sort the problem out for FF8 and make my tests to run fine:

  1. Create and configure a new FF profile, using these instruction and suggestions . Don't switch your FF to default profile at the end.
  2. Then perform the first 6 steps by SafeBrowser (see above) for the new profile. Switch to default profile (in firefox -p).
  3. Don't forget to use your new profile when running Selenium Server (-firefoxProfileTemplate command line parameter) or set Selenium to use this profile when starting a browser from Salenece.

Okulungisiwe ngu tenety

more options

@cor-el: thanks for pointing it out; would be great if Mozilla can inform System Admins about changes like these!