Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

unable to play videos from youtube on firefox

  • 7 uphendule
  • 275 zinale nkinga
  • 5901 views
  • Igcine ukuphendulwa ngu BrendaL

more options

I am unable to play youtube videos on Firefox after the updates. Firefox works great with Facebook but can no longer play videos there. I have down loaded adobe flash player it wont work either I dont know what else to do. I have windows 7. Please help.

All Replies (7)

more options

Do you see the Flash plugin on the Tools > Add-ons > Plugins and the about:plugins page?

Does the Flash test site confirm that the Flash player is installed?

more options

The same here. No video on youtube at all, suddenly. I have latest flash player installed.

more options

Download CCleaner, scan and clean....then problem will be solved ;) I fixed mine that way.

more options

The latest Adobe Flash plugin adds a 64-bit player as well as the standard 32-bit player. Youtube seems to set a cookie that conflicts with the 64-bit version and therefore causes you to see a black screen when trying to play videos. The following steps should fix your issue if it is related to this update:

  1. Click the Firefox menu on the top left (or the Tools menu if you use the menu bar).
  2. Go to History -> Clear Recent History (Omit first part from the Tools menu).
  3. Make sure both Cookies and Cache are check-marked (feel free to uncheck everything else)
  4. Set the Time range to clear drop-down box to Everything.
  5. Click the Clear Now button.

You should now be able to play Youtube (and presumably) other videos again. Doing this worked for me anyway...

Okulungisiwe ngu Ketonom

more options
more options

This did not resolve the problem for me. Sadly. Videos play OK one IE but I don't use it as a rule.

more options

This is a Flash player issue - I uninstalled the latest Flash Player and reinstalled Flash 10.3 and everything seems to be working again.

(Youtube videos were just coming up as a black box with a play button - when I pressed this I got the message "An error has occurred - please try later"