Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Is there an older versionof firefox I can use for my 10.2 Mac

  • 1 baphendule
  • 2 zinale nkinga
  • 25 views
  • Igcine ukuphendulwa ngu cor-el

more options

My Mac is a 10.2.8 revision. The Firefox version I am using is not compatible with gmail. My Mac revision is old and cannot upgrade to the latest revision of Firefox. Is there an old version of Firefox that can be used with my Mac?

My Mac is a 10.2.8 revision. The Firefox version I am using is not compatible with gmail. My Mac revision is old and cannot upgrade to the latest revision of Firefox. Is there an old version of Firefox that can be used with my Mac?

All Replies (1)

more options