X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

For 7.0, get popup saying "Can't load XRE extensions." Firefox fails to open.

Kuphostiwe

On Win 7 system, loaded new version 7.0 of Firefox. When attempting to open Firefox, I get a popup that say's "Couldn't load XRE functions." Firefox won't open.

On Win 7 system, loaded new version 7.0 of Firefox. When attempting to open Firefox, I get a popup that say's "Couldn't load XRE functions." Firefox won't open.

Isisombululo esikhethiwe

I had the same problem. I am running Zone Alarm. Went in and changed the setting in the 'Internet Protected' part, turned off Browser Virtualization. And no more popups from XUL Runner. Firefox opens just fine.

Funda le mpendulo ngokuhambisana nalesi sihloko 33

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

After installing v. 7.0

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • Shockwave Flash 11.0 d1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • iTunes Detector Plug-in
  • Version 1.1.11, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • npFFApi
  • Office Live Update v1.5
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • 4.0.50401.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20110923 Firefox/7.0 SeaMonkey/2.4

Eminye Imininingwane

Firefox won't open so there isn't any.

Umnikazi wombuzo

The popup with the message "Couldn't load XRE functions." is coming from XULRunner.

The popup with the message "Couldn't load XRE functions." is coming from XULRunner.
karla_n_spike 1 izisombululo 1 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

I had the same problem. I am running Zone Alarm. Went in and changed the setting in the 'Internet Protected' part, turned off Browser Virtualization. And no more popups from XUL Runner. Firefox opens just fine.

I had the same problem. I am running Zone Alarm. Went in and changed the setting in the 'Internet Protected' part, turned off Browser Virtualization. And no more popups from XUL Runner. Firefox opens just fine.

Umnikazi wombuzo

Same here. Good catch. Have you let Zone Alarm know about this incompatibility?

Same here. Good catch. Have you let Zone Alarm know about this incompatibility?

Umnikazi wombuzo

The problem with Zone Alarm and Win 7 did not occur on my XP laptop. Firefox 7.0 opened normally even with Browser Visualization turned on.

The problem with Zone Alarm and Win 7 did not occur on my XP laptop. Firefox 7.0 opened normally even with Browser Visualization turned on.
Arbyem 0 izisombululo 3 izimpendulo
Kuphostiwe

Hi: I just posted a question regarding the same problem. I have not yet received a response. However, I just happened to try running Firefox 7.0.1 in Administrator Mode, and Firfox opened! I have recently performed an In-Place Upgrade of my HP dv9820 laptop from Vista Home Premium x64 to Win 7 HP x64, and upgrades to my Firefox (from 6.0.2) and, of course all of the many updates for Win 7. I also have Zone Alarm Extreme Security 2011, but I have yet to try the solution above from karla_n_spike. Until Mozilla provides a resolution such that Firefox 7.0.1 does not have to run from Administarator Mode, I will continue to do so. However, given that I receive the same error "XULRunner-couldn't load XRE function" whenever I activate a hotlink from an email or website (Firefox is my default browser), I will try changing my default to IE9. I would be grateful for any other insights into a more satisfactory resolution such that I could continue to use Firefox and my default browser. Appreciatively, Arbyem

Hi: I just posted a question regarding the same problem. I have not yet received a response. However, I just happened to try running Firefox 7.0.1 in Administrator Mode, and Firfox opened! I have recently performed an In-Place Upgrade of my HP dv9820 laptop from Vista Home Premium x64 to Win 7 HP x64, and upgrades to my Firefox (from 6.0.2) and, of course all of the many updates for Win 7. I also have Zone Alarm Extreme Security 2011, but I have yet to try the solution above from karla_n_spike. Until Mozilla provides a resolution such that Firefox 7.0.1 does not have to run from Administarator Mode, I will continue to do so. However, given that I receive the same error "XULRunner-couldn't load XRE function" whenever I activate a hotlink from an email or website (Firefox is my default browser), I will try changing my default to IE9. I would be grateful for any other insights into a more satisfactory resolution such that I could continue to use Firefox and my default browser. Appreciatively, Arbyem
camba78 0 izisombululo 1 izimpendulo
Kuphostiwe

Also got Firefox to load normally after changing the setting mentioned. But I don't know how important the protection is which I am losing by switching this setting to "off." Haven't tried on my laptop yet.

Also got Firefox to load normally after changing the setting mentioned. But I don't know how important the protection is which I am losing by switching this setting to "off." Haven't tried on my laptop yet.
Arbyem 0 izisombululo 3 izimpendulo
Kuphostiwe

Hi again: I tried the "disable browser virtualization" In my Zone Alarm Extreme Security 2011, as suggested in this post stream: https://bugzilla.mozilla.org/show_bug.cgi?id=689719 but it did not resolve the problem For my work-around to the inability to use hotlinks via Firefox, I can also open Firefox running under the Administrator, and copy and paste the hotlink, but that is a kludgy process to have to conduct. Besides, I want the Zone Alarm Extreme Security protection in the "browser virtualization" area. I await a more satisfactory resolution from Mozilla. Appreciatively, Arbyem

Hi again: I tried the "disable browser virtualization" In my Zone Alarm Extreme Security 2011, as suggested in this post stream: https://bugzilla.mozilla.org/show_bug.cgi?id=689719 but it did not resolve the problem For my work-around to the inability to use hotlinks via Firefox, I can also open Firefox running under the Administrator, and copy and paste the hotlink, but that is a kludgy process to have to conduct. Besides, I want the Zone Alarm Extreme Security protection in the "browser virtualization" area. I await a more satisfactory resolution from Mozilla. Appreciatively, Arbyem

Umnikazi wombuzo

I agree. Mozilla needs to address this issue so that the Zone Alarm functionality can be used. This problem does not affect Sea Monkey, another Mozilla browser, or any other browser as far as I am aware.

I agree. Mozilla needs to address this issue so that the Zone Alarm functionality can be used. This problem does not affect Sea Monkey, another Mozilla browser, or any other browser as far as I am aware.
Arbyem 0 izisombululo 3 izimpendulo
Kuphostiwe

Thanks for the confirmation. I had to use the kludgy approach of copying and pasting the URL from my email to a Firefox webpage opened using the run as Administrator mode. Hopefully, Mozilla will resolve this embarrassing problem. I also hope that they resolve a similar incompatibility that prevents Firefox from permitting my RoboForm2Go program to operate by displaying its toolbar as an acceptable add-on. Arbyem

Thanks for the confirmation. I had to use the kludgy approach of copying and pasting the URL from my email to a Firefox webpage opened using the run as Administrator mode. Hopefully, Mozilla will resolve this embarrassing problem. I also hope that they resolve a similar incompatibility that prevents Firefox from permitting my RoboForm2Go program to operate by displaying its toolbar as an acceptable add-on. Arbyem
kestrels 0 izisombululo 1 izimpendulo
Kuphostiwe

I also have the XRE problem with XP Pro. I'm pleased to hear that I'm not alone. I've no intention of altering Zone Alarm security settings. I have no problems using Chrome, IE or Safari. I expect Mozilla to address the issue.

I also have the XRE problem with XP Pro. I'm pleased to hear that I'm not alone. I've no intention of altering Zone Alarm security settings. I have no problems using Chrome, IE or Safari. I expect Mozilla to address the issue.
Panthera 0 izisombululo 2 izimpendulo
Kuphostiwe

Impendulo Ewusizo

This is from ZA - Of course, I'm running extreme!

We are beginning to send out auto updates for the Security tool bar (Conduit tool bar) and Web Security (Browser Virtualization, Site Check, Advanced download protection, etc...) This is a silent update

These are separate components that are integrated together.

Reason that we are late delivering compatibility for Firefox is that two different companies and development teams need to deliver both parts at the same time. But it not always possible that can be accomplish due to many issues not always we can control.

We are auto updating now for all paid products except for Extreme. (ZA Free is not updating also) We don't have an ETA for Extreme or ZA Free yet but when we do we will update this thread.

You can try to manually update the Conduit tool bar from there menu in the tool bar. You can also update Web Security from the setting section of web security in the ZA client.

We acknowledge the manual update does not always work. In these cases you will have to wait until the auto update gets delivered to your PC(s).

We hope this answers some of your questions and gives you a better idea how things work behind the scenes.

Also, check the version you're running. I clicked update and it said I was up to date. I went to the website and see I don't have the latest version. I don't know if it will help since I've got Extreme but I'd rather have the current version.

This is from [http://forums.zonealarm.com/showthread.php?t=77781 ZA] - Of course, I'm running extreme! We are beginning to send out auto updates for the Security tool bar (Conduit tool bar) and Web Security (Browser Virtualization, Site Check, Advanced download protection, etc...) This is a silent update These are separate components that are integrated together. Reason that we are late delivering compatibility for Firefox is that two different companies and development teams need to deliver both parts at the same time. But it not always possible that can be accomplish due to many issues not always we can control. We are auto updating now for all paid products except for Extreme. (ZA Free is not updating also) We don't have an ETA for Extreme or ZA Free yet but when we do we will update this thread. You can try to manually update the Conduit tool bar from there menu in the tool bar. You can also update Web Security from the setting section of web security in the ZA client. We acknowledge the manual update does not always work. In these cases you will have to wait until the auto update gets delivered to your PC(s). We hope this answers some of your questions and gives you a better idea how things work behind the scenes. Also, check the version you're running. I clicked update and it said I was up to date. I went to the website and see I don't have the [https://support.zonealarm.com/index.php?/Knowledgebase/Article/View/10/0/download-latest-version-of-zonealarm latest version]. I don't know if it will help since I've got Extreme but I'd rather have the current version.

Okulungisiwe ngu Panthera

Panthera 0 izisombululo 2 izimpendulo
Kuphostiwe

I updated my ZA Extreme and I can now open 7.0.1 normally.

I updated my ZA Extreme and I can now open 7.0.1 normally.
DavidBessire 0 izisombululo 2 izimpendulo
Kuphostiwe

In attempting to upgrade to Firefox 8.0, I get the error message "Cannot load XRE functions" and although Mozilla Firefox 8.0 is shown downloaded into Programs and Features, it won't open. I tried to Run as Administrator and get the same error message. I am not using Zone Alarm but do have Avast Anti-virus, XoftSpySE, Ad-Aware and ParetoLogic PC Health operating.

How can I complete installation of Firefox 8.0 and use it?

In attempting to upgrade to Firefox 8.0, I get the error message "Cannot load XRE functions" and although Mozilla Firefox 8.0 is shown downloaded into Programs and Features, it won't open. I tried to Run as Administrator and get the same error message. I am not using Zone Alarm but do have Avast Anti-virus, XoftSpySE, Ad-Aware and ParetoLogic PC Health operating. How can I complete installation of Firefox 8.0 and use it?
DavidBessire 0 izisombululo 2 izimpendulo
Kuphostiwe

I forgot to mention that I am using Windows 7 operating system in 32 bit.

I forgot to mention that I am using Windows 7 operating system in 32 bit.