Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

idm 6.07 build 9 (idm cc 7.3.6), downloadhelper 4.9.5 , googleEnhancer 1.87 , imtranslator 4.5 , and personas rotator 2.3 is disable or can't be used in my update aurora firefox 8.a2

  • 6 uphendule
  • 2303 zinale nkinga
  • 4742 views
  • Igcine ukuphendulwa ngu Rohman, M.A.

more options

firstly, i used aurora mozila firefox 6.a2.en US installer as my default browser aplication, with idm 6.07 installer as well as compatible after i update to be IDM CC 7.3.6 extention (enable), but after i update aurora mozila firefox in notification to 8.a2, its doesn't compatible with this version. other uncompalible extention is downloadhelper 4.9.5 , googleEnhancer 1.87 , imtranslator 4.5 , and personas rotator 2.3

All Replies (6)

more options

Don't use Aurora if you require specific extensions which haven't been up dated for 8.0a2 yet. Firefox 8.0 is over a couple of months from being released.

Best to stick with the Firefox 6.0.2 release version.
http://www.mozilla.com/en-US/firefox/

more options

i must to uninstall this version and take back the older version? if i install "firefox-6.0a2.en-US.win32.installer.exe" again, the updater will make some decision to make update this aurora 6.0a2 to 8.0a2, and what i doing in this brawser will be lost.

more options

No, as long as you don't select the option to Remove all Aurora personal data and customizations , you won't lose anything.

more options

used repair option? hha, thanks a lot, but aurora 8.0a2 have a better give than aurora 6.0a2, haven't it?

more options

You should install the latest Firefox 6.0.x version and not an older Firefox 6.0a2 test version that will keep you on the beta update channel an off the release channel.

Okulungisiwe ngu cor-el

more options

guys, in here i am use the latest version for "aurora mozilla firefox" from install at 6.0a2 installer i update to 8.0a2, its the newest but uncompatible with that extention.. firefox 6.0.x older than this version.