X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Middle mouse button not opening links in new tab anymore

Kuphostiwe

Sinc ea few days ago I can no longer open links in a new tab with my middle mouse button. All the other features in firefox that use it remain the same. (ie. middle click tab to close, tab bar to reopen last tab,scrolling.) I have changed no settings and have gone over them multiple times, but to na avail. Is it Firefox 6.0.1? Please help I like opening tabs without having to use a right click function.

Sinc ea few days ago I can no longer open links in a new tab with my middle mouse button. All the other features in firefox that use it remain the same. (ie. middle click tab to close, tab bar to reopen last tab,scrolling.) I have changed no settings and have gone over them multiple times, but to na avail. Is it Firefox 6.0.1? Please help I like opening tabs without having to use a right click function.

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

I updated to 6.0.1

Fakela amapulagi

  • np-mswmp
  • npdnu
  • npdnupdater2
  • Winamp Application Detector
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Unity Player 3.1.0f3
  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Activation Technologies Plugin for Mozilla
  • 4.0.60531.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 1.5

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

Eminye Imininingwane

OS Windows 7 64 bit. Firefox 6.0.1

David McRitchie 320 izisombululo 3092 izimpendulo
Kuphostiwe

I can only help you get around the problem (circumvention).

You could use the keyboard shortcuts that existed before Mozilla tried to usurp user control of the their middle-click button (mine is set to "Enter") Ctrl+click on link, and Ctrl+Shift+click on link.

Keyboard Shortcuts:

You might try updating to Firefox 6.0.2 via Help > About Firefox, but I doubt that it would affect that.

I can only help you get around the problem (circumvention). You could use the keyboard shortcuts that existed before Mozilla tried to usurp user control of the their middle-click button (mine is set to "Enter") Ctrl+click on link, and Ctrl+Shift+click on link. '''Keyboard Shortcuts:''' * Firefox Support Home Page | Firefox Help<br>Adapts to your system, but a very limited number of shortcuts are shown<br>https://support.mozilla.com/kb/Keyboard%20shortcuts * Firefox and other Browser Keyboard Shortcuts (Comparison Table)<br>Long list of shortcuts -- Windows oriented, most other systems use similar (Mac/Linux see key at top) <br>http://dmcritchie.mvps.org/firefox/keyboard.htm You might try updating to Firefox 6.0.2 via Help > About Firefox, but I doubt that it would affect that.

Okulungisiwe ngu David McRitchie

Umnikazi wombuzo

None of the shortcuts are working anymore either. I love firefox, but if it means using internet explorer I will have to switch

None of the shortcuts are working anymore either. I love firefox, but if it means using internet explorer I will have to switch
Rmkdec 0 izisombululo 1 izimpendulo
Kuphostiwe

This problem started for me today too.

Middle Click / CTRL Click links would not open those links in a new tab; though Middle Click would scroll the page as normal.

I fixed it by creating a new Firefox profile using Profile Manager, starting Firefox using the new profile (now Middle Click / CTRL click worked fine), closed Firefox and reopened it using my original profile - and Middle Click / CTRL click now work fine.

This problem started for me today too. Middle Click / CTRL Click links would not open those links in a new tab; though Middle Click would scroll the page as normal. I fixed it by creating a new Firefox profile using Profile Manager, starting Firefox using the new profile (now Middle Click / CTRL click worked fine), closed Firefox and reopened it using my original profile - and Middle Click / CTRL click now work fine.
Randomini 0 izisombululo 1 izimpendulo
Kuphostiwe

@Rmkdec: Made an account just to say thanks for this, it works perfectly now.

@Rmkdec: Made an account just to say thanks for this, it works perfectly now.

Okulungisiwe ngu Randomini

dustyflip 0 izisombululo 2 izimpendulo
Kuphostiwe

This would help if i knew how to get to profile manager, or what it is.. kind of a noob. Anyone have a simpler/more detailed explaination? Do I have to get an add-on? Thanks

This would help if i knew how to get to profile manager, or what it is.. kind of a noob. Anyone have a simpler/more detailed explaination? Do I have to get an add-on? Thanks
cor-el
  • Top 10 Contributor
  • Moderator
17584 izisombululo 159079 izimpendulo
Kuphostiwe

Impendulo Ewusizo

This can be a problem with Greasemonkey and Tab Mix Plus

See:

This can be a problem with Greasemonkey and Tab Mix Plus See: * [[/forums/contributors/707642]] * http://tmp.garyr.net/forum/viewtopic.php?f=2&t=15046

Okulungisiwe ngu cor-el

dustyflip 0 izisombululo 2 izimpendulo
Kuphostiwe

Thanks! Disabled grease monkey and now it works perfectly.

Thanks! Disabled grease monkey and now it works perfectly.
cor-el
  • Top 10 Contributor
  • Moderator
17584 izisombululo 159079 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You can also update to the unreviewed Greasemonkey 0.9.11:

You can also update to the unreviewed Greasemonkey 0.9.11: * https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/versions/
DC Cardwell 0 izisombululo 1 izimpendulo
Kuphostiwe

Thanks cor-el - this has been driving me nuts for days but I upgraded to Greasemonkey 0.9.11 and it fixed the problem for me :)

~DC

Thanks cor-el - this has been driving me nuts for days but I upgraded to Greasemonkey 0.9.11 and it fixed the problem for me :) ~DC