Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Does not recognize Firefox 6.0.dmg

  • 3 uphendule
  • 3 zinale nkinga
  • 57 views
  • Igcine ukuphendulwa ngu cor-el

more options

When I tried to download firefox 6.0, I got an error message "Fireofx 6.0.dmg is not regognized." The same thing happened over and over. What should I do?

All Replies (3)

more options

Isisombululo Esikhethiwe

more options

10.4.11. I got it. Thanks.

more options

Firefox 4 and later require at least OS X 10.5 and an Intel Mac.

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here: