X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 6 has high cpu consumption

Kuphostiwe

Hi,

I have just upgraded from Firefox 5.x to 6.0. I am using Windows 7 32-bit on a Dell Laptop, Core 2 duo, 4 GB RAM.

I have observed that FF seems to consume a lot more CPU than before.

Also, the memory footprint keeps changing rapidly. I don't have a physical memory issue.

The worrying factor is intermittent but unpredictable recurrence of high cpu usage when i open a new site, etc.

Adobe plugin does work but it is a bug CPU hog.

Please help provide a resolution as it seems like going back to 5.x is a better option at the moment since i didn't have much of an issue with FF 5.x.

Thanks, Anand

Hi, I have just upgraded from Firefox 5.x to 6.0. I am using Windows 7 32-bit on a Dell Laptop, Core 2 duo, 4 GB RAM. I have observed that FF seems to consume a lot more CPU than before. Also, the memory footprint keeps changing rapidly. I don't have a physical memory issue. The worrying factor is intermittent but unpredictable recurrence of high cpu usage when i open a new site, etc. Adobe plugin does work but it is a bug CPU hog. Please help provide a resolution as it seems like going back to 5.x is a better option at the moment since i didn't have much of an issue with FF 5.x. Thanks, Anand

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

Right after i upgraded to Firefox 6.0

Fakela amapulagi

  • Octoshape embedded video plugin
  • Google Update
  • Shockwave Flash 10.3 r183
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Version 1.1.8, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0

Eminye Imininingwane

burningmonk 0 izisombululo 1 izimpendulo
Kuphostiwe

I had this problem too. For me it was some kind of conflict with asghost.exe (works with my fingerprint scanner which I never use). When I terminated this process everything settled down.

I had this problem too. For me it was some kind of conflict with asghost.exe (works with my fingerprint scanner which I never use). When I terminated this process everything settled down.
babar 0 izisombululo 1 izimpendulo
Kuphostiwe

Same symptoms. Since updating to version 6, Firefox spikes to 100% CPU every ten minutes or so. It lasts for about twenty seconds.

Same symptoms. Since updating to version 6, Firefox spikes to 100% CPU every ten minutes or so. It lasts for about twenty seconds.
KennyBoy73 0 izisombululo 3 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Same symptoms as well. Have tried starting in safemode, disabling addons etc. as detailed in solutions elsewhere on this site, but the problem remains. Have completely uninstalled and reinstalled Firfox as well, but no good.

The problem happens instantly whenever I open a link in a new tab or have multiple tabs. The high load (95-100%) does not reduce from this point on and the only solution is to kill Firefox. I'm running XP SP3 on AMD 64 platform.

Same symptoms as well. Have tried starting in safemode, disabling addons etc. as detailed in solutions elsewhere on this site, but the problem remains. Have completely uninstalled and reinstalled Firfox as well, but no good. The problem happens instantly whenever I open a link in a new tab or have multiple tabs. The high load (95-100%) does not reduce from this point on and the only solution is to kill Firefox. I'm running XP SP3 on AMD 64 platform.
Idris Isiktan 0 izisombululo 8 izimpendulo
Kuphostiwe

I have the same problem. I could not find a solution yet. Shall I go back to FF 5?

I have the same problem. I could not find a solution yet. Shall I go back to FF 5?
Hasan 469 izisombululo 5600 izimpendulo
Kuphostiwe

Troubleshooting extensions and themes

Clear Cookies & Cache

Clear the Network Cache

Update All your Firefox Plugins

Troubleshooting plugins

Check and tell if its working.

Troubleshooting extensions and themes * https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes Clear Cookies & Cache * https://support.mozilla.com/en-US/kb/Template:clearCookiesCache Clear the Network Cache * https://support.mozilla.com/en-US/kb/How%20to%20clear%20the%20cache#w_clear-the-cache Update All your Firefox Plugins * https://www-trunk.stage.mozilla.com/en-US/plugincheck/ * http://www.mozilla.com/en-US/plugincheck/ ** Remove Checkmark from Downloading other Optional Softwares with your Plugins (e.g. Toolbars, McAfee, Google Chrome, etc.) Troubleshooting plugins * https://support.mozilla.com/en-US/kb/Troubleshooting%20plugins Check and tell if its working.

Okulungisiwe ngu Hasan

Idris Isiktan 0 izisombululo 8 izimpendulo
Kuphostiwe

I tried this today, and it is working now: Click Firefox > Options > Options > Advanced ... then Uncheck the option "Use hardware acceleration when available"

I tried this today, and it is working now: Click Firefox > Options > Options > Advanced ... then Uncheck the option "Use hardware acceleration when available"
cjreeve 0 izisombululo 3 izimpendulo
Kuphostiwe

I tried the above suggestions (clearing cache and cookies, clearing network cache, disabling all plugins and extensions, and disabling hardware acceleration) but it did not help.

I notice firefox goes straight to 100% CPU when I click on the history menu but not on other menus. There seems to be a pattern at other times it enters a 100% CPU phase but I have not figured out the pattern yet.

I am using Mac OS 10.6.8

I really like the tab grouping feature. Well done. Chris

I tried the above suggestions (clearing cache and cookies, clearing network cache, disabling all plugins and extensions, and disabling hardware acceleration) but it did not help. '''I notice firefox goes straight to 100% CPU when I click on the history menu but not on other menus.''' There seems to be a pattern at other times it enters a 100% CPU phase but I have not figured out the pattern yet. I am using Mac OS 10.6.8 I really like the tab grouping feature. Well done. Chris
Hasan 469 izisombululo 5600 izimpendulo
Kuphostiwe
Firefox Consumes a lot of CPU Resources * https://support.mozilla.com/en-US/kb/Firefox%20consumes%20a%20lot%20of%20CPU%20resources * http://kb.mozillazine.org/Firefox_CPU_usage High Memory Usage * https://support.mozilla.com/en-US/kb/High%20memory%20usage * http://kb.mozillazine.org/Reducing_memory_usage_-_Firefox Check and tell if its working.
cjreeve 0 izisombululo 3 izimpendulo
Kuphostiwe

Sorry none of those suggestions are helpful. I already run a flash blocker and have also tried disabling it, I don't view PDFs within Firefox and surely Firefox should be able to handle any JavaScript on a fresh start with only this very page? Firefox does not hog the RAM when the CPU problem occurs.

Still if I to the history menu Firefox hogs the CPU and becomes unresponsive for up to 2 mins. It is very frustrating and there are only so many times I can test it because the time quickly adds up. I'm actually considering moving over to another browser until this issue is repaired.

Should I bother try to reinstall or are there other configuration files I can delete/reset?

Cheers, Chris

Sorry none of those suggestions are helpful. I already run a flash blocker and have also tried disabling it, I don't view PDFs within Firefox and surely Firefox should be able to handle any JavaScript on a fresh start with only this very page? Firefox does not hog the RAM when the CPU problem occurs. Still if I to the history menu Firefox hogs the CPU and becomes unresponsive for up to 2 mins. It is very frustrating and there are only so many times I can test it because the time quickly adds up. I'm actually considering moving over to another browser until this issue is repaired. Should I bother try to reinstall or are there other configuration files I can delete/reset? Cheers, Chris

Okulungisiwe ngu cjreeve

Hasan 469 izisombululo 5600 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Firefox Hangs opening the History menu or the History sidebar * https://support.mozilla.com/en-US/kb/Firefox%20hangs#w_hang-opening-the-history-menu-or-the-history-sidebar * http://kb.mozillazine.org/Firefox_hangs#Hang_using_page_history Check and tell if its working.
cjreeve 0 izisombululo 3 izimpendulo
Kuphostiwe

Works! I cleared my browser history (reluctantly) and it does not hang whenever I go to my history menu any more. I'll come back to you if it stills periodically hangs. Thanks for you help and sorry it was not an interesting problem/solution + but I hope other people's solutions are as simple. Cheers.

Works! I cleared my browser history (reluctantly) and it does not hang whenever I go to my history menu any more. I'll come back to you if it stills periodically hangs. Thanks for you help and sorry it was not an interesting problem/solution + but I hope other people's solutions are as simple. Cheers.
KennyBoy73 0 izisombululo 3 izimpendulo
Kuphostiwe

Tried all of the above and have disabled every extension and plugin, but it is still going to 95-100% CPU load and the memory usage increases at the same time.

Tried all of the above and have disabled every extension and plugin, but it is still going to 95-100% CPU load and the memory usage increases at the same time.
Hasan 469 izisombululo 5600 izimpendulo
Kuphostiwe

@KennyBoy73 Create a New Profile as a test to check if your current profile is causing the problems.

-> Basic Troubleshooting: Make a New Profile

-> If that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile.

-> Recovering important data from an old profile

Check and tell if its working.

'''@KennyBoy73''' Create a New Profile as a test to check if your current profile is causing the problems. -> Basic Troubleshooting: Make a New Profile * https://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile -> If that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile. -> Recovering important data from an old profile * https://support.mozilla.com/en-US/kb/Recovering%20important%20data%20from%20an%20old%20profile Check and tell if its working.

Okulungisiwe ngu Hasan

KennyBoy73 0 izisombululo 3 izimpendulo
Kuphostiwe

Well, creating a new profile appears to have done the trick this time. I tried that before I posted to this forum, but there was no difference. But FF has been running OK all day today. Thanks for your help mha007

Well, creating a new profile appears to have done the trick this time. I tried that before I posted to this forum, but there was no difference. But FF has been running OK all day today. Thanks for your help mha007