X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox always re-opens full screen, regardless of previous state.

Kuphostiwe

Firefox always re-opens full screen, regardless of previous state. VERY annoying on a wide screen monitor. How do I fix this?

Firefox always re-opens full screen, regardless of previous state. VERY annoying on a wide screen monitor. How do I fix this?

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

27th July 2011

Fakela amapulagi

  • getplusplusadobe16291
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • BlackBerry WebSL Browser Plug-In
  • Reader Library Helper Plugin
  • Google Update
  • Wacom Dynamic Link Library

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

Eminye Imininingwane

the-edmeister
  • Top 25 Contributor
  • Moderator
5397 izisombululo 40140 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Are you talking about Maximized vs Full Screen, where all the toolbars are hidden and they appear when you move the cursor to the top of the screen?

Are you talking about Maximized vs Full Screen, where all the toolbars are hidden and they appear when you move the cursor to the top of the screen?

Umnikazi wombuzo

Full screen, not maximized, i.e. the size can be changed by dragging corners.

Full screen, not maximized, i.e. the size can be changed by dragging corners.
Hasan 469 izisombululo 5600 izimpendulo
Kuphostiwe

-> press F11 to bring the browser out of Full Screen

-> Tap ALT key or press F10 to show the Menu Bar

-> go to View Menu -> Toolbars -> select Menu Bar and Navigation ToolBar

Check and tell if its working.

-> press '''F11''' to bring the browser out of Full Screen -> Tap '''ALT''' key or press '''F10''' to show the Menu Bar -> go to View Menu -> Toolbars -> select '''Menu Bar''' and '''Navigation ToolBar''' Check and tell if its working.
Xircal 334 izisombululo 3835 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Please do the following.

  1. Right click the shortcut you use to launch Firefox and choose "Properties".

  2. In the "Run" field, change it to 'Normal window" if it says "Maximized".

  3. If it already says "Normal Window", the proceed as follows.

  4. Start Firefox and click the orange Firefox button, then go to Options | Options | Content.

  5. Click the "Advanced" button to the right of Enable Javascript and remove the checkmark from "Move or resize existing windows".

  6. Click OK/OK to close the menu.

  7. Grab the resizer corner of Firefox and resize it to you liking.

  8. Next, Hold down CTRL while you click the Close button (the "X")

When you restart Firefox, it should retain the size you chose. And since you will have disabled the ability of a script to resize the window, you shouldn't be bothered by that problem anymore.


If this suggestion fixes the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same subject.

Thanks.

Please do the following.<br><br> #Right click the shortcut you use to launch Firefox and choose "'''Properties'''".<br><br> #In the "Run" field, change it to ''''Normal window'''" if it says "''Maximized''".<br><br> #If it already says "Normal Window", the proceed as follows.<br><br> #Start Firefox and click the orange Firefox button, then go to '''Options '''| '''Options '''| '''Content'''.<br><br> #Click the "'''Advanced'''" button to the right of ''Enable Javascript'' and remove the checkmark from "'''Move or resize existing windows'''".<br><br> #Click OK/OK to close the menu.<br><br> #Grab the resizer corner of Firefox and resize it to you liking.<br><br> #Next, Hold down CTRL while you click the Close button (the "X")<br> When you restart Firefox, it should retain the size you chose. And since you will have disabled the ability of a script to resize the window, you shouldn't be bothered by that problem anymore.<br><br> ---- If this suggestion fixes the problem for you, please click the '''Solved it''' button next to this post after you log in into the forum. This will help others searching for a solution to the same subject. Thanks.

Umnikazi wombuzo

Sorry, hasn't worked, still same size.

Sorry, hasn't worked, still same size.
Xircal 334 izisombululo 3835 izimpendulo
Kuphostiwe

Try running Firefox in Troubleshoot Firefox issues using Safe Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.

Try running Firefox in [[Safe Mode]]. If it functions properly in that configuration, then one of your add-ons is the culprit.

Umnikazi wombuzo

Seemed to work Ok in safe mode. Disabled all add-ons and makes no difference, still full screen. Very weird as I don't know what caused it.

Seemed to work Ok in safe mode. Disabled all add-ons and makes no difference, still full screen. Very weird as I don't know what caused it.
Hasan 469 izisombululo 5600 izimpendulo
Kuphostiwe

here's what i think you should do:

-> press F11 to keep your browser in Full Screen mode -> move your Mouse Pointer to the top towards Minimize button -> right-click and unselect Hide Toolbars

-> again press F11 to exit FullScreen mode -> right-click on Tab strip and select Navigation Toolbar

-> Close Firefox (ALT + F -> Exit) -> Restart Firefox

Check and tell if its working.

here's what i think you should do: -> press '''F11''' to keep your browser in '''Full Screen''' mode -> move your Mouse Pointer to the top towards Minimize button -> right-click and unselect '''Hide Toolbars''' -> again press '''F11''' to exit '''FullScreen''' mode -> right-click on '''Tab strip''' and select '''Navigation Toolbar''' -> Close Firefox (ALT + F -> Exit) -> Restart Firefox Check and tell if its working.

Okulungisiwe ngu Hasan

Xircal 334 izisombululo 3835 izimpendulo
Kuphostiwe

You can do the following, but be aware that you will lose any customizations you made. By that I mean changes to the layout, extra buttons added etc.

  1. Click Help | Restart with Add-ons disabled.

  2. Firefox will close and you'll see a menu appear.

  3. Checkmark the option called "Reset all user preferences to Firefox defaults".

  4. Click the button called "Make changes and restart".

If it starts full screen, click the normal button to the left of the Close button (X)


If this suggestion fixes the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same subject.

Thanks.

You can do the following, but be aware that you will lose any customizations you made. By that I mean changes to the layout, extra buttons added etc.<br><br> #Click '''Help '''| '''Restart with Add-ons disabled'''.<br><br> #Firefox will close and you'll see a menu appear.<br><br> #Checkmark the option called "'''Reset all user preferences to Firefox defaults'''".<br><br> #Click the button called "'''Make changes and restart'''".<br> If it starts full screen, click the normal button to the left of the Close button (X) ---- If this suggestion fixes the problem for you, please click the '''Solved it''' button next to this post after you log in into the forum. This will help others searching for a solution to the same subject. Thanks.

Umnikazi wombuzo

Nope, still no go.

Nope, still no go.

Umnikazi wombuzo

Still the same.

Still the same.

Umnikazi wombuzo

Would love to say it worked, really would. But it didn't. Maybe I'll go back to IE9 (horror of horrors)

Would love to say it worked, really would. But it didn't. Maybe I'll go back to IE9 (horror of horrors)
Xircal 334 izisombululo 3835 izimpendulo
Kuphostiwe

Try creating a new Profile. See these articles.


If this suggestion fixes the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same subject.

Thanks.

Try creating a new Profile. See these articles.<br><br> * [[Profiles]]<br><br> * [[Managing Profiles]]<br><br> * [[Recovering important data from an old profile]]<br><br> ---- If this suggestion fixes the problem for you, please click the '''Solved it''' button next to this post after you log in into the forum. This will help others searching for a solution to the same subject. Thanks.

Umnikazi wombuzo

Will give it a go tomorrow, getting a bit of flak from she who must be obeyed. Thanks for the help, will get back to you when I've tried it. Regards. Geoff

Will give it a go tomorrow, getting a bit of flak from she who must be obeyed. Thanks for the help, will get back to you when I've tried it. Regards. Geoff
AliceWyman
  • Moderator
240 izisombululo 2594 izimpendulo
Kuphostiwe

The problem could be a corrupt localstore.rdf file, which you can solve by restarting in Firefox Troubleshoot Firefox issues using Safe Mode and choosing the option "Reset toolbars and controls", then "Make Changes and Restart".

Ref: Changes to toolbars and window sizes are not saved

The problem could be a corrupt ''localstore.rdf'' file, which you can solve by restarting in Firefox [[Safe Mode]] and choosing the option "'''Reset toolbars and controls'''", then "'''Make Changes and Restart'''". Ref: [[Toolbar keeps resetting]]
Xircal 334 izisombululo 3835 izimpendulo
Kuphostiwe

Glad I'm still single :P

Glad I'm still single :P
Xircal 334 izisombululo 3835 izimpendulo
Kuphostiwe

@ AliceWyman, would resetting all user preferences to Firefox defaults not override that setting?

@ ''AliceWyman'', would resetting all user preferences to Firefox defaults not override that setting?
cor-el
  • Top 10 Contributor
  • Moderator
17468 izisombululo 157853 izimpendulo
Kuphostiwe

No. You need to use "Reset toolbars and controls" to do that and not reset preferences.

No. You need to use "Reset toolbars and controls" to do that and not reset preferences.

Umnikazi wombuzo

There are advantages, don't have to do my own ironing, cooking or cleaning, but then I've always been a male chauvinist pig. Wouldn't change.

There are advantages, don't have to do my own ironing, cooking or cleaning, but then I've always been a male chauvinist pig. Wouldn't change.

Umnikazi wombuzo

Don't know what happened, haven't done anything else since yesterday and now it works fine. Maybe Mozilla should try getting things right before introducing new versions.

Don't know what happened, haven't done anything else since yesterday and now it works fine. Maybe Mozilla should try getting things right before introducing new versions.