Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I did a dumb thing and clicked on "Start Private Browsing". Ever since then I have not been able to set my home page in Firefox. I have tried dozens of times and each time I close Firefox and re-open it - My homepage is BLANK.

  • 3 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu cor-el

more options

This is so frustrating and this question/answer place is my last resort. How do I get my favorite home page back? Sure hope you can help me.

All Replies (3)

more options

go to Tools Menu -> Options -> Privacy -> Firefox will: select "Use custom settings for history" -> REMOVE Checkmark from "Permanent Private Browsing mode"

-> Now place Checkmarks on:

1) Remember my Browsing History

2) Remember Download History

3) Remember Search History

4) Accept Cookies from sites -> select "Exceptions..." button -> Click "Remove All Sites" at the bottom of "Exception - Cookies" window

    4a) Accept Third-party Cookies -> under "Keep Until" select "They Expire"

-> REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES

-> Click OK on Options window.

Check and tell if its working.

Okulungisiwe ngu Hasan

more options

That didn't help. I set my home page in Tools, Options, General. I put in the address for my home page and the page comes up. For some reason ??? I have to ALLOW my home page to open. I click on ALLOW and it keeps coming back up. I close Firefox and re-open it. My home page still says "about:blank".

more options

See:

  • Firefox/Tools > Options > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

See also:


Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

If the home page setting doesn't keep then see:


Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).