Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why do my add-ons don't work? Thanks.

  • 5 uphendule
  • 33 zinale nkinga
  • 315 views
  • Igcine ukuphendulwa ngu aknight

more options

WOT, Download Statusbar, Speed Dial, Video Downloadhelper add-ons didn't work in Firefox 5 nor in Firefox 6 beta. They are all enabled and compatible with the exception of Video Downloadhelper which is not compatible with Firefox 6 beta. They do not show up in my customize toolbar.

All Replies (5)

more options

The Status Bar has been replaced by the Add-on bar try "Ctrl+/" (toggles on/off). You will not see items in Customize if they are in a toolbar. The Add-on bar is not quite fully integrated as a toolbar. It is the only toolbar to have its very own keyboard shortcut. Toggling the shortcut is the same as turning it on/off through the ["Alt" >] View>Toolbars or through "Firefox" button > options (on the right-hand column)

You can make Firefox Firefox 5.0 look like Firefox 3.6.18, see numbered items 1-10 in the following topic Fix Firefox 4.0 toolbar user interface, problems (Make Firefox 5.0, or 4.0.1, look like 3.6).

more options

> go Tools Menu -> Clear Recent History -> Time range to clear: select EVERYTHING -> click Details (small arrow) button -> place Checkmarks on ALL Options -> click "Clear Now"

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE any Unwanted/Suspicious Extension (add-ons) -> Restart Firefox

Check and tell if its working.

Okulungisiwe ngu Hasan

more options

I tried both options and it is still not working. However I did remove a Unwanted/Suspicious Extension (add-ons) - Facetheme. I never have heard of it nor do I have any idea how it got there in the first place. Thanks though.

more options

go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. Now do this:

-> Update ALL your Firefox Plug-ins https://www.mozilla.com/en-US/plugincheck/

-> go to View Menu -> Zoom -> click "Reset"

-> go to View Menu -> Page Style -> select "Basic Page Style"

-> go to View Menu -> Toolbars -> unselect all unwanted toolbars

-> go Tools Menu -> Clear Recent History -> Time range to clear: select EVERYTHING -> click Details (small arrow) button -> place Checkmarks on ALL Options -> click "Clear Now"

-> go to Tools Menu -> Options -> General -> When Firefox starts : select "Show My Home Page" -> Type the address of the website which you want to be your HomePage e.g. http:www.google.com -> place Checkmark on "Show the Downloads window when downloading a file" -> select Radio Button option2 "Always ask me where to save files"

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows

2) Load images automatically

3) Enable JavaScript

-> go to Tools Menu -> Options -> Privacy -> History section -> Firefox will: select "Use custom settings for history" -> PLACE CHECKMARKS on:

1) Remember my Browsing History

2) Remember Download History

3) Remember Search History

4) Accept Cookies from sites -> select "Exceptions..." button -> Click "Remove All Sites" at the bottom of "Exception - Cookies" window

 4a) Accept Third-party Cookies -> under "Keep Until" select "They Expire"

-> REMOVE CHECKMARK from Last Option (CLEAR HISTORY WHEN FIREFOX CLOSES)

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons

2) Block reported attack sites

3) Block reported web forgeries

-> Click OK on Options window

-> click the Favicon (small drop down menu icon) on Firefox SearchBar (its position is on the Right side of the Address Bar) -> click "Manage Search Engines" -> select all Unwanted Search Engines and click Remove -> click OK

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious Extensions (Add-ons) -> Restart Firefox

You can enable your Known & Trustworthy Add-ons later. Check and tell if its working.

more options

Most of what you had written was already set up on my computer after going through each individual step the only differences in the tools then option menu was the homepage where mine was chrome://speeddial/content/speeddial.xul and the place Checkmark on "Show the Downloads window when downloading a file" -> select Radio Button option2 "Always ask me where to save files". I just have them always saved to my downloads folder as well as having the option of the 'show the downloads window when downloading a file' option with a red X.

I appreciate the help but still no lucking in making it so these add-ons actually work. I have gone through each add-ons options menu and made sure everything was correct before posting this question still didn't work. Perhaps someone can learn from your advice.