Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

It seems outrageous to many of us that Firefox 4.0 would no longer be backwards compatible with at least one previous OS such as Tiger!

  • Akukho zimpendulo
  • 2 zinale nkinga
  • 1 view
more options

When I first attempted to upgrade to 4.0 on my workstations that still use Tiger, I get a message saying that “the current system is not compatible with the new version of Firefox”. So why force people to upgrade their OS, before they can upgrade their browser? And how can I send you any feedback (besides this email) if I need to have 4.0 to be able to even write to you?

   Why don’t you provide an email address along with your physical address, so people can reach you whether or not they have

the current version of Firefox???

I won’t upgrade my Operating System until I am ready, not because Firefox says so.

carlos.ubriaco@warnerbros.com Digital Imaging Technician Warner Bros. Studios Photo Lab