X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

what does it mean that i do not have sufficient priviledges to finish update of version 4 on my mac?

Kuphostiwe

I have just downloaded version 4. After dragging the icon into the application folder I get a box that says the installation will not complete because I have insufficient privileges. What does that mean and what is the blasted fix?

I have just downloaded version 4. After dragging the icon into the application folder I get a box that says the installation will not complete because I have insufficient privileges. What does that mean and what is the blasted fix?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Netscape Navigator Default Plug-in
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Shockwave Flash 10.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Eminye Imininingwane

Toby 3 izisombululo 19 izimpendulo
Kuphostiwe

First, confirm that your account is an Admin account - in the Apple menu, choose System Preferences, then Accounts. Yours should say "Admin", as opposed to "Standard". If your account isn't an Admin account, you'll need to ask whoever has an Admin account to either install Firefox, or to give your account Admin status. If it is, I would suggest that you Repair Permissions on your Mac, either by booting from the gray DVD that came with it, and choosing Disk Utility from the menu bar, or by using the free tool OnyX .

First, confirm that your account is an Admin account - in the Apple menu, choose System Preferences, then Accounts. Yours should say "Admin", as opposed to "Standard". If your account isn't an Admin account, you'll need to ask whoever has an Admin account to either install Firefox, or to give your account Admin status. If it is, I would suggest that you Repair Permissions on your Mac, either by booting from the gray DVD that came with it, and choosing Disk Utility from the menu bar, or by using the free tool [http://en.wikipedia.org/wiki/OnyX OnyX] .

Okulungisiwe ngu Toby

cor-el
  • Top 10 Contributor
  • Moderator
17860 izisombululo 161609 izimpendulo
Kuphostiwe

If you get an error message that you do not have sufficient permissions to update then easiest is to trash the currently installed version to do a clean install of the new version.

Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data.

If you get an error message that you do not have sufficient permissions to update then easiest is to trash the currently installed version to do a clean install of the new version. * Download a new copy of the Firefox program and save the DMG file to the desktop * Firefox 4.0.x: http://www.mozilla.com/en-US/firefox/all.html * Firefox 3.6.x: http://www.mozilla.com/en-US/firefox/all-older.html * Trash the current Firefox application to do a clean (re-)install * Install the new version that you have downloaded Your profile data is stored elsewhere in the [http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox Profile Folder], so you won't lose your bookmarks and other personal data.

Umnikazi wombuzo

Thanks for the quick response. I opened the account under system preferences and see that I am the listed administrator for this account. Since that is so, does this mean that the repairing permissions you wrote about is needed or is there another step I must do before that?

Thanks for the quick response. I opened the account under system preferences and see that I am the listed administrator for this account. Since that is so, does this mean that the repairing permissions you wrote about is needed or is there another step I must do before that?

Umnikazi wombuzo

Thank you both very much. The deleting of my older version cleared the problem and I am now operating on version 4. I appreciate the prompt assistance.

Thank you both very much. The deleting of my older version cleared the problem and I am now operating on version 4. I appreciate the prompt assistance.