Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.


  • 12 uphendule
  • 26 zinale nkinga
  • Igcine ukuphendulwa ngu K.M.Mitul

more options

All of a sudden, when I put a subject in the Yahoo search engine, and I get all the "hits" listed, I can no longer just click on them and they go to the web site. NOW each time I get a box titled "Opening" that say "You have chosen to open" and then says things like "which is a: application/octet-stream' and "from: http//". Then "What should firefox do with that file?" and I can choose "Open with [Browse]" or "Save File" with an "OK" and "Cancel" button. When I try "Open with" and use Browse I get lots of choices but none of them will work. What changed? Do I have malware in my computer? I am ready to just give up on FireFox and move to Chrome, which works just fine. Any help out there????

All Replies (12)

more options

Normally search results are regular web page sent to Firefox as text/html content. If the server indicates it is application/octet-stream content, then Firefox will treat it as a download. This definitely is not normal for search results.

Something is wrong with the way your Firefox is interacting with Yahoo. Assuming it's not something Yahoo changed, it could be malware, since malware has targeted search engine links in the past. Have you done a thorough scrubbing? To supplement your regular full-time antivirus software, you can try:


Malwarebytes Anti-Malware

more options

I have the same problem on a windows 7 computer and a windows XP computer also. Google search works fine without any problems on both computers. I also use Firefox on a Linux computer with yahoo search without any problems. The problem seems to only happen with the combination of windows, Firefox, and yahoo together. I hope someone finds the answer to this problem.

more options

Jsher 2000: Many thanks for taking time to reply. I did have both Superantispyware and malwarebytes on my computer, and the first one runs every day - the second I use now and then. So I ran a complete scan with both of them, and they found nothing but a few tracking cookies they removed. When that was all over I STILL have the problem. I have tried other search engines with YAHOO and the problem is not present - only with Firefox. It drives me nuts now because I love Firefox, and have many "Favorites" listed there. I am now thinking of removing Firefox from my computer and then loading it again from their web site, but I guess I would lose all my "Favorites" and have to start over again.....any ideas if removing and reloading might help???? Again, thanks...

more options

Whoa, don't uninstall. We're not done troubleshooting.

I think you might have to go through the (sometimes) painful process of looking for problems with add-ons or settings.

First, make a backup of your computer for safekeeping. To back up Firefox, see Backing up your information.

Next, try starting Firefox in Firefox Safe Mode. Be careful not to "reset" anything permanently if you didn't back up.

Does that fix it? If so, you can use the Safe Mode options to temporarily disable your add-ons, or you can individually disable nonessential ones.

If that isn't working, you can set up a new Firefox profile and move over your bookmarks and essential settings.

Creating a new (blank) profile: Managing profiles.

Moving key settings to the new profile: Recovering important data from an old profile.

Hope this helps.

more options

I disabled all my plugin's and add-ons ,then restarted one by one to see if any of those might be the culprit,but nothing changed ,its not any of them,but your suggestion to do the safe mode is something I have not tried,(and believe me I have logged many hours into researching this) it is not an isolated problem to just a hand full,but if you research octet stream in yahoo search you will find its a problem. I will try the safe mode now. Thanks

more options

You can also check the advanced settings for Firefox in the firewall and make sure that no content is blocked if the settings in Firefox are correct.

more options

Okay, I can replicate this on Firefox 3.6.16 on Windows XP. (On my new Windows 7 PC with Firefox 4, Yahoo seems to work fine.)

For some results, I get a strange partially blank popup. If I cancel the popup and click again the link works fine. In other cases, I get a partial page of gibberish. If I go back and click again, it works fine. This is pretty annoying.

The problem seems to be with the Yahoo tracking script. When you click a link, you will notice that instead of immediately displaying the destination URL in the status bar, there is a URL followed by a bunch of seemingly random characters.

I was using Yahoo logged out, but I'm not sure it makes any difference.

It is possible to bypass the Yahoo tracking links by rewriting part of the page. One approach would be a userscript, or there might be an add-on.

I posted a Greasemonkey userscript here: Yahoo Search Tracking Clean dirtyhref. This assumes you would be willing to install the Greasemonkey extension. (You can get that using the search box in the Add-ons dialog.)

more options

Upgrading to Firefox 4 solved the problem for me. Yahoo search works okay with windows xp as well as on windows 7 when using Firefox 4. I was able to upgrade without uninstalling Firefox 3 without any problems.

more options

Ok ,well I just got a email from Yahoo Support (I sent many,many)and in the beginning they kept insisting it was malware,or a virus,this now has changed. The email says they're currently investigating the issue and have determined that this is a problem on their end. They are working to resolve this. I do hope that a lot of people who are experiencing this have not let up on contacting Yahoo,and I do know that they are hard to contact,the support is not easily obtained,but you just have to be persistent till you get one person who is willing to go beyond the standard answer they give to a lot of problems people present to them..and this isn't just Yahoo,but others,who will automatically blame it on a virus,ad-ware,malware-or in this case even the firefox browser. So please submit your complaints to Yahoo this will make them work harder if they see how many people are effected . I did try the firefox safe mode that was brought up earlier,this did not do anything and I more or less felt it wouldn't,but wanted to give it a try. Now I will wait to see how long it takes for Yahoo to resolve this problem.

more options

Greetings, all. I'm the guy who started this string. I tried all the fixes suggested along the way and nothing helped, UNTIL..... I just downloaded FireFox 4.0, and EVERYTHING WORKS AGAIN! Yea!! I noted that it said about 4 addons were not compatible with the 4.0 version and would not be activated. Good! Whatever happened, I love my FireFox once again. Thanks to everyone for suggesting fixes. All the best WIL C. Greensboro, NC

more options

You may not have had to update your FireFox as this was a Yahoo Problem They confirmed it was on their end, and as I said in another Post Yahoo will not realize its their problem unless People contact Yahoo Support and complain. I was and am not ready to go to Firefox 4 (I like to wait awhile and hear the reviews on it first) And I troubleshooted everything I could and just knew it was not a Firefox problem.Then a Yahoo response email to me confirmed it. I found Yahoo working back to normal ,and am happy.I have returned to having MyYahoo as my Homepage as before. I would like to know what they found wrong just out of curiosity ,but as long as its working that's fine

more options

Assalamualikum,all.After goggling a lot on different sites I have come to an end to solve the problem.First of all this is not the problem of the browser but it is always better to be have updated version.

Solution 1:Check out your windows firewall,internet security soft & of course internet filter soft.Make sure these are not denying network transmission & turn off any parental control & have administrator privilege.

Solution 2:Check your Firefox plugins & update those if necessary []

Solution 3:Run Firefox in "safe mode" remove all settings & restore to default.

Inshaallah your problem will be solved.

Okulungisiwe ngu K.M.Mitul