Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

how to let firefox to save all the open pages till next start?

  • 2 uphendule
  • 16 zinale nkinga
  • 2949 views
  • Igcine ukuphendulwa ngu Helper7677

more options

When I close firefox never ask me to save opened pages to be opened automatically on next firefox start ? how i can let this feature work in version 4.0?

All Replies (2)

more options

Go to Tools | Options | General and where it probably says "Show My Home Page", change it to "Show my windows and tabs from last time".

more options

"firefox never ask me to save opened pages to be opened automatically on next firefox start ? how i can let this feature work in version 4.0?"

One of the changes in Firefox 4: by default Firefox 4 does not display the "Save Tabs and Exit" warning message when closing multiple tabs, but it can be turned back on by changing some preferences.

  • Saving tabs was not removed from Firefox 4, but it works a bit differently.
  • By default, Firefox 4 will not ask to save tabs, but instead it will always save your tabs on exit unless you are in Private Browsing mode. You can restore them next time by:
    1. clicking Firefox button > History >"Restore Previous Session", or
    2. type about:home in the URL bar and press the Enter key, then press the "Restore Previous Session" button
  • Note: This was a decision by the developers. On this forum, we are all uncompensated volunteers here to help other users. The developes/employees of Mozilla/Firefox rarely, if ever visit here.

Some things to check:

  1. Browsing history must be saved
    • Firefox button: Firefox button > Options > Options > Privacy > [X] Remember my browsing history
    • Menu Bar: Tools > Options > Privacy > [X] Remember my browsing history
  2. Also make sure you do not clear "Browsing History" when using Clear Recent History or when closing Firefox
    • Using Clear Recent History
      • Firefox button: Firefox button > History >Clear Recent History
      • Menu Bar: Tools > Clear Recent History
    • When closing Firefox
  3. Make sure you are not in Private Browsing mode or in permanent Private Browsing mode:
  4. If you have theTab Mix Plusextension, then disable the built-in session restore.

To display the "Save Tabs and Exit" message when closing multiple tabs, you can do the following:

  1. Type about:config in the URL/Location/Address bar and press the Enter key
  2. Accept the warning message (promise to be careful)
  3. The preferences page/list will open
  4. Filter = browser.tabs.warnOnClose
  5. If its value is set to false, double-click on it (in the lower panel) to toggle its value to true
  6. Repeat steps 4 and 5 for these following 3 preferences also:
    • browser.warnOnQuit
    • browser.warnOnRestart
    • browser.showQuitWarning
  7. See:




You need to update the following:

  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  1. Check your plugin versions on either of the following links':
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox