X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable the "Prevent page from creating additional dialogs" checkbox

Kuphostiwe

I currently run a CRM application and we have always supported it only for Firefox. With the new feature, in Firefox 4, that gives the end user the ability to stop the page from creating dialogs, it has pretty much broken the application if a user checks this feature. One issue I have run into is, when an alert is needed to inform a user that they need to do something specific before they can complete a task, it does not alert them and they think the system is bugged because it is automatically assumed as OK and they never see the info. My question boils down to, is there something in the about:config that we can set up in our corporate login files that can be disabled for this?

I currently run a CRM application and we have always supported it only for Firefox. With the new feature, in Firefox 4, that gives the end user the ability to stop the page from creating dialogs, it has pretty much broken the application if a user checks this feature. One issue I have run into is, when an alert is needed to inform a user that they need to do something specific before they can complete a task, it does not alert them and they think the system is bugged because it is automatically assumed as OK and they never see the info. My question boils down to, is there something in the about:config that we can set up in our corporate login files that can be disabled for this?

Okulungisiwe ngu mfoote

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

Firefox 4 released

Fakela amapulagi

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Google Update
  • Pando Web Plugin
  • Shockwave Flash 10.2 r153
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.51204.0
  • NPWLPG

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Eminye Imininingwane

Have a alert that has information for the user to continue, they never see the alert, so don't know what is required of them to continue.

cor-el
  • Top 10 Contributor
  • Moderator
17668 izisombululo 159825 izimpendulo
Kuphostiwe

You can set the pref prompts.tab_modal.enabled to false on the about:config page to get the old appearance.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

You can set the pref <b>prompts.tab_modal.enabled</b> to false on the <b>about:config</b> page to get the old appearance. To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br />

Impendulo Ewusizo

I tried that one previously, its not the appearance that is the problem, its the check box "Prevent page from creating additional dialogs" that is the problem. I need something that completely disables/hides that. If i can find the setting for it, we can roll out a task that forces the setting on all our corporate machines.

Thanks.

I tried that one previously, its not the appearance that is the problem, its the check box "Prevent page from creating additional dialogs" that is the problem. I need something that completely disables/hides that. If i can find the setting for it, we can roll out a task that forces the setting on all our corporate machines. Thanks.

Umnikazi wombuzo

After working some more on this issue, I misspoke when I said it "automatically assumed as OK ", it doesn't assume anything, it just kills all dialogs. This is a small relief, at least people aren't going to be deleting records by accident because they hit the wrong button. I still would love a resolution if anyone has it.

After working some more on this issue, I misspoke when I said it "automatically assumed as OK ", it doesn't assume anything, it just kills all dialogs. This is a small relief, at least people aren't going to be deleting records by accident because they hit the wrong button. I still would love a resolution if anyone has it.
bacalov 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Finally... found a useful post or at least for me worked. http://forums.mozillazine.org/viewtopic.php?p=10737317#p10737317

Finally... found a useful post or at least for me worked. http://forums.mozillazine.org/viewtopic.php?p=10737317#p10737317

Okulungisiwe ngu bacalov

Dabnis 0 izisombululo 1 izimpendulo
Kuphostiwe

I have exactly the same problem with a web app. Once users check the box all AJAX dialog disappears, system ends up being none useable. I never thought that I would say this, but now we have to notify all users that services can not be provided via FireFox. I have read the fix, but end users are, well 'end users' most even don't even know what the address bar is!! We did try and notify them of the fix result-> total chaos.

While I'm here and just to note: The very short intervals between updates is causing many problems with plugins that are used in house for development. It seems that releasing updates every few weeks does not give add developers time to keep up resulting is plugins failing etc. Once again to my disgust we as a company have now bought commercial licensees for IE web development add ons and now use IE for all in house development.

What's gone wrong FireFox?

From a very disappointment EX Firefox user.

I have exactly the same problem with a web app. Once users check the box all AJAX dialog disappears, system ends up being none useable. I never thought that I would say this, but now we have to notify all users that services can not be provided via FireFox. I have read the fix, but end users are, well 'end users' most even don't even know what the address bar is!! We did try and notify them of the fix result-> total chaos. While I'm here and just to note: The very short intervals between updates is causing many problems with plugins that are used in house for development. It seems that releasing updates every few weeks does not give add developers time to keep up resulting is plugins failing etc. Once again to my disgust we as a company have now bought commercial licensees for IE web development add ons and now use IE for all in house development. What's gone wrong FireFox? From a very disappointment EX Firefox user.

Okulungisiwe ngu Dabnis

cor-el
  • Top 10 Contributor
  • Moderator
17668 izisombululo 159825 izimpendulo
Kuphostiwe

You need to reload and and bypass the cache to rest such an disable action.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) or "Cmd + Shift + R" (MAC)

Users can disable that feature by setting the pref dom.successive_dialog_time_limit to zero, but as a web developer there is nothing that you can do unless you would delay such a pop-up as it only happens if such subsequent alerts appear too quickly.

You need to reload and and bypass the cache to rest such an disable action. * Press and hold Shift and left-click the Reload button. * Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) or "Cmd + Shift + R" (MAC) Users can disable that feature by setting the pref dom.successive_dialog_time_limit to zero, but as a web developer there is nothing that you can do unless you would delay such a pop-up as it only happens if such subsequent alerts appear too quickly.

Okulungisiwe ngu cor-el

greendraw 1 izisombululo 2 izimpendulo
Kuphostiwe

i don't find "dom.successive_dialog_time_limit" property in FF9.0.1

i don't find "dom.successive_dialog_time_limit" property in FF9.0.1
cor-el
  • Top 10 Contributor
  • Moderator
17668 izisombululo 159825 izimpendulo
Kuphostiwe

If you do not have the dom.successive_dialog_time_limit pref then you need to create a new Integer pref with that name and set the value to 0.

If you do not have the dom.successive_dialog_time_limit pref then you need to create a new Integer pref with that name and set the value to 0.