Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The back button is disabled even though I clearly visted the link through Google

  • 1 baphendule
  • 30 zinale nkinga
  • 68 views
  • Igcine ukuphendulwa ngu cor-el

more options

When I search for something in Google, and find a particular link interesting, I view it. But when I want to go back to my search list, it seems like the back button is disabled and it won't allow me to go back. This is obviously painful, if I am searching for a variety of things. The back button works perfectly sometimes but others it just doesn't. Can anyone explain this odd behavior?

Isisombululo esikhethiwe

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons (McAfee SiteAdvisor) is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Appearance/Themes).

  • Don't make any changes on the Safe mode start window.

See:

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (1)

more options

Isisombululo Esikhethiwe

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons (McAfee SiteAdvisor) is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Appearance/Themes).

  • Don't make any changes on the Safe mode start window.

See: