Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FF4 displaying all Arial text as bold since upgrade (Screenshot included)

  • 5 uphendule
  • 27 zinale nkinga
  • 14 views
  • Igcine ukuphendulwa ngu koinek

more options

Screenshot: http://i.imgur.com/4Ef0t.jpg

Comparison is between FF4 on top and Chrome below. See the text in the article to see the difference in font display. This occurs on just about every website that allows the browser to select the font (Google, Bing, etc.).

I've already tried looking at the content display options and set them to default. I've also exhaustively Googled this issue with no results that have been helpful.

This issue started as soon I upgraded to FF4. This issue did not occur in FF3

Screenshot: http://i.imgur.com/4Ef0t.jpg Comparison is between FF4 on top and Chrome below. See the text in the article to see the difference in font display. This occurs on just about every website that allows the browser to select the font (Google, Bing, etc.). I've already tried looking at the content display options and set them to default. I've also exhaustively Googled this issue with no results that have been helpful. This issue started as soon I upgraded to FF4. This issue did not occur in FF3

Isisombululo esikhethiwe

wow, what a coincidence that i just got this problem too (I installed Age of Empires yesterday).

to fix it, i went to this web site and downloaded the Arial font (not the Mizo Arial at the top, it's about five fonts down) and placed it over the Arial in my Windows/Fonts folder:

http://www.fonts101.com/search/ARIAL.aspx

good luck, and thanks for the help!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

hi, I was having the same problem, it started when I installed Age of Empires classic. It seems it installs a corrupted arial font, all you need to do is install a good version, you can get it here: http://web.nickshanks.com/fonts/microsoft-core-web-fonts. You can run the installer as administrator or use 7-zip to extract the fonts and copy then manually to C:\Windows\Fonts.

more options

oh, I forgot to tell you: you need to install the arial32.exe from that site.

more options

I've done this before with no effect. :( Do I need to install in safe mode or something?

more options

Isisombululo Esikhethiwe

wow, what a coincidence that i just got this problem too (I installed Age of Empires yesterday).

to fix it, i went to this web site and downloaded the Arial font (not the Mizo Arial at the top, it's about five fonts down) and placed it over the Arial in my Windows/Fonts folder:

http://www.fonts101.com/search/ARIAL.aspx

good luck, and thanks for the help!

more options

Thank you thank you thank you FreyjasChosen, that worked perfectly.