X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

New, custom toolbars disapear after restarting Firefox 4. Is Firefox unable to save them for some reason?

Kuphostiwe

Hello, and first of all thank you for reading.

After restarting Firefox 4 (for any reason, e.g. add-ons), all the custom new toolbars will be missing.

I tried recreating them with or without certain tools to see if it was a specific tool that was preventing the entire toolbar from loading. No results though.

My opinion so far is that Firefox is unable to save any setting for some unknown reason. But then again is able to save bookmarks, add-ons and history... So the problem really is with the toolbars ONLY.

I've been using Firefox for a very long time, but this is the first time this happens to me.

The platform I'm using Firefox on is a Mac with OS X 10.6. I am not sure if this issue happens only on Macs or not.

Any help is welcome! Thank you.

Hello, and first of all thank you for reading. After restarting Firefox 4 (for any reason, e.g. add-ons), all the custom new toolbars will be missing. I tried recreating them with or without certain tools to see if it was a specific tool that was preventing the entire toolbar from loading. No results though. My opinion so far is that Firefox is unable to save any setting for some unknown reason. But then again is able to save bookmarks, add-ons and history... So the problem really is with the toolbars ONLY. I've been using Firefox for a very long time, but this is the first time this happens to me. The platform I'm using Firefox on is a Mac with OS X 10.6. I am not sure if this issue happens only on Macs or not. Any help is welcome! Thank you.

Okulungisiwe ngu Falxo

Isisombululo esikhethiwe

I solved by following the method described here: http://support.mozilla.com/en-US/kb/Toolbar%20keeps%20resetting

Hope it helps! ;-)

Funda le mpendulo ngokuhambisana nalesi sihloko 2

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

After updating to Firefox 4

Fakela amapulagi

  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6
  • DivX Web Player version 1.4.1.4
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Shockwave Flash 10.2 r152
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Eminye Imininingwane

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

furas 0 izisombululo 1 izimpendulo
Kuphostiwe

I had the same problem. My problem disapeared but I don't know exactly why.

I intended to star Firefox 4 in safe mode but I started my previous version 3.6.15. It asked for some add-ons updates so I let it do it (and after a while I killed proces because 3.6.15 starts too long ;) After that problem disapeared. Firefox 4 again remember custom toolbars.

I don't know what really happend. Maybe it overwrote some (config) files.

I had the same problem. My problem disapeared but I don't know exactly why. I intended to star Firefox 4 in safe mode but I started my previous version 3.6.15. It asked for some add-ons updates so I let it do it (and after a while I killed proces because 3.6.15 starts too long ;) After that problem disapeared. Firefox 4 again remember custom toolbars. I don't know what really happend. Maybe it overwrote some (config) files.

Umnikazi wombuzo

Well, I tried a couple of times to repeat your process, but it doesn't seem to do anything.

I launched Firefox 3.6 (which I must say, that one remembered my toolbars), and after downgrading and the add-ons and then I relaunched the Firefox 4 to (without letting to update anything)...

The problem still persist for me I'm afraid...

Is there anything else you can remember from doing the whole process?

Thank you for sharing though!

Well, I tried a couple of times to repeat your process, but it doesn't seem to do anything. I launched Firefox 3.6 (which I must say, that one remembered my toolbars), and after downgrading and the add-ons and then I relaunched the Firefox 4 to (without letting to update anything)... The problem still persist for me I'm afraid... Is there anything else you can remember from doing the whole process? Thank you for sharing though!
cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You can try: * http://kb.mozillazine.org/Corrupt_localstore.rdf

Umnikazi wombuzo

Read the article and I tried the following combinations:


-Delete completely the localstore.rdf file so it will create a new one when starting up: -No results

-Launched Firefox 3.6, made the customizations there and kept the its localstore.rdf and replaced it with the one FF 4 had created: -No results

-Deleted the localstore.rdf while FF4 was running, so it will create a new one while quiting the application and force it to write down and the customizations with the new file: -No results


This concludes me that it's able to write down the changes.... but its unable to load them on start up....

It's not possible to exit the app. without creating the localstore.rdf (which it must contain any modification done).

Read the article and I tried the following combinations: -Delete completely the localstore.rdf file so it will create a new one when starting up: -No results -Launched Firefox 3.6, made the customizations there and kept the its localstore.rdf and replaced it with the one FF 4 had created: -No results -Deleted the localstore.rdf while FF4 was running, so it will create a new one while quiting the application and force it to write down and the customizations with the new file: -No results This concludes me that it's able to write down the changes.... but its unable to load them on start up.... It's not possible to exit the app. without creating the localstore.rdf (which it must contain any modification done).

Okulungisiwe ngu Falxo

cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

Make sure that you place content like a Space element on a custom toolbar before closing the customize window. Empty toolbar are automatically removed.

Make sure that you place content like a Space element on a custom toolbar before closing the customize window. Empty toolbar are automatically removed.

Umnikazi wombuzo

Don't worry, I did that (Threw a couple tools like copy and paste).

Don't worry, I did that (Threw a couple tools like copy and paste).

Okulungisiwe ngu Falxo

iblis17 0 izisombululo 3 izimpendulo
Kuphostiwe

For fixing this problem temporality:

  • - i uesd vim to edit /usr/local/lib/firefox/chrome/browser.jar (environment: FreeBSD 8.2 Release) and seleceted content/browser/browser.xul .
  • -Just copied the block --
             <toolbar id="PersonalToolbar" 
             ....
             </toolbar>

and renamed the id.


i hope you can understand my grammar .... orz

For fixing this problem temporality: *- i uesd vim to edit /usr/local/lib/firefox/chrome/browser.jar (environment: FreeBSD 8.2 Release) and seleceted content/browser/browser.xul . *-Just copied the block -- &lt;toolbar id="PersonalToolbar" .... &lt;/toolbar&gt; and renamed the id. ----- i hope you can understand my grammar .... orz

Okulungisiwe ngu iblis17

Umnikazi wombuzo

Thank you for your reply.

There seems to be a problem here...

I checked the contents and, unlike Firefox 3.6, FF4 does not have either Chrome Folder or even a Browser.jar.

I copied the one from FF3.6 to the FF4... and see if it works....

Then, after no results from that, I tried checking the content of Browser.jar (with TextWrangler.app) and fix the Browser.xul as you said, but there was no browser.xul either...

Am I doing it wrong? Or is my Firefox 4 totally screwed up?

Thank you for your reply. There seems to be a problem here... I checked the contents and, unlike Firefox 3.6, FF4 does not have either Chrome Folder or even a Browser.jar. I copied the one from FF3.6 to the FF4... and see if it works.... Then, after no results from that, I tried checking the content of Browser.jar (with TextWrangler.app) and fix the Browser.xul as you said, but there was no browser.xul either... Am I doing it wrong? Or is my Firefox 4 totally screwed up?

Okulungisiwe ngu Falxo

cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

You are in the correct location of the Firefox Profile Folder ?

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
You are in the correct location of the [http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox Profile Folder] ? * Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Umnikazi wombuzo

Yep.

In the meantime I had the chance to re install FF4 to see if it was a folder creation failure...

I was still unlucky...

Yep. In the meantime I had the chance to re install FF4 to see if it was a folder creation failure... I was still unlucky...
cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

Does Firefox create a new file localstore.rdf in that profile folder?

Did you check the content of localstore,rdf with a text editor to see if there is section that refers to that toolbar. Firefox should write a new version of that file after closing the customize window and also on closing the Firefox application.

Does Firefox create a new file localstore.rdf in that profile folder? Did you check the content of localstore,rdf with a text editor to see if there is section that refers to that toolbar. Firefox should write a new version of that file after closing the customize window and also on closing the Firefox application.

Umnikazi wombuzo

Yes, there is actually.

Here's a part of it:

<RDF:Description RDF:about="chrome://browser/content/browser.xul#PersonalToolbar"

                  mode="icons"
                  collapsed="false"
                  currentset="history-button,personal-bookmarks,sessionmanager-undo,sessionmanager-toolbar,RIL_toolbar_button" />
 <RDF:Description RDF:about="chrome://adblockplus/content/ui/settings.xul#abpPreferencesWindow"
                  screenY="309"
                  sizemode="normal"
                  width="813"
                  height="585"
                  screenX="541" />

So, I guess that proves FF4 is unable to load them? It is able to save them after all....

Yes, there is actually. Here's a part of it: <RDF:Description RDF:about="chrome://browser/content/browser.xul#PersonalToolbar" mode="icons" collapsed="false" currentset="history-button,personal-bookmarks,sessionmanager-undo,sessionmanager-toolbar,RIL_toolbar_button" /> <RDF:Description RDF:about="chrome://adblockplus/content/ui/settings.xul#abpPreferencesWindow" screenY="309" sizemode="normal" width="813" height="585" screenX="541" /> So, I guess that proves FF4 is unable to load them? It is able to save them after all....
Sandro 0 izisombululo 2 izimpendulo
Kuphostiwe

I'm having the same problem

  • My FF toolbar didn't load & render but was in the localstore.rdf file
  • I created a new toolbar and loaded it up and then I restarted FF and the new toolbar didn't load & render but again was in the localstore.rdf file
  • I quit FF, deleted the localstore.rdf and restarted FF. I then created a new toolbar (with a new name) and added a couple of items and quit FF. The new localstore.rdf file was created and written to but when I restarted FF the new toolbar didn't load & render but again was in the localstore.rdf file

Please help and this is beyond frustrating

I'm having the same problem * My FF toolbar didn't load & render but was in the localstore.rdf file * I created a new toolbar and loaded it up and then I restarted FF and the new toolbar didn't load & render but again was in the localstore.rdf file * I quit FF, deleted the localstore.rdf and restarted FF. I then created a new toolbar (with a new name) and added a couple of items and quit FF. The new localstore.rdf file was created and written to but when I restarted FF the new toolbar didn't load & render but again was in the localstore.rdf file Please help and this is beyond frustrating

Okulungisiwe ngu Sandro

iblis17 0 izisombululo 3 izimpendulo
Kuphostiwe

The path of the lib may change with different OS. Please check the path.

i confirmed that FF4 has the chrome folder and browser.jar ...

The path of the lib may change with different OS. Please check the path. i confirmed that FF4 has the chrome folder and browser.jar ...
iblis17 0 izisombululo 3 izimpendulo
Kuphostiwe

i found another way (?) to view browser.xul ... :

  • Open a new tab on FF.
  • Type "chrome://browser/content/browser.xul" in Location bar(?).
  • Use Ctrl + u to view the Page Source !
i found another way (?) to view browser.xul ... : *Open a new tab on FF. * Type "chrome://browser/content/browser.xul" in Location bar(?). *Use Ctrl + u to view the Page Source !

Okulungisiwe ngu iblis17

prso 0 izisombululo 1 izimpendulo
Kuphostiwe

I fixed this by disabling Gmail manager addon.

I fixed this by disabling Gmail manager addon.
cmo999 0 izisombululo 1 izimpendulo
Kuphostiwe

I was finally given the solution to this problem. First, exit FireFox via File => Exit. Then, right-click on the Mozilla Firefox directory, and uncheck the Read-Only box, instructing it to uncheck read only on the entire directory tree. After that, your custom toolbars should remain.

I was finally given the solution to this problem. First, exit FireFox via File => Exit. Then, right-click on the Mozilla Firefox directory, and uncheck the Read-Only box, instructing it to uncheck read only on the entire directory tree. After that, your custom toolbars should remain.
RiversideRepeat 1 izisombululo 6 izimpendulo
Kuphostiwe

Impendulo Ewusizo

cmo999, your solution might be great for windows users, I don't know, but it doesn't help anyone on a mac. EDIT: it did help a little, but not enough.

cmo999, your solution might be great for windows users, I don't know, but it doesn't help anyone on a mac. EDIT: it did help a little, but not enough.

Okulungisiwe ngu RiversideRepeat

RiversideRepeat 1 izisombululo 6 izimpendulo
Kuphostiwe

Not sure but I may have to take that back at least half way. I opened the package folder and made it read/write for administrator. That kept the toolbar when I restarted, but there is still big problem.

The custom toolbar ONLY appears in the window in which it was created. Nowhere else.

EDIT: Correction. This did NOT fix the problem. After second restart, the toolbar is gone. Not even in the right click list anymore.

Not sure but I may have to take that back at least half way. I opened the package folder and made it read/write for administrator. That kept the toolbar when I restarted, but there is still big problem. The custom toolbar ONLY appears in the window in which it was created. Nowhere else. EDIT: Correction. This did NOT fix the problem. After second restart, the toolbar is gone. Not even in the right click list anymore.

Okulungisiwe ngu RiversideRepeat

niente0 1 izisombululo 1 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

I solved by following the method described here: http://support.mozilla.com/en-US/kb/Toolbar%20keeps%20resetting

Hope it helps! ;-)

I solved by following the method described here: [http://support.mozilla.com/en-US/kb/Toolbar%20keeps%20resetting http://support.mozilla.com/en-US/kb/Toolbar%20keeps%20resetting] Hope it helps! ;-)

Okulungisiwe ngu niente0