X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Back Button not working in FireFox 4

Kuphostiwe

Is anyone else having trouble with the back and forward buttons not working in FireFox 4? I installed 4 on an XP desktop and a Vista 64 laptop, and the forward and back buttons don't work on either installation. Does anyone know a fix for this? I tried deleting the "places" files in the profile and that does not help.

Is anyone else having trouble with the back and forward buttons not working in FireFox 4? I installed 4 on an XP desktop and a Vista 64 laptop, and the forward and back buttons don't work on either installation. Does anyone know a fix for this? I tried deleting the "places" files in the profile and that does not help.

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

I upgraded to FireFox 4

Fakela amapulagi

  • np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.2 r153
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Live Update v1.5
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

Eminye Imininingwane

hippaul 0 izisombululo 4 izimpendulo
Kuphostiwe

I am having this same issue too. It's really annoying me and I'm probably just going to go back to Firefox 3 if I can't find a fix for this issue soon. Oh and I'm on Windows 7 so it's multiple OSs =\

I am having this same issue too. It's really annoying me and I'm probably just going to go back to Firefox 3 if I can't find a fix for this issue soon. Oh and I'm on Windows 7 so it's multiple OSs =\
cor-el
  • Top 10 Contributor
  • Moderator
17476 izisombululo 157949 izimpendulo
Kuphostiwe

This can be a problem with the file places.sqlite that stores the bookmarks and the history.

This can be a problem with the file places.sqlite that stores the bookmarks and the history. * http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox

Umnikazi wombuzo

Yes, you post that on every help request posted on this issue. If you would have read my message, you would have quickly seen that I have already done this fix that you post so ubiquitously. It doesn't fix the problem.

Yes, you post that on every help request posted on this issue. If you would have read my message, you would have quickly seen that I have already done this fix that you post so ubiquitously. It doesn't fix the problem.
mrenkema 0 izisombululo 1 izimpendulo
Kuphostiwe

Same problem here. Intranet application om MSSQL Windows 7 Hope you can solve this indeed annoying issue

Thanks, M

Same problem here. Intranet application om MSSQL Windows 7 Hope you can solve this indeed annoying issue Thanks, M
gspooner 0 izisombululo 2 izimpendulo
Kuphostiwe

I too am having problems with the back button. The way it works is totally inconsistent - sometimes it seems to work and sometimes it doesn't. This is only one of a long list of problems I am having with firefox 4 anybody know how to rollback to a previoius version. If not I an going to rollback my machine to a "good" version.

I too am having problems with the back button. The way it works is totally inconsistent - sometimes it seems to work and sometimes it doesn't. This is only one of a long list of problems I am having with firefox 4 anybody know how to rollback to a previoius version. If not I an going to rollback my machine to a "good" version.
matthew393 0 izisombululo 3 izimpendulo
Kuphostiwe

I had a problem with the back button and fixed it by disabling McAfee SiteAdvisor add-in.

I had a problem with the back button and fixed it by disabling McAfee SiteAdvisor add-in.

Umnikazi wombuzo

I don't use the SiteAdvisor program.

I don't use the SiteAdvisor program.
allibone 0 izisombululo 2 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I am having a problem with the back button also in Firefox 4. Firefox forgets the 1st page in any new session or tab. If I open a tab to say bbc.com and navigate to guardian.com I can't click the back button to get back to bbc.com.

I am having a problem with the back button also in Firefox 4. Firefox forgets the 1st page in any new session or tab. If I open a tab to say bbc.com and navigate to guardian.com I can't click the back button to get back to bbc.com.
matthew393 0 izisombululo 3 izimpendulo
Kuphostiwe

What happens if you start FF in safe mode? http://support.mozilla.com/en-US/kb/Safe%20Mode

What happens if you start FF in safe mode? http://support.mozilla.com/en-US/kb/Safe%20Mode

Umnikazi wombuzo

I don't know. I don't have time to fool around with it. I don't run in "safe mode" so I don't see how this is relevant.

I don't know. I don't have time to fool around with it. I don't run in "safe mode" so I don't see how this is relevant.
matthew393 0 izisombululo 3 izimpendulo
Kuphostiwe

Safe Mode is a special Firefox execution mode that can be used to troubleshoot issues in Firefox. In Safe Mode, you can reset some settings or disable add-ons that might be the source of the issue. By comparing Firefox behavior in normal mode to its behavior in Safe Mode with various items disabled, you may be able to diagnose issues.

Safe Mode is a special Firefox execution mode that can be used to troubleshoot issues in Firefox. In Safe Mode, you can reset some settings or disable add-ons that might be the source of the issue. By comparing Firefox behavior in normal mode to its behavior in Safe Mode with various items disabled, you may be able to diagnose issues.

Umnikazi wombuzo

Thanks, but like I said, I really don't have the time to fool around with it. How hard is it to build a back button that works? I've been using FireFox for years. I don't have a bunch of exotic extensions installed. I have never had this problem before, and I am extremely disappointed in FireFox that they have come out with an "upgrade" that doesn't work for thousands of users.

Thanks, but like I said, I really don't have the time to fool around with it. How hard is it to build a back button that works? I've been using FireFox for years. I don't have a bunch of exotic extensions installed. I have never had this problem before, and I am extremely disappointed in FireFox that they have come out with an "upgrade" that doesn't work for thousands of users.
BryceC 0 izisombululo 1 izimpendulo
Kuphostiwe

I disabled SiteAdvisor also, after reading various comments, and my back-button is working properly again. Thanks.

I disabled SiteAdvisor also, after reading various comments, and my back-button is working properly again. Thanks.
fzier 0 izisombululo 1 izimpendulo
Kuphostiwe

Same problem here. When opening a new tab and clicking a link on a new page, FF loses track of the original page. Annoying, but I'd rather keep site advisor and live with it if those are my only options

Same problem here. When opening a new tab and clicking a link on a new page, FF loses track of the original page. Annoying, but I'd rather keep site advisor and live with it if those are my only options

Umnikazi wombuzo

I don't use SiteAdvisor and my forward and back buttons are completely dead in FF 4. I reverted to 3.6 and life is good.

I don't use SiteAdvisor and my forward and back buttons are completely dead in FF 4. I reverted to 3.6 and life is good.
Eddie 0 izisombululo 2 izimpendulo
Kuphostiwe

This happened to me as well,since day one when I upgraded to FF4:back/forward buttons greyed out and unclickable.First I tried restarting with all of my extensions disabled,didn't work.Then I tried a fresh,clean install of FF4 with no extensions,didn't work.I ended up going back to 3.6.16,because I have to have my back/forward function. (And no,I don't have the McAfee SiteAdvisor add-in.I'm using Windows XP.) Oh well,3.6.16 it is until someone figures out how to go back/forward in Firefox 4.

This happened to me as well,since day one when I upgraded to FF4:back/forward buttons greyed out and unclickable.First I tried restarting with all of my extensions disabled,didn't work.Then I tried a fresh,clean install of FF4 with no extensions,didn't work.I ended up going back to 3.6.16,because I have to have my back/forward function. (And no,I don't have the McAfee SiteAdvisor add-in.I'm using Windows XP.) Oh well,3.6.16 it is until someone figures out how to go back/forward in Firefox 4.
navilor 0 izisombululo 2 izimpendulo
Kuphostiwe

Operating system: Windows Vista Ultimate 64bit (fully updated) CPU: Core i7 920

I am running the following addons: Adblock Plux 1.3.5 BetterPrivacy 1.490 CheckPlaces 2.4.5 Cookie Manager Button 1.0.1.6 Cookie Monster 1.0.5 Element Hiding Helper for Adblock Plus 1.1.1 McAfee SiteAdvisor 3.3.1 NoScript 2.1.0.1 RealPlayer Browser Record Plugin 14.0.1

Disabling all of those addons does nothing to resolve this issue.

Operating system: Windows Vista Ultimate 64bit (fully updated) CPU: Core i7 920 I am running the following addons: Adblock Plux 1.3.5 BetterPrivacy 1.490 CheckPlaces 2.4.5 Cookie Manager Button 1.0.1.6 Cookie Monster 1.0.5 Element Hiding Helper for Adblock Plus 1.1.1 McAfee SiteAdvisor 3.3.1 NoScript 2.1.0.1 RealPlayer Browser Record Plugin 14.0.1 Disabling all of those addons does nothing to resolve this issue.
peter99 0 izisombululo 1 izimpendulo
Kuphostiwe

I had the same problem as everyone else running on Win7.

I was about the follow the KB article that tells you to delete/rename the places.sqlite file, but I noticed that when I exited out of FF4, it automatically renamed places.sqlite to places.sqlite.corrupt.

I then started FF again and the back/forward/history functions were all fine.

However, my bookmarks are empty. I couldn't export them previously as they had all disappeared and I can't import any of my bookmark backups.

It comes back with the message:

"Could not process backup file"

I've tried all 6 of the bookmark backups without any success.

At least I have the back/forward buttons working again, which means FF4 is finally usable.

It amazes me that an issue with a core function like this wouldn't have been picked up in beta testing.

I had the same problem as everyone else running on Win7. I was about the follow the KB article that tells you to delete/rename the places.sqlite file, but I noticed that when I exited out of FF4, it automatically renamed places.sqlite to places.sqlite.corrupt. I then started FF again and the back/forward/history functions were all fine. However, my bookmarks are empty. I couldn't export them previously as they had all disappeared and I can't import any of my bookmark backups. It comes back with the message: "Could not process backup file" I've tried all 6 of the bookmark backups without any success. At least I have the back/forward buttons working again, which means FF4 is finally usable. It amazes me that an issue with a core function like this wouldn't have been picked up in beta testing.
John R 0 izisombululo 2 izimpendulo
Kuphostiwe

Like the others, I've had this problem, but it's not consistent. It happens mostly on my FF homepage (foxnews.com). I click to read an article and yet the back button is grayed out. I agree with peter99's statement, "It amazes me that an issue with a core function like this wouldn't have been picked up in beta testing." I'm sure that for every person who found, read, and posted in here, there are a few hundred who did nothing, or even switched browsers. I'll wait to see what happens with 4.1 or 4.0.1. Maybe the problem will be fixed.

Like the others, I've had this problem, but it's not consistent. It happens mostly on my FF homepage (foxnews.com). I click to read an article and yet the back button is grayed out. I agree with peter99's statement, "It amazes me that an issue with a core function like this wouldn't have been picked up in beta testing." I'm sure that for every person who found, read, and posted in here, there are a few hundred who did nothing, or even switched browsers. I'll wait to see what happens with 4.1 or 4.0.1. Maybe the problem will be fixed.

Okulungisiwe ngu John R

RossFraser 0 izisombululo 1 izimpendulo
Kuphostiwe

Starting in FF 4 safe mode doe NOT alleviate the problem. Starting with all add-ins disabled (under Win 7), the back and forward buttons remain greyed out, regardless of how many web pages are opened and regardless of the navigation patterns used (links followed, successive urls entered into address bar, etc.)

Re-installing FF 4 does NOT fix the problem. The arrows immediately become usable again when FF 3.6 is reinstalled.

Starting in FF 4 safe mode doe NOT alleviate the problem. Starting with all add-ins disabled (under Win 7), the back and forward buttons remain greyed out, regardless of how many web pages are opened and regardless of the navigation patterns used (links followed, successive urls entered into address bar, etc.) Re-installing FF 4 does NOT fix the problem. The arrows immediately become usable again when FF 3.6 is reinstalled.