Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have just downloaded Firefox 4 and get a message that says "You cannot open the application “Firefox” because it is not supported on this architecture." I'm on a Mac with OS X 10.5.8 and it has a PC G5 chip. Does anyone know what is happening?

more options

Details are in the question.

For extra information, I got the same message when I downloaded the latest update for Skype. I'm wondering whether it's the G5 chip or the Leopard OS - because I can't upgrade to Snow Leopard (10.6) on G5 chip!

Isisombululo esikhethiwe

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (2)

more options

Isisombululo Esikhethiwe

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

more options

It really is getting annoying on problem with skype. Please clear this up so we can download again.