Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I downloaded Firefox 4 to my Mac. When I try to open it says it can't be used with this version of Mac OS X (mine is 10.4.11). But now I can't find a download to revert back. HELP

  • 1 baphendule
  • 9 zinale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

I downloaded Firefox 4 on my iMac, liked it, so went to put it on my older MacBook. When I went to download, I didn't see any system requirements (though it could have been there). I downloaded, installed. But when I went to open Firefox, it said "Firefox can't be used with this version of Mac OS X (mine is 10.4.11). But now I can't figure out how to go back to the last version.

I downloaded Firefox 4 on my iMac, liked it, so went to put it on my older MacBook. When I went to download, I didn't see any system requirements (though it could have been there). I downloaded, installed. But when I went to open Firefox, it said "Firefox can't be used with this version of Mac OS X (mine is 10.4.11). But now I can't figure out how to go back to the last version.

All Replies (1)

more options

For older Macs that aren't supported in Firefox 4.0, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/

You can get 3.6.16 from here:
http://www.mozilla.com/en-US/firefox/all-older.html