Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

why does firefox 4 freeze on the 1st result page of google search engine

  • 5 uphendule
  • 166 zinale nkinga
  • 48 views
  • Igcine ukuphendulwa ngu alpi1

more options

I updated to Firefox 4 yesterday and now every time I use the google search engine my screen freezes on the first results page and will not allow me to click on any of the links on it, saying that it is not responding before eventually the screen goes white.

I tried to find a solution on the Firefox Support page but the only solution relates to McAfee Site Advisor. As I do not have this installed and never have I was wondering if it would be possible for you to tell me how do I fix it?

Thank you.

All Replies (5)

more options

I've had the same problem too!

I can use Firefox 4 without any issues unless I go to the Google homepage and start typing. After typing a few characters Firefox freezes and becomes unresponsive.

I was using the Firefox 4 Beta from the start and it was working perfectly up until version 7 or 8 and above when the problem started. I've now upgraded to the full release version and the problem remains. If I revert to Firefox 3.6 it works again.

I use Bullguard so it's not related to the McAfee problem that's been mentioned and I've tried using a new profile with only my bookmarks copied over from my old profile.

Please help Mozilla! I've been using Firefox for years but this latest issue causes so much hassle I'm starting to think about going elsewhere for my browser.

more options

The cause of the problem is the Bullguard Safe Browsing Toolbar 1.0.

If you click on Firefox, Add-ons, Extensions, Disable and Restart now Google should work properly.

I contacted Bullguard Support last Wednesday and they said they were aware of the problem and were working on a fix for it.

As of 11:33 on 30/03/2011 the problem has not been solved so I will contact them again.

more options

Hi, i had the same problem, and I also use Bullguard, I contacted them, just received answer, (in about 20 min). It is incompatibility of FF4 and bullguard (they know about it, and fix will be released soon), and probably most of the other antiviruses, as I see this is very popular problem. The solution though is very simple : in firefox disable addon "Bullguard Safe Browsing". It works. Or alternatively open bullguard go : antivirus - settings - safe browsing (unchek that). For those not using bullguard i would recommend to check their addons in FF and if there is any from your antivirus try to disable it for now.

more options

I've been having this problem and I have switched Bullguard off and I still get the problem. Any ideas?

more options

Bullguard Safe Browsing Toolbar 1.0 was updated to Bullguard Safe Browsing 1.1 on 10 May 2011 and should now work properly.

Hope you find this reply helpful.