Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why is Firefox 4 telling me it will not run on Mac OS X Version 10.4.11 and how do I get a version of Firefox that does work?

  • Akukho zimpendulo
  • 25 zinale nkinga
  • 5 views
more options

When I updated to Firefox 4 and try running it states that it can not run on my verson of Mac OS X. I now have no Firefox and would like to keep using, how can I install a version of Firefox that works for my Mac OS X Version 10.4.11?

All Replies (3)

more options

Firefox 3.6.x should work with 10.4. it can be found here: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.6.15/

more options

There's also an outside group that is maintaining a version of Firefox 4 that works on PPC and 10.4. You can get it here: http://www.floodgap.com/software/tenfourfox/

more options

Thank you! I've downloaded an older version of Firefox for now. Converting to tenfourfox maybe my best option once updates are stopped for my old version of Firefox.