X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

My laptop touchpad scroll is not working with firefox 4. It is wroking with other programs. When I attach a mouse then scroll works with mouse wheel. It is only not working with touchpad. It is/was working with firefox 3.6.x

Kuphostiwe

I am using windows xp service pack 3 with Lenovo T60p.

I am using windows xp service pack 3 with Lenovo T60p.

Eminye Imininingwane Yohlelo

Lokhu kwenzekile

Ngaso sonke isikhathi lapho i-Firefox ivulwa

Lokhu kwaqala ngenkathi...

Since I installed firefox 4

Fakela amapulagi

  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • Version 1.9.2.0
  • Provides additional functionality on Facebook. See our web site for details.
  • Google Update
  • Shockwave Flash 10.1 r102
  • iTunes Detector Plug-in
  • DivX Web Player version 2.1.0.900
  • DivX OVS Helper Plug-in
  • GEPlugin
  • Picasa plugin
  • Java Plug-in 1.4.2 for Netscape Navigator (DLL Helper)
  • Next Generation Java Plug-in 1.6.0 for Mozilla browsers
  • Yahoo Application State Plugin
  • 4.0.50524.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 6.0.12.1739
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

Eminye Imininingwane

the-edmeister
  • Top 25 Contributor
  • Moderator
5406 izisombululo 40221 izimpendulo
Kuphostiwe

Look for updated scroll pad drivers at the Lenovo website.

Look for updated scroll pad drivers at the Lenovo website.
Lillelilo 0 izisombululo 1 izimpendulo
Kuphostiwe

This might seem silly, but I have found a work around that works for me.

On Windows 7 it helps to open "Libraries" and have it open in the background/on the taskbar. Now I can scroll in Firefox 4. I guess any folder will do. I doesn't have to be Libraries.

This might seem silly, but I have found a work around that works for me. On Windows 7 it helps to open "Libraries" and have it open in the background/on the taskbar. Now I can scroll in Firefox 4. I guess any folder will do. I doesn't have to be Libraries.

Umnikazi wombuzo

This is also not helping.... If I got it correct then you are saying open some windows folder. I have some folders open but still scroll with touchpad does not work

This is also not helping.... If I got it correct then you are saying open some windows folder. I have some folders open but still scroll with touchpad does not work
smartdonkey 0 izisombululo 2 izimpendulo
Kuphostiwe

I've got an IBM T60 and upon installing Firefox 4 Rc2, vertical scrolling with the Synaptic touchpad stopped working in Firefox. It was working fine in Firefox 3. I then installed the latest UltraNav driver (the synaptic driver) dated March 18, 2011, downloaded from Lenovo's support site. Vertical scrolling works in Firefox 4 now.

I've got an IBM T60 and upon installing Firefox 4 Rc2, vertical scrolling with the Synaptic touchpad stopped working in Firefox. It was working fine in Firefox 3. I then installed the latest UltraNav driver (the synaptic driver) dated March 18, 2011, downloaded from Lenovo's support site. Vertical scrolling works in Firefox 4 now.
Earthborn 0 izisombululo 1 izimpendulo
Kuphostiwe

@ the-edmeister (offered initial suggestion: sorry smartdonkey)

Thanks Edmeister, your suggestion resolved my issue.

@ the-edmeister (offered initial suggestion: sorry smartdonkey) Thanks Edmeister, your suggestion resolved my issue.

Umnikazi wombuzo

Thanks Edmeister and Smartdonkey your suggestions resolved my issue too.

Thanks Edmeister and Smartdonkey your suggestions resolved my issue too.
mchipeur 0 izisombululo 1 izimpendulo
Kuphostiwe

I have an X60. I tried the UltraNav driver. No result. I unistalled the UltraNav driver then installed the most recent TrackPoint driver. Solved.

Driver: http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-66893

I have an X60. I tried the UltraNav driver. No result. I unistalled the UltraNav driver then installed the most recent TrackPoint driver. Solved. Driver: http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-66893
sandy52125 0 izisombululo 1 izimpendulo
Kuphostiwe

Perfect..updating the latest lenovo UltaNav driver 15.2.14.0 fixed the issue not only with Firefox also Microsoft office 2007 scrolling issue

Perfect..updating the latest lenovo UltaNav driver 15.2.14.0 fixed the issue not only with Firefox also Microsoft office 2007 scrolling issue
DOG425 0 izisombululo 15 izimpendulo
Kuphostiwe

The suggested solution with updated driver did not do it for me. I also tried other solutions in combination with this (see here) but without success.

I do however have the ALPS (not Synaptic) hardware so the latest driver is still OLD. I hope that someone manages to solve this, it is a bit of a deal breaker not being able to scroll in a convenient way...

System: SL300, Windows 7 Ultimate 64-bit

The suggested solution with updated driver did not do it for me. I also tried other solutions in combination with this (see [http://support.mozilla.com/en-US/kb/Cannot%20scroll%20with%20mouse%20wheel%20or%20touchpad here]) but without success. I do however have the ALPS (not Synaptic) hardware so the latest driver is still OLD. I hope that someone manages to solve this, it is a bit of a deal breaker not being able to scroll in a convenient way... System: SL300, Windows 7 Ultimate 64-bit

Okulungisiwe ngu DOG425

iasonas 0 izisombululo 2 izimpendulo
Kuphostiwe

I'm using an X61 and now that I've upgraded from FF 3.6 to FF 4.0, my middle scrolling mouse button no longer works. Unfortunately the mentioned UltraNav driver update isn't for the X61. In fact, there have been no recent updates to the mouse or track point drivers and there are none specifically for Win 7 (which I currently run). I don't have this problem with any other app.

I'm starting to get use to using the pg up/down keys, but this is still kindof a pain-in-the-ass.

Any ideas/fixes?

I'm using an X61 and now that I've upgraded from FF 3.6 to FF 4.0, my middle scrolling mouse button no longer works. Unfortunately the mentioned UltraNav driver update isn't for the X61. In fact, there have been [http://www-307.ibm.com/pc/support/site.wss/migr-67971.html no recent updates] to the mouse or track point drivers and there are none specifically for Win 7 (which I currently run). I don't have this problem with any other app. I'm starting to get use to using the pg up/down keys, but this is still kindof a pain-in-the-ass. Any ideas/fixes?
dazmanic 0 izisombululo 2 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I too have this problem, I have an Acer Aspire 7551G with an ALPS mutitouch touchpad. It works perfectly fine in every other program, and worked in Firefox 3.6. Scroll also works fine with a USB mouse. I tried downloading the 'latest' driver from the Acer support website, but when I tried to install it, it says that I am trying to install the same driver that I already have, so that fix isn't possible. I've only had the machine for 3 months, so I would imagine the drivers are pretty current.

I can't believe that this is a driver problem anyway, as I say, it works perfectly well in every other program, so it must be something wrong with Firefox. I was looking forward to using Firefox 4, but this problem is too annoying to put up with. Oh well, back to Chrome... at least until there is a fix found or implemented.

I too have this problem, I have an Acer Aspire 7551G with an ALPS mutitouch touchpad. It works perfectly fine in every other program, and worked in Firefox 3.6. Scroll also works fine with a USB mouse. I tried downloading the 'latest' driver from the Acer support website, but when I tried to install it, it says that I am trying to install the same driver that I already have, so that fix isn't possible. I've only had the machine for 3 months, so I would imagine the drivers are pretty current. I can't believe that this is a driver problem anyway, as I say, it works perfectly well in every other program, so it must be something wrong with Firefox. I was looking forward to using Firefox 4, but this problem is too annoying to put up with. Oh well, back to Chrome... at least until there is a fix found or implemented.

Okulungisiwe ngu dazmanic

jakens 0 izisombululo 1 izimpendulo
Kuphostiwe

IASONAS: I also have an X61 and had the exact same problem when I upgraded today to FF4. At the Lenovo site you link to, I have XP, so I used the Mouse/Trackpoint update: Windows Vista (32-bit), XP 8 Apr 2010 4.72

However, I do see that this version also supports Windows 7 (32bit).

The update for Windows Vista (64-bit) 8 Apr 2010 4.72 shows that it supports Windows 7 (64bit), so one of these should work for you.

This update did the trick for me and now I can scroll in FF4 with my TrackPoint with ease!

Good luck.

IASONAS: I also have an X61 and had the exact same problem when I upgraded today to FF4. At the Lenovo site you link to, I have XP, so I used the Mouse/Trackpoint update: Windows Vista (32-bit), XP 8 Apr 2010 4.72 However, I do see that this version also supports Windows 7 (32bit). The update for Windows Vista (64-bit) 8 Apr 2010 4.72 shows that it supports Windows 7 (64bit), so one of these should work for you. This update did the trick for me and now I can scroll in FF4 with my TrackPoint with ease! Good luck.

Okulungisiwe ngu jakens

iasonas 0 izisombululo 2 izimpendulo
Kuphostiwe

Jakens: Thanks! I'm pretty sure I had installed that driver when I upgraded to Win 7, but reinstalling has fixed things for me.

Jakens: Thanks! I'm pretty sure I had installed that driver when I upgraded to Win 7, but reinstalling has fixed things for me.
iuliand 0 izisombululo 3 izimpendulo
Kuphostiwe

Same problem here with Acer Extensa 5220 notebook. OS: Win7 ultimate 32b. Touchpad: Synaptics.

As this topic suggests, I installed the latest Synaptics driver v15.2.7 and the problem is "improved" but not solved. With the latest synaptics driver the touchpad scroll works for about one minute after FF4 is started. After this, it will not work until I close and restart FF4 again (and again it works for only about one minute). Very strange behavior.

The touchpad scroll works just fain in every other application.

EDIT: If I keep scrolling continuously (up and down without taking the finger of the touchpad) right after FF4 is started, it will scroll fain for more than one minute, but just until I take my finger off the touchpad and try to scroll again. Then it will not work anymore.

EDIT2: See solution below in my next post.

Same problem here with '''Acer Extensa 5220''' notebook. OS: '''Win7''' ultimate 32b. Touchpad: '''Synaptics'''. As this topic suggests, I installed the latest Synaptics driver v15.2.7 and the problem is "improved" but not solved. With the latest synaptics driver the touchpad scroll works for about one minute after FF4 is started. After this, it will not work until I close and restart FF4 again (and again it works for only about one minute). Very strange behavior. The touchpad scroll works just fain in every other application. EDIT: If I keep scrolling continuously (up and down without taking the finger of the touchpad) right after FF4 is started, it will scroll fain for more than one minute, but just until I take my finger off the touchpad and try to scroll again. Then it will not work anymore. EDIT2: See solution below in my next post.

Okulungisiwe ngu iuliand

stuffy 0 izisombululo 1 izimpendulo
Kuphostiwe

I had two laptops with this scrolling problem after upgrading to Firefox 4. One Vista and one Windows XP. I fixed it by restarting Firefox with all the addons disabled in safe mode. Then restarted Firefox and scrolling started working again. The XP machine I had to do it twice for some reason. Maybe I didn't wait long enough for all of Firefox to load.

Hopefully this will help someone else.

I had two laptops with this scrolling problem after upgrading to Firefox 4. One Vista and one Windows XP. I fixed it by restarting Firefox with all the addons disabled in safe mode. Then restarted Firefox and scrolling started working again. The XP machine I had to do it twice for some reason. Maybe I didn't wait long enough for all of Firefox to load. Hopefully this will help someone else.
iuliand 0 izisombululo 3 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Stuffy, you've made a very useful observation. This lead me to the culprit which is Adobe Acrobat 10.0.1.434 Add-on!

Once I disabled acrobat add-on, scrolling resumed right away (without FF4 restart)!

This issue may be related to the fact that my FF4 always opened automatically a .pdf file in one of the tabs but I haven't tested this yet.


Solution:
If you have issues with touch-pad scrolling in FF4 do this:
1) disable Adobe Acrobat add-on and test if it works, otherwise
2) install the latest touch-pad driver.
Hope this will help others.


Edit:

If the above does not work, temporarily disable all add-ons in order to check if there is another one that may cause this.

Also, make sure you update to the latest touch-pad driver from the touch-pad manufacturer site (very easy to do if you have a Synaptics). Most of the time drivers from notebook manufacturer support site are NOT up to date.

Keep in mind that you may need to do both things (disable acrobat AND install latest driver). Both are possible causes and may occur at the same time, as it was in my case.

Edit 2:

If you have an ALPS touch-pad and none of the above works, check dog425's post below in this topic. He pointed out a solution found in this thread: https://support.mozilla.com/en-US/questions/791829#answer-163071

Stuffy, you've made a very useful observation. This lead me to the culprit which is '''Adobe Acrobat 10.0.1.434 Add-on'''! Once I disabled acrobat add-on, scrolling resumed right away (without FF4 restart)! This issue may be related to the fact that my FF4 always opened automatically a .pdf file in one of the tabs but I haven't tested this yet. Solution: If you have issues with touch-pad scrolling in FF4 do this: 1) disable Adobe Acrobat add-on and test if it works, otherwise 2) install the latest touch-pad driver. Hope this will help others. Edit: If the above does not work, temporarily disable all add-ons in order to check if there is another one that may cause this. Also, make sure you update to the latest touch-pad driver from the touch-pad manufacturer site (very easy to do if you have a Synaptics). Most of the time drivers from notebook manufacturer support site are NOT up to date. Keep in mind that you may need to do both things (disable acrobat AND install latest driver). Both are possible causes and may occur at the same time, as it was in my case. Edit 2: If you have an ALPS touch-pad and none of the above works, check dog425's post below in this topic. He pointed out a solution found in this thread: https://support.mozilla.com/en-US/questions/791829#answer-163071

Okulungisiwe ngu iuliand

flottx 0 izisombululo 1 izimpendulo
Kuphostiwe

iuliand: Thanks, disabling the Adobe Acrobat add-on worked for me as well. I have an HP dv6-1355 dx using Win 7 64-bit with Synaptics touchpad driver.

iuliand: Thanks, disabling the Adobe Acrobat add-on worked for me as well. I have an HP dv6-1355 dx using Win 7 64-bit with Synaptics touchpad driver.
myclarkfam 0 izisombululo 1 izimpendulo
Kuphostiwe

Ok, I have been having the same problem and I have tried everything on the list. I noticed for me it works one time then not another. It might sound strange but it seems to do it when my antivirus is running a scan. I use system mechanics professional.

Ok, I have been having the same problem and I have tried everything on the list. I noticed for me it works one time then not another. It might sound strange but it seems to do it when my antivirus is running a scan. I use system mechanics professional.
panda368 0 izisombululo 1 izimpendulo
Kuphostiwe

Thanks all for the info...by disabling Adobe plug-in in Firefox 4, scrolling working automatically again!

Thanks all for the info...by disabling Adobe plug-in in Firefox 4, scrolling working automatically again!

Okulungisiwe ngu panda368

bsmithbrown 0 izisombululo 2 izimpendulo
Kuphostiwe

Haven't had any luck with these solutions and went back to 3.6. Re-considering IE...I just don't have time for these random inconveniences, which always seem to happen on a day when I have way too much to do already!

Haven't had any luck with these solutions and went back to 3.6. Re-considering IE...I just don't have time for these random inconveniences, which always seem to happen on a day when I have way too much to do already!