Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Please, will someone tell me how to configure Firefox 3.6 to color the URL address when on a secure website.

  • 5 uphendule
  • 9 zinale nkinga
  • 808 views
  • Igcine ukuphendulwa ngu HavingTrouble

more options

Earlier versions of Firefox, such as 2.0, would change the color of the URL or website address from white to yellow when it went from an unsecured website (http) to a secured website (https). Although my eyesight has been getting worse, this feature made it very easy to glance at the address & know I was on a secure website. Firefox 3.6 does not make such a color change. I would greatly appreciate it someone would tell me how to configure Firefox 3.6 to act like 2.0 in this matter.

Isisombululo esikhethiwe

If the above posted code doesn't work then add -moz-appearance: none !important;

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar[level] > .autocomplete-textbox-container {
 background-color: #FFB !important;
 -moz-appearance: none !important;
}
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

Current versions of Firefox use the site identity button to give a visual indication of the security used by the site, for details see https://support.mozilla.com/kb/Site+Identity+Button

It is possible to make the background yellow, but it involves adding some code to a file called userChrome.css. For details on this file see http://kb.mozillazine.org/UserChrome.css

The code that you need to add below the line that begins with @namespace is:

#urlbar[level] .autocomplete-textbox-container {background-color: #FFB !important;}


For more details on editing this file see http://kb.mozillazine.org/Editing_configuration

For another site that gives a good overview of editing this file, see the top part of this link - http://www.linnhe2.free-online.co.uk/firefox/chrome.html

more options

Isisombululo Esikhethiwe

If the above posted code doesn't work then add -moz-appearance: none !important;

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar[level] > .autocomplete-textbox-container {
 background-color: #FFB !important;
 -moz-appearance: none !important;
}

Okulungisiwe ngu cor-el

more options

Be aware that Firefox 3 versions do not run on the Windows 98 platform that you used to post your question.

Firefox 2.0.0.20 is the last release that runs on the Windows 98 and Windows ME platform.

Win32: https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/win32/en-US/

See also:

more options

I'm sorry it's taken me so long to respond to your suggestions. I haven't had the opportunity to access the computers in question for the last few days. Although your suggestions didn't work, I would like to assure you that I really appreciate the time & effort you took to try & help me & hope you will make another attempt. Being uncertain as to the proper syntax involved & how important a small difference might make, I tried the five variations of your suggestions below. None of them seemed to have any effect on the two systems. One system belongs to a relative & is a fairly new laptop running Windows 7. The other is an older desptop running XP. Do you try or test the suggestions you make?

@namespace is:

  1. urlbar[level].autocomplete-textbox-container {background-color:
  2. FFB !important;}

@namespace url:

  1. urlbar[level].autocomplete-textbox-container {background-color:
  2. FFB !important;}

@namespace url ("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

  1. urlbar[level].autocomplete-textbox-container {background-color:
  2. FFB !important;}

/* *@namespace url/* ("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

  1. urlbar[level].autocomplete-textbox-container {background-color:
  2. FFB !important;}
@namespace url
("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 
/*only needed once*/
#urlbar[level].textbox-input-box {background-color:
#FFB !important;}

Okulungisiwe ngu HavingTrouble

more options

I'm not sure if the problem was that the response from cor-el that was emailed to me had some html elements mixed in with it or I was to stupid to realize that his suggestion had been corrupted or compromised. At any rate, the important thing is that it works now. Thank you, thank you, thank you!!! For anyone interested in making this change, the version that worked is: @namespace url ("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /*only needed once*/

  1. urlbar[level] > .autocomplete-textbox-container {
background-color: #FFB !important;
-moz-appearance: none !important;

}