Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

In YOUTUBE videos are not playing

  • 5 uphendule
  • 1007 zinale nkinga
  • 19940 views
  • Igcine ukuphendulwa ngu esgt

more options

I have recently upgraded my browser from Firefox 3.6 to Firefox 4 beta version. Now I find that videos are not playing in YOUTUBE website. A black window appears.

All Replies (5)

more options

Try to install Adobe Flash Again. If this doesn't works, check in you addons manager there isn't any plugin interfering with flash animations/videos

more options

That Firefox 4 beta 9 version is outdated.
Make sure that you update to the latest Firefox 4 RC2 version.


Clear the cache and the cookies from sites that cause problems.

  • "Clear the Cache": Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites causing problems: Firefox > Preferences > Privacy > Cookies: "Show Cookies"

You can also try to change the protocol in the YouTube links from http: to a secure https:

more options

1. START any youtube video that's not working. 2. right-click on face of video. 3. click SETTINGS. 4. UNCHECK "Hardware Acceleration"

more options

I was having this problem and solved it by going into the Add-ons area, clicking on the Plugins menu item and disabling Shockwave Flash 11.3.300.257. Maybe that will help.

more options

Shokweave is disabled by me now videos are playing but speedbit video download is now not working