Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why won't Firefox browse to my address when I press enter on the keyboard?

  • 7 uphendule
  • 76 zinale nkinga
  • 254 views
  • Igcine ukuphendulwa ngu amedina

more options

Since I installed (and uninstalled) the 4.0 beta, when I type an address in the address bar (in 3.6) and press the enter key on the keyboard, nothing happens. I now must click the arrow to browse to my typed address. Solutions?

All Replies (7)

more options

Try

I have 3.6.13 & 4.0B8 installed but on XP Pro sp2; & have probably avoided some problems by having separate profiles available for each firefox version (use Profile Manger)

A recent thread Enter key no longer works in address bar implicates AVG in some similar problems.

If problems are cause by a corrupted profile it will be worth you creating another additional profile to experiment with, and making backups before considering a more permanent solution. ( Heed the cautions to use empty folders for any additional profiles)

more options

Try disabling the AVG Safe Search extension that you have installed. As John99 alluded to, that extension has been reported to cause that problem for other users on 3.6.13 - AVG has some fixing to do with that extension.

more options

Your above posted system details show multiple Java Console extensions.
You can uninstall (remove) the Java Console extensions, you do not need them to run Java applets.

See http://kb.mozillazine.org/Java#Multiple_Java_Console_extensions

more options

AVG is definitely the problem. I disabled the "Safe Search" Add-on (under Tools/Add Ons) and the functionality was restored. Thanks for all the comments.

more options

Glad to know it is fixed.

more options

this is kinda scary to do.. :( it's overwhelming.. for some of us who are not techie..

more options

what i did was one of the suggestions from another thread:

  • Tools (ctrl+shift+A)
  • Add-Ons
  • Extensions
  • Look for any extra "JAVA Console" on the list

> you can disable the older version that you find, make sure there's only one there > the previous thread suggested "uninstalling".. but "disable" is the only button available if you go there.. so I did that

  • Restarted FF as suggested by the window that prompted
  • Try searching on the address bar and press ENTER

> if still doesn't work.. disable anything that would say AVG as well.. or if you have "remove" button.. remove it together with those extensions that failed to install due to compatibility issues..

Hope that helps.. ^^