Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

error: xulrunner version 1.9.2.1o not compatible with firefox 3.6.12 min/maxVersion 1.9.2.12

  • 6 uphendule
  • 331 zinale nkinga
  • 1451 views
  • Igcine ukuphendulwa ngu Plugin7

more options

Loaded firefox 3.6.12 from scratch. It won't start, popping up an XULRunner dialog box that says :Error: Platform version '1.9.2.10' is not compatible with minVersion >= 1.9.2.12 maxVersion <= 1.9.2.12. How do I get proper version of XULRunner so Firefox recognizes it?

Isisombululo esikhethiwe

Do a clean (re)install:

  • Download a fresh Firefox copy from http://www.mozilla.com/firefox/all.html and save the file to the desktop.
  • Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.
  • Don't remove personal data when uninstalling.
  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 11

All Replies (6)

more options

Isisombululo Esikhethiwe

Do a clean (re)install:

  • Download a fresh Firefox copy from http://www.mozilla.com/firefox/all.html and save the file to the desktop.
  • Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.
  • Don't remove personal data when uninstalling.
  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.
more options

Needed to do an uninstall from Add or Remove Programs Control Panel . Then complete re-installation worked. Thanks.

more options

I found that when I right click the FireFox icon then click "Always run outside sandbox" the problem goes away but when I click "Run inside sandbox" I can't open the browser and I get that error. I'm assuming the sandbox thing is part of my Avast I purchased(?).

more options

Hi I had the same problem but with version 1.9.2.15

I found many people with the same issue doing a Google research and all seem to solve it with a clean reinstall. However:

inside your installation directory (where firefox.exe is) check for the file platform.ini if you don’t have one, please create it. Edit the newly created platform.ini or the existing one with a text editor

add the following 2 lines

[Build] Milestone=X.X.X.X

replace the X.X.X.X with the version number from the error massage. This worked in my case

Okulungisiwe ngu haloumis

more options

My question:

ERROR:PLATFORM VERSION 1.9.2.15 IS NOT COMPATIBLE WITH minversion >=1.9.2.13 maxversion<=1.9.2.13

Specifically how to solve it? Please reply me E-mail:zpk6209@sina.com Thank you!

more options

If you are running Zone Alarm Extreme Security Ver 9....... onwards with browser protection operating then go into browser security, settings, enter advanced and clear the virtual data at the bottom of page. exit and your version of firefox should work. Cheers Plugin7