Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why does localhost page not show only in Firefox

  • 2 uphendule
  • 34 zinale nkinga
  • 1794 views
  • Igcine ukuphendulwa ngu Jai-Styl

more options

Every time I try to open the page 'http://localhost' in my FF, all I get is a blank, white page. I tried this with two different local server programs XAMPP and WAMPServer. Both give the same result, a blank, white page. Apache and MySQL, which those local servers provide, work perfectly fine. I can access that page only if I type in 'https://localhost' or the IP '127.0.0.1'. But IE, Opera and Chrome have no problem showing the page the normal way. Could you please tell me what my problem is? I tried to find something in other forums and asked as well in a forum for XAMPP? But they couldn't help me. I changed my hosts file and also tried to disable IPv6 but that didn't help. The servers are both working perfectly fine, there were no error messages when I installed them. I also tried to disable the firewall and see if that would be the mistake but that didn't help either.

Here maybe some information you would need to analyse the problem: I use WIN7 Home Premium 64 bit, XAMPP version 1.7.3 and Firefox version 3.6.10

Thank you very much for all your efforts Jonny

All Replies (2)

more options

I found out what it was that blocked that page. It was a Programm on my computer to block porn pages. But unfortunately it also blocked other programs. Now I will use a different program to block porn. But my localhost is showing now.

more options

If you're working where there are proxies and Firefox is set to use the System Settings, then go to the Control Panel (Windows-XP)> Internet Properties> Connections (tab)> LAN settings. In the Proxy server section click the Advanced button. Add localhost to the Exceptions section.