Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

well known, oft visted site = Server not found. not banned, others can still view - What to do?

  • 8 uphendule
  • 3 zinale nkinga
  • 4 views
  • Igcine ukuphendulwa ngu Blue1389

more options

it seems that after a recent Firefox update i can no longer view 'mtgsalvation.com". i have not been banned, and others can view the site. i have tried everything in the support section offering help for this (deleting cookies and history, running malware destroyers etc.) nothing is working. any help would be greatly appreciated.

All Replies (8)

more options

Can you access that site via other browsers like IE ?

Does the Google cache work: http://www.google.com/search?hl=en&ie=UTF-8&q=cache:http%3...

See also http://kb.mozillazine.org/Error_loading_websites - "Error_loading_some_websites"

more options

thanks for replying, i appreciate the help.

no, i can't access the site with IE. not from this computer anyway 9and it's the only one i have). i haven't tried from a friends house yet.

the google cache did work, but when i click on a sub-page (eg. Forums) i get the same error.

i did read through the mozillazine, but i have tried all of that.

any other thoughts? thanks again.

more options

can anyone else help with this problem?

more options
more options

thanks for the tip, but it didn't work either.

Okulungisiwe ngu Blue1389

more options

Is that the only website that gives problems?


Do a malware check with a few malware scan programs. You need to use all programs because each detects different malware. Make sure that you update each program to get the latest version of the database.

See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked and What to do when searches take you to the wrong search website


http://kb.mozillazine.org/Error_loading_websites - "Error_loading_some_websites"

more options

yes, so far it is the only one i have found that this is happening too.

i have used Ad-Aware and Spybot, the first found nothing, the second didn't fix the issue. i was really hoping that there would be a quicker fix than downloading all of those, but i will start. thanks for the help.

more options

well... don't ask me how or why, but without doing anything else it started working again.

i didn't have time to download all the malware services that you suggested last night, so i didn't do anything else, but now i can log on to the website again.

weird. i don't like ghosts in the machine.