Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I force Outlook 2010 to use Firefox instead if IE8?

more options

Whenever I click a link in my emails, it opens in IE8. With only one link, it works fine, but when I click on multiple links in a techie email, IE locks up when dealing with multiple tabs. Firefox works great. Where do I change the settings in Outlook 2010 so that links will open using Firefox instead??????? Help files have not produced an answer. This is on a Win 7 Ultimate 32, Office 2010 Military version, with full Outlook 2010. TIA

All Replies (2)

more options

In Firefox tools>options>advanced. At the bottom>system defaults. Make FF your default browser

Okulungisiwe ngu rupertbear

more options

I found that this link solved my problem for windows 7: http://www.werockyourweb.com/how-do-i-set-default-browser-outlook