Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FF3 redirects me to Google Australia [google.com.au] instead of to USA [google.com]

  • 8 uphendule
  • 84 zinale nkinga
  • 260 views
  • Igcine ukuphendulwa ngu cor-el

more options

FF3 recently stopped opening Google.com, as listed in my Home Page, and always redirects me to Google. com.au (Australia), even when I keep entering USA address in URL bar.

I am located in Australia but often wish to google US sites only.

All Replies (8)

more options
more options

Q, thanks for replying...... your recommended web-page didn't resolve my problem - I had already been clicking on the the lower right-hand link to try getting to google.com (USA), but without success.

I strongly suspect it is an FF3 problem seeing I don't have any trouble with IE7. Changing ISPs also makes no difference.

Anything else I should try besides re-installing FF3?

more options

I am located in Australia but often wish to google US sites only

Since you are located in Australia, Firefox/Google will try to give you search results based on your locale.

I do not believe you can effectively restrict your search from the Location Bar. However you can do so from the Google search page (in your case www.google.com.au ),

  • by clicking "Advanced Search",
  • enter your search words, other information and restrictions,
  • then for Region, pull down the selections and choose the country.
  • If you are looking for information in a specific city/area/state, include location: followed by the city name, state/province name, etc, in your search words with no space between location: and the city, state, etc. Examples: location:denver or location:CO (for Colorado).

See:
http://www.googleguide.com/advanced_operators.html http://www.googleguide.com/advanced_operators.html#location

Hope this is helpful.


Update Shockwave Flash (Adobe Flash). A new version was released 2010-08-12, ver. 10.1.82.76.

  1. You can check your version: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Use Firefox to Download and SAVE to your hard drive (link in article below)
  3. After download completes, close Firefox
  4. Click on the file you just downloaded and install
  5. After installation, restart Firefox and check your version again.
  6. Download link and other information: https://support.mozilla.com/en-US/kb/Managing+the+Flash+plugin#Updating_Flash

Okulungisiwe ngu Helper7677

more options

Helper7677, thank you too for replying. I visited your suggested links (and tried your suggested customisations) but found they were not simple to simply "set and forget". I'd have to invoke them for each search. (I just emigrated to Australia from the US and still wish to frequently search US based info, services, addresses, etc.)

I'm actually looking to somehow reinstate FF3 to what I had some 2 weeks ago, where I simply clicked on my Home Page with it's embedded Google USA address. Just like I still can with IE7!

Do I have to reinstall FF3 or FF4 beta to make it happen?? Or do I switch to the dreaded IE tool?

more options

I know of no "set and forget" way of doing what you are trying to accomplish. Maybe someone else will come along with other ideas.

Have you updated your version of Adobe Shockwave Flash as I suggested in my first post? You really need to do that for security reasons.

more options

Isisombululo Esikhethiwe

more options

COR--EL, Thanks, your suggestion solved my problem.

Notwithstanding, I'd really like to know (preferably from a google rep - fat chance) what caused the change - making my searches default to Australian google.com.au, and why the Home Page function is inoperative? If my IE7 still defaults correctly, then the problem is with FF3 ?????

Thanks to ALL who tried to help, Andrew.C

more options

Did you check http://www.google.com/support/websearch/bin/answer.py?answer=873 ?

A possibility is that you have corrupted cookies if it suddenly changed.

You can go to the Google international page via htp://ww.google.com/ncr
Google stores that setting in a cookie on your computer that you need to keep via an allow exception.
If that cookie gets removed then you may have to redo that choice.