Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

facebook directory pictures not showing. IE shows them just fine.

  • 3 uphendule
  • 113 zinale nkinga
  • 234 views
  • Igcine ukuphendulwa ngu howbya

more options

While wall pictures and profile pictures show on my facebook, my friends directory pictures don't. These are the little profile pictures next to the friends names on my face book directory. If I sign up on Internet Explorer and go to my face book they show just fine. Very Frustrating.

This happened

Every time Firefox opened

== Since the begining of using firefox

All Replies (3)

more options

Check the image exceptions: Tools > Options > Content: Load Images: Exceptions - See Settings for web content, pop-ups, fonts, and languages

A way to see which images are blocked is to click the favicon (Site Identification icon) on the left side of the location bar. A click on the "More Information" button will open the Security tab of the "Page Info" window (also accessible via "Tools > Page Info"). Open the Media tab of the "Page Info" window. Select the first image and scroll down though the list with the Down arrow key. If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

See also Fix problems that cause images to not show and http://kb.mozillazine.org/Images_or_animations_do_not_load

more options
  1. On the facebook page where the picture should be showing, right click in the whitespace.
  2. Select "View Page info".
  3. In the window that opens click "Media" at the top.
  4. Click on the first address in the address list. That image should show in the "media preview" (it may be very tiny).
  5. Use the down arrow to check out all the images until you find the one that should be showing.
  6. Once you find it you may notice the "block images from ..." is checked.
  7. Uncheck it and you're problem is solved.

Okulungisiwe ngu howbya

more options
  1. Click "Tools" at the top of Firefox
  2. Click "Options" at the bottom of the menu
  3. Select "Content"
  4. Click "Exceptions" across from "Load Images Automatically"
  5. For me the address that was being blocked was "sphotos.fbcdn.net"
  6. Click the address to select it.
  7. Click "Remove Site" and "Close". Then "OK". Problem solved.