On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Videos dont play on my computer I have a mac osx 10.3.9 and it says unsupportive operating system i must get tiger or leopard

  • 1 baphendule
  • 5 zinale nkinga
  • 4 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

i have mac osx 10.3.9 and i must get tiger 10.4 or later to play videos and other things like links in my e-mail won't open, and other problems

This happened

Every time Firefox opened

i have mac osx 10.3.9 and i must get tiger 10.4 or later to play videos and other things like links in my e-mail won't open, and other problems == This happened == Every time Firefox opened

All Replies (1)